Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Clam update error

  1. #1
    Join Date
    Feb 2011
    Location
    India
    Beans
    321
    Distro
    Ubuntu

    Clam update error

    I get this error when i type sudo freshclam in the terminal

    ERROR: Please edit the example config file /etc/clamav/freshclam.conf
    ERROR: Can't open/parse the config file /etc/clamav/freshclam.conf

  2. #2
    Join Date
    Feb 2011
    Location
    India
    Beans
    321
    Distro
    Ubuntu

    Re: Clam update error

    Anyone please help me.......

  3. #3
    Join Date
    Dec 2010
    Location
    Madison, Wisconsin
    Beans
    163
    Distro
    Ubuntu

    Re: Clam update error

    Type the following

    Code:
    nano /path/to/freshclam.conf
    and make sure Example is commented out.
    Last edited by zhogan85; June 7th, 2012 at 03:44 PM. Reason: Typo in the code, I was thinking one think and typed another

  4. #4
    Join Date
    Feb 2011
    Location
    India
    Beans
    321
    Distro
    Ubuntu

    Re: Clam update error

    Quote Originally Posted by zhogan85 View Post
    Type the following

    Code:
    nano /path/to/freshclam.conf
    and make sure Example is commented out.
    After doing that....when i type sudo freshclam, I get..

    ERROR: Can't create temporary directory /var/lib/clamav/clamav-50a7a5f6dd45550766b7f45b49844073
    Hint: The database directory must be writable for UID 64 or GID 64

  5. #5
    Join Date
    Dec 2010
    Location
    Madison, Wisconsin
    Beans
    163
    Distro
    Ubuntu

    Re: Clam update error

    Try the code below, from the ArchWiki

    Code:
    chown 64:64 /var/lib/clamav & chmod 755 /var/lib/clamav

  6. #6
    Join Date
    Feb 2011
    Location
    India
    Beans
    321
    Distro
    Ubuntu

    Re: Clam update error

    Quote Originally Posted by zhogan85 View Post
    Try the code below, from the ArchWiki

    Code:
    chown 64:64 /var/lib/clamav & chmod 755 /var/lib/clamav
    yes....thanks very much.....it worked.....but can you also tell me how to uptdate the clamav engine and GUI???????

  7. #7
    Join Date
    Dec 2010
    Location
    Madison, Wisconsin
    Beans
    163
    Distro
    Ubuntu

    Re: Clam update error

    You're using Arch right? Then I would think, as long as you update your system regularly they should be up to date.

  8. #8
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Clam update error

    Quote Originally Posted by abnordude View Post
    yes....thanks very much.....it worked.....but can you also tell me how to uptdate the clamav engine and GUI???????
    Have you infact read the wiki?

    If you had did you notice this?
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

  9. #9
    Join Date
    Feb 2011
    Location
    India
    Beans
    321
    Distro
    Ubuntu

    Re: Clam update error

    Quote Originally Posted by zhogan85 View Post
    You're using Arch right? Then I would think, as long as you update your system regularly they should be up to date.

    I'm using arch....i am talking about clamtk.....when i open that i can see that the GUI and the AV Engine is out of date.....I read the wiki (Had not read earlier)....But, in the wiki, I didn't see a method to update the GUI and the Engine.....

    How can I do that?

  10. #10
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Clam update error

    You need to re read it as the answer is in there. It's actually the link I posted.
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •