Results 1 to 6 of 6

Thread: Missing menu bar in wx applications after update

  1. #1
    Join Date
    Feb 2012
    Beans
    16

    Missing menu bar in wx applications after update

    OS: Ubuntu 12.04 LTS

    After updating the OS with apt-get dist-upgrade I discovered that menu bar in wx applications are disappeared.

    While in Unity there are no trouble, in Gnome-Shell and Gnome-Classic sessions the menu bars don't appears anymore.

    I noticed the bug in these applications:

    - Audacity
    - wxMaxima

    The package that has been updated are:

    - libwxbase2.8-0
    - libwxgtk2.8-0
    - unity-lens-video
    - software-center

  2. #2
    Join Date
    Mar 2006
    Beans
    45

    Re: Missing menu bar in wx applications after update

    Hi all,

    I can confirm that behavior. However, for me it does not work neither with Gnome 3 nor with Unity. I had hoped that logging in using Unity would fix the problem.

    That's a pity since it seems that all wx applications are affected and we have some data analysis tool in our lab that rely an python-taits and python-traitsui and the wx interface.

  3. #3
    Join Date
    Jul 2011
    Beans
    38

    Re: Missing menu bar in wx applications after update

    I've got this problem in Kubuntu with XFCE desktop.

    Audacity starts with no menu.
    I can get the menu back in Audacity by pressing Ctr-N , which then starts a new instance with the menu back.

  4. #4
    Join Date
    Dec 2008
    Beans
    5
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Missing menu bar in wx applications after update

    A temporary workaround is switching the gnome theme and the menubar apears again.

    https://bugs.launchpad.net/ubuntu/+s....8/+bug/662077

  5. #5
    Join Date
    Apr 2007
    Beans
    457
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Missing menu bar in wx applications after update

    This bug sucks about as it seems to bring the horrors of Unity to the Gnome Shell. (= personal opinion, not meant to start a flame against Unity)

    Quote Originally Posted by nairboon View Post
    A temporary workaround is switching the gnome theme and the menubar apears again.

    https://bugs.launchpad.net/ubuntu/+s....8/+bug/662077
    Excellent! That works for poEdit, pySVN ( SVN Workbench) and rapidSVN too... Sadly, you have to do this EACH time you open the application but then again, it's a work-around. Thanks for sharing
    PB EasyNote R3450, Ubuntu 11.04 AMD64 // Asus M2400N, Mint 9

    HOW-TO: The Wicd RT2500 solution * XFCE Media buttons

  6. #6
    Join Date
    Sep 2012
    Beans
    2

    Re: Missing menu bar in wx applications after update

    Cool, on kubuntu, I "simply" got rid of the bug with:

    Code:
    sudo apt-get remove appmenu-gtk
    There were no package dependent on this one, so it was really smooth.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •