Results 1 to 6 of 6

Thread: iwlwifi 11n_disable=0 permanent fix

  1. #1
    Join Date
    Aug 2010
    Beans
    6

    iwlwifi 11n_disable=0 permanent fix

    Hi all, I'm a newbie to linux so please bear with me. I've searched and can't find how to make this fix permanent. In summary I can get my wireless to work by entering a couple of lines at the terminal (see below). However I can't figure out how to make this a permanent fix.

    I have 12.04 installed on my laptop (lenovo x220) and couldn't get my wireless to work properly. It would connect to the router and get a valid IP address, but I couldn't ping the router or get any internet access. After searching around I found the issue was that wireless n was disabled. Typing the following in the terminal fixes the issue:
    sudo modprobe iwlwifi -r
    sudo modprobe iwlwifi 11n_disable=0

    Wireless works!

    I then created a file /etc/modprobe.d/iwlwifi.conf and entered the following lines
    options iwlwifi -r
    options iwlwifi 11n_disable=0

    After rebooting the first line seems to work because the wireless is disabled, however it doesn't reconnect. If I then type sudo modprobe iwlwifi 11n_disable=0 in the terminal I get this error:
    FATAL: Error inserting iwlwifi (/lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    It doesn't matter what I name the file, I get the same error. As soon as I delete the file and try that line again at the terminal, wireless works!

    I'm not really sure what I've done wrong...can someone help?

    Cheers,
    Yas

  2. #2
    Join Date
    Feb 2011
    Location
    new york state
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: iwlwifi 11n_disable=0 permanent fix

    Quote Originally Posted by yasitha View Post
    I have 12.04 installed on my laptop (lenovo x220) and couldn't get my wireless to work properly. It would connect to the router and get a valid IP address, but I couldn't ping the router or get any internet access. After searching around I found the issue was that wireless n was disabled. Typing the following in the terminal fixes the issue:
    sudo modprobe iwlwifi -r
    sudo modprobe iwlwifi 11n_disable=0

    Wireless works!
    simple work around would be.

    make script and place in /usr/sbin/
    Code:
    #!/usr/bin/env bash
    sudo modprobe iwlwifi -r
    sudo modprobe iwlwifi 11n_disable=0
    save that ^^ in /usr/sbin as wireless-fix

    open terminal
    Code:
    cd /usr/sbin/
    Code:
    sudo chmod +x wireless-fix
    Code:
    gnome-session-properties
    Click on Add
    name : wireless-fix
    command: /usr/sbin/wireless-fix
    comment: temp fix till I fix upstream

    Click add again




    This will be a temp fix. Next post I will talk about Upstream and fixing the source code its-self
    Attached Images Attached Images
    Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men, even when they exercise influence and not authority

  3. #3
    Join Date
    Feb 2011
    Location
    new york state
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: iwlwifi 11n_disable=0 permanent fix

    can we also see a
    Code:
    cat /etc/modprobe.d/iwlwifi.conf
    if it is not there please find and show us
    Code:
    sudo find / -name "iwlwifi.conf"
    also a
    Code:
    dmesg
    would also help Take out sensitive info plz
    Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men, even when they exercise influence and not authority

  4. #4
    Join Date
    Jan 2011
    Beans
    1,151

    Re: iwlwifi 11n_disable=0 permanent fix

    remove this line
    Code:
     options iwlwifi -r
    it is not necessary since the modules is parsing all the files before they load it

    the options must be defined in
    Code:
    modinfo iwlwifi
    or else it will spit errors
    (\ /)
    (O.o)
    (> <)
    This is Bunny. Copy Bunny into your signature to help him on his way to world domination.

  5. #5
    Join Date
    Aug 2010
    Beans
    6

    Re: iwlwifi 11n_disable=0 permanent fix

    Quote Originally Posted by idoitprone View Post
    remove this line
    Code:
     options iwlwifi -r
    it is not necessary since the modules is parsing all the files before they load it
    Looks like that was the issue, removed that line from the .conf file and it works fine.

    Thanks all for your help!

    Yas

  6. #6
    Join Date
    Aug 2010
    Beans
    6

    Re: iwlwifi 11n_disable=0 permanent fix

    An update on this.

    I don't think this issue had anything to do with wireless n being disabled (at least not directly). It turns out that booting my laptop without it being plugged in causes the problem.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •