Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Inconsistent wifi

  1. #1
    Join Date
    Sep 2013
    Beans
    21

    Inconsistent wifi

    --- 192.168.1.1 ping statistics ---20 packets transmitted, 12 received, 40% packet loss, time 19073ms
    rtt min/avg/max/mdev = 318.882/806.300/1320.009/313.207 ms, pipe 2

    I have a very inconsistent wifi. My most recent ping is above. This is a desktop with Ubuntu 13.10. I was having wifi problems with a card, so I switched it out for another one. It worked fine for a while, but now I'm having these problems again.

    This is my wireless card.

    Any help would be great!

  2. #2
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Inconsistent wifi

    Please confirm the exact details of your card:
    Code:
    lspci -nn | grep 0280
    And is the driver I suspect loaded now?
    Code:
    lsmod | grep rt2
    If so, are there any interesting clues here?
    Code:
    dmesg | grep rt2
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Sep 2013
    Beans
    21

    Re: Inconsistent wifi

    Here goes:
    lspci -nn | grep 0280
    04:00.0 Network controller [0280]: Ralink corp. Device [1814:5392]

    $ lsmod | grep rt2
    rt2800pci 18690 0
    rt2800lib 79963 1 rt2800pci
    rt2x00pci 13287 1 rt2800pci
    rt2x00mmio 13603 1 rt2800pci
    rt2x00lib 55238 4 rt2x00pci,rt2800lib,rt2800pci,rt2x00mmio
    mac80211 596969 3 rt2x00lib,rt2x00pci,rt2800lib
    cfg80211 479757 2 mac80211,rt2x00lib
    eeprom_93cx6 13344 1 rt2800pci
    crc_ccitt 12707 1 rt2800lib


    dmesg | grep rt2
    [ 10.683159] rt2800pci 0000:04:00.0: enabling device (0000 -> 0002)
    [ 10.683672] rt2800pci 0000:04:00.0: irq 60 for MSI/MSI-X
    [ 10.683718] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5392, rev 0223 detected
    [ 10.687392] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 5392 detected
    [ 11.199701] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2860.bin'
    [ 11.200034] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.34







  4. #4
    Join Date
    Sep 2013
    Beans
    21

    Re: Inconsistent wifi

    Here's the output from the wifi script varun suggested for me. http://paste.ubuntu.com/6559829/

  5. #5
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,920
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Inconsistent wifi

    I would wait for Dr. chili's advice, but I think in the meanwhile you may try disabling N-channel in the router (it will reduce the connection speed to 54 Mbps, but may help stability). It is easy to revert back if didn't help.

    If the router's settings provide the option to set the band, try setting it to g-only or b/g only mode. It currently seems to be in b/g/n mode. Save the settings and reboot both the router and your computer to make sure the change properly takes effect.

    Oh, and before trying above, even easier to try is the "nohwcrypt" parameter. In a terminal, please do -
    Code:
    sudo modprobe -rv rt2800pci
    sudo modprobe -v rt2800pci nohwcrypt=Y
    This will be a temporary change that will be lost at next boot or after an unload --> reload of the driver without the parameter. You may try this before or after (with or without) the change suggested about the router.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  6. #6
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Inconsistent wifi

    Awesome suggestions, Varun! Pretty much exactly what I'd suggest. I did notice this:
    # PCI device 0x168c:/sys/devices/pci0000:00/0000:00:1c.6/0000:06:00.0/0000:07:00.0 (ath9k)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    Did you remove and replace an internal Atheros wireless device? Is ath9k loading?
    Code:
    lsmod | grep ath
    Are there any interesting clues here?
    Code:
    cat /var/log/syslog | grep -i dns | tail -n10
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Sep 2013
    Beans
    21

    Re: Inconsistent wifi

    This is the card I had in before. You guys helped me and it worked for a while, but then it broke enough times that I got fed up, so I replaced it.

    No results from
    lsmod | grep ath
    Then I tried
    $ cat /var/log/syslog | grep -i dns | tail -n10
    Dec 12 15:15:24 fornax avahi-daemon[626]: Joining mDNS multicast group on interface wlan1.IPv6 with address fd09:a47d:7a29:0:1919:fc90:27a4:27f0.
    Dec 12 15:15:25 fornax avahi-daemon[626]: Joining mDNS multicast group on interface wlan1.IPv4 with address 192.168.1.122.
    Dec 12 15:15:25 fornax avahi-daemon[626]: New relevant interface wlan1.IPv4 for mDNS.
    Dec 12 15:15:25 fornax NetworkManager[890]: <info> Policy set 'kahnboche 1' (wlan1) as default for IPv4 routing and DNS.
    Dec 12 15:15:25 fornax NetworkManager[890]: <info> Writing DNS information to /sbin/resolvconf
    Dec 12 15:15:25 fornax dnsmasq[2762]: setting upstream servers from DBus
    Dec 12 15:15:25 fornax dnsmasq[2762]: using nameserver 192.168.1.1#53
    Dec 12 15:15:25 fornax dnsmasq[2762]: using nameserver 209.18.47.62#53
    Dec 12 15:15:25 fornax dnsmasq[2762]: using nameserver 209.18.47.61#53
    Dec 12 15:15:26 fornax NetworkManager[890]: <info> Policy set 'kahnboche 1' (wlan1) as default for IPv6 routing and DNS.

    Part of the difficulty with this problem is that the connection isn't usually broken -- it's just inconsistent (breaks maybe 4-5 times per day). So it's not immediately obvious if I've fixed something.

    One aspect is: when it breaks, if I just click reconnect to the network (in the wifi-indicator dropdown menu), it works again.

    I'll try varun's suggestion and see what happens:
    sudo modprobe -rv rt2800pci
    sudo modprobe -v rt2800pci nohwcrypt=Y
    If I "Suspend" the computer, will I revert the settings?

  8. #8
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Inconsistent wifi

    Quote Originally Posted by HJQG3wT View Post
    If I "Suspend" the computer, will I revert the settings?
    No, but if you reboot it will. If it helps, we can write a file to make it persistent.

    Your syslog looks fine; no clues there.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #9
    Join Date
    Sep 2013
    Beans
    21

    Re: Inconsistent wifi

    I ran varun's modprobes. What exactly do they do?

    I also changed my wifi to 802.11G.

    The connection is still inconsistent. What's next?

  10. #10
    Join Date
    Sep 2005
    Beans
    1,605
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Inconsistent wifi

    Try this:
    Code:
    sudo iw dev wlan0 get power_save
    If it says on run:

    Code:
    sudo iw dev wlan0 set power_save off

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •