Page 8 of 9 FirstFirst ... 6789 LastLast
Results 71 to 80 of 90

Thread: fglrx with kernel 3.4 and 3.5

  1. #71
    Join Date
    Jan 2011
    Location
    UK
    Beans
    55
    Distro
    Ubuntu

    Re: fglrx with kernel 3.4 and 3.5

    Quote Originally Posted by jfernyhough View Post
    I tried upgrading to xserver 1.13. Not working, as expected.

    I had to go through Launchpad and manually select debs to get X running again. I've bundled them together in case it's useful for someone else:

    https://dl.dropbox.com/u/172275/xorg...2.amd64.tar.xz

    Just extract somewhere and
    $ sudo dpkg -i *.deb
    Exemplary assistance. I was debating waiting until an xserver 1.13 compatible version for my Mobility Radeon 4200 HD card but i guess i could downgrade for now and get the power management perks that come with fglrx.

    I've tried all manner of things like disabling kernel modesetting, creating an xorg.conf with ClockGating and ForceLowPowerMode, to no avail. Idle, the radeon module is great but it loves creeping up about 20 degrees whereas fglrx stays consistently around 55 degrees. Shame really, because that's the only real issue i have with the open source driver; it looks great visually.

    Do you know what the situation is going to be for pre-5000 cards: are the repos going to contain an 'fglrx' package and something like 'fglrx-legacy' for the 'legacy' (ha!) cards?
    Disco ut intelligam. I learn, so that i may understand.

    Please direct translation related work messages and queries over to my page on launchpad. https://launchpad.net/~untaintableangel
    ...and happy typing!

  2. #72
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    New fglrx packages from Alberto Milone: https://launchpad.net/ubuntu/quantal...9.000-0ubuntu1

    The second bullet-point of the changelog is tantalising...

    Must try 1.13 again.

    Code:
    * New upstream release (LP: #1032672).
      * debian/dkms.conf.in:
        - Do not apply any kernel patch.
      * debian/rules:
        - Make it possible to set the xserver ABIs in debian/substvars.
      * Merge fixes from the upstream installer:
        - Fix openCL issues running x86 binaries on x86_64.
        - Make sure that dh_shlibdeps doesn't complain about missing qt
          libraries.
    Do you know what the situation is going to be for pre-5000 cards: are the repos going to contain an 'fglrx' package and something like 'fglrx-legacy' for the 'legacy' (ha!) cards?
    I don't know; I assume something similar to the Nvidia system would be adopted with an fglrx-current and fglrx-legacy.

    Exemplary assistance.
    I may call on you to support an Ubuntu membership application next time I apply.

    --edit
    Just got an email from Launchpad, this update fixes bug 1032672 ("fglrx-updates broken dependency with xorg-video-abi-12"): https://bugs.launchpad.net/bugs/1032672

    This is looking good.

    --edit 2
    Arg, package builds in one hour. Well, I guess I'll try to build it from the source.

    --edit 3
    Hmm, pbuilder made that easier than builds I've done before. I like it. 8 minutes to official build, but I want to try my own build.

    --edit 4
    Success! xserver 1.13 running!

    amd64 packages are built, so have at it! https://launchpad.net/ubuntu/+source...+build/3860478
    i386 are coming in 45 mins: https://launchpad.net/ubuntu/+source...+build/3860479
    Last edited by jfernyhough; September 28th, 2012 at 12:42 AM.
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  3. #73
    Join Date
    Jan 2011
    Location
    UK
    Beans
    55
    Distro
    Ubuntu

    Smile Re: fglrx with kernel 3.4 and 3.5

    Well aren't you bursting with life? XD

    Excellent! Love to see progress trickling down from upstream

    Now before i go getting too pleased - would i be right in thinking that fglrx 9.000-0ubuntu1 is not going to work for pre-5000 gpus? Is amd planning on releasing a separate fglrx legacy with xserver 1.13 compatibility, or can i run this new version?

    OR is this new revision to the code "- Make it possible to set the xserver ABIs in debian/substvars." (and others of course, this one being paramount to dependency corrections) to be carried over into the legacy version, and all we pre-5000 users have to do is simply wait until this has been done shortly?
    Disco ut intelligam. I learn, so that i may understand.

    Please direct translation related work messages and queries over to my page on launchpad. https://launchpad.net/~untaintableangel
    ...and happy typing!

  4. #74
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    As far as i know fglrx 9.00 doesn't work with pre-HD5000 cards. I'm not sure what AMDs plans are, there's not been anything recently from Andrew D (https://twitter.com/CatalystCreator/) except notifying about the latest legacy release for Windows 8 which is still based on the 12.6 legacy beta...
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  5. #75
    Join Date
    Oct 2011
    Beans
    12

    Re: fglrx with kernel 3.4 and 3.5

    Quote Originally Posted by jfernyhough View Post
    As far as i know fglrx 9.00 doesn't work with pre-HD5000 cards. I'm not sure what AMDs plans are, there's not been anything recently from Andrew D (https://twitter.com/CatalystCreator/) except notifying about the latest legacy release for Windows 8 which is still based on the 12.6 legacy beta...
    Hi, sorry for my newb question, but so, this new driver supposed to don't work on a Mobility HD 4650?
    Thanks

  6. #76
    Join Date
    Jan 2011
    Location
    UK
    Beans
    55
    Distro
    Ubuntu

    Re: fglrx with kernel 3.4 and 3.5

    Quote Originally Posted by erickwill View Post
    Hi, sorry for my newb question, but so, this new driver supposed to don't work on a Mobility HD 4650?
    Thanks

    I'm afraid this new version doesn't work on pre-HD5000 gpus (i tested it quickly to be absolutely sure), sorry Does that mean a legacy version will be released by amd soon? who knows. We need x 1.13 support (and kernel 3.5 support of course) in the next legacy module or we'll have to make do as is.

    Anyone know when the next legacy driver is due? Some time in october? Hopefully before prime time for ubuntu 12.10
    Disco ut intelligam. I learn, so that i may understand.

    Please direct translation related work messages and queries over to my page on launchpad. https://launchpad.net/~untaintableangel
    ...and happy typing!

  7. #77
    Join Date
    Oct 2008
    Beans
    308

    Re: fglrx with kernel 3.4 and 3.5

    I have installed the new driver. It is working fine.

    but catalyst does not work. When I type
    amdcccle

    Nothing happens.

    Any ideas why

    Thanks

  8. #78
    Join Date
    Mar 2009
    Beans
    12

    Re: fglrx with kernel 3.4 and 3.5

    Is there support for xserver 1.13? I don't think so.
    Drivers are suitable for the Ubuntu 12.10 and kernel but not to the newest xserver...
    Last edited by luk1don; September 29th, 2012 at 09:10 AM.

  9. #79
    Join Date
    Mar 2009
    Beans
    12

    Re: fglrx with kernel 3.4 and 3.5

    NVIDIA drivers support X.org 1.13...

  10. #80
    Join Date
    Mar 2009
    Beans
    12

    Re: fglrx with kernel 3.4 and 3.5

    OK. I take that back
    Drivers from Quantal repositories works like a charm and looks like supports xserver version.

Page 8 of 9 FirstFirst ... 6789 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •