Page 7 of 9 FirstFirst ... 56789 LastLast
Results 61 to 70 of 90

Thread: fglrx with kernel 3.4 and 3.5

  1. #61
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: fglrx with kernel 3.4 and 3.5

    Quote Originally Posted by ashwinrao View Post
    Got the desired resolutions using xorg.conf file with Vesa driver. However, I'm still wondering whether any chance of getting proprietary AMD drivers with 12.10 for Radeon HD 4250 in future?
    For several years AMD/ATI has made sure that the xx.4 and xx.10 drivers have worked for Ubuntu and made them available for Canonical to get them in the repo about the time of the RC. As one writer put it, you can bet AMD will do whatever they need to do to meet Ubuntu's needs.

    I hope it continues and we can expect Catalyst 12.10 to work just fine. We wouldn't want AMD to deprive Phoronix of their semi-annual article complaining about Ubuntu getting the goods before anyone else!
    Last edited by QIII; September 11th, 2012 at 01:00 AM.
    The Community Java Wiki * The Community ATI Driver Wiki * Find what you need in the Ubuntu Community wikis

    And seeing the terror on the faces of the people, QIII did speak to them, saying "Fear not the Terminal, for it is a road both swift and secure to the Great Mysteries of Linux without passing through the dangers of The Land of Ten Thousand Competing Desktop Environments."

  2. #62
    Join Date
    Dec 2009
    Location
    Mangalore, India
    Beans
    100
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    Thanks a lot for your clarification. Will wait for the official Ubuntu AMD drivers. 12.10 is additional OS I have installed for testing purpose. The main OS in my machine is 12.04.
    Last edited by ashwinrao; September 14th, 2012 at 08:08 PM.

  3. #63
    Join Date
    Apr 2012
    Beans
    30

    radeon 4250

    add me to the list of radeon 4250ers with no 3d graphics capibility: ( its a shame cuz there are lots and lots of great active desktops out there for ubunto 12.04 lts.

    the radeon 4200 series is listed as compatible in the open source support but I don't know how to install the open source PPA driver

    does anyone have the steps??? ... instructions i read are killing me.

    I am new to PPA drivers. unless someone has a depository way?really would like to blow my wifes desktop away with some killer graphics until I can, I will never get her off of a windows machine.

  4. #64
    Join Date
    Jul 2007
    Beans
    44
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: radeon 4250

    Looks like Catalyst 12.9 is out. http://www.phoronix.com/scan.php?pag...tem&px=MTE4NDk

    Has anybody tried it?

  5. #65
    Join Date
    Jul 2006
    Location
    Johannesburg, South Afric
    Beans
    31
    Distro
    Ubuntu

    Re: fglrx with kernel 3.4 and 3.5

    Did not work for me. It is for embedded devices apparently. I am on HD6xxx

  6. #66
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    Before anyone asks: Catalyst 12.9 is not compatible with cards earlier than HD5000.

    If it doesn't work with your (HD5000 or later) hardware try the control file from here: http://catalyst.apocalypsus.net/files/control-12.8/

    and read Arch AUR page here: https://aur.archlinux.org/packages.php?ID=34773

    There is reported support for kernel 3.5 and early 3.6rc, which is nice. No xserver 1.13 support.

    My progress:
    Downloaded installer and built the debs. done
    $ sh ./amd-driver-installer-9.00-x86.x86_64.run --buildpkg Ubuntu/quantal
    Packages generated. done
    Install and DKMS module build. done
    $ sudo dpkg -i *.deb
    Reboot. done

    OK, so it installs, builds, and loads fine for me with xserver 1.12 and kernel 3.5. I have a lovely "Unsupported hardware" watermark but I guess the 12.8 control file will sort that out. Now to download and test kernel 3.6-rc6!

    Rebooted and running successfully with kernel 3.6-rc6, and with the 12.8 control file copied to /etc/ati/control the watermark is gone.

    Success!
    Last edited by jfernyhough; September 17th, 2012 at 02:13 PM.
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  7. #67
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    Catalyst 12.9 beta is out:
    http://www2.ati.com/drivers/beta/amd...x86.x86_64.zip

    Downloading now.

    Packages build, install, DKMS look fine as for the embedded release. Let's see if a reboot leads to a watermark...

    --edit
    Nope, watermark is back. Same procedure to fix, copy across the 12.8 control file.
    Last edited by jfernyhough; September 26th, 2012 at 07:39 PM.
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  8. #68
    Join Date
    Oct 2008
    Beans
    308

    Re: fglrx with kernel 3.4 and 3.5

    Quote Originally Posted by jfernyhough View Post
    Catalyst 12.9 beta is out:
    http://www2.ati.com/drivers/beta/amd...x86.x86_64.zip

    Downloading now.
    Is this compatible with ubuntu 12.10 ?

    The one in the ppa and the repo is'nt

  9. #69
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    I doubt it. It has the same number (9.000) as the embedded release. For full support we'll probably have to wait for Catalyst 12.10 around the release date of Quantal.

    --edit
    I thought that perhaps the embedded and beta releases might be the same so I checked the md5sum for each:

    e643cad1cb458e8bb179cc837d7cd513 amd-driver-installer-9.00-x86.x86_64.run
    7754c50a19e8402b5863d2061bae5482 amd-driver-installer-12-9-beta-x86.x86_64.run

    Different, so probably some minor changes.

    --edit 2
    Just three files changed in /etc/ati to support more GPUs [1]:
    amdpcsdb.default control signature

    --edit 3
    Changelog:
    http://support.amd.com/us/kbarticles...etadriver.aspx
    Last edited by jfernyhough; September 26th, 2012 at 08:54 PM.
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  10. #70
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    I tried upgrading to xserver 1.13. Not working, as expected.

    I had to go through Launchpad and manually select debs to get X running again. I've bundled them together in case it's useful for someone else:

    https://dl.dropbox.com/u/172275/xorg...2.amd64.tar.xz

    Just extract somewhere and
    $ sudo dpkg -i *.deb
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

Page 7 of 9 FirstFirst ... 56789 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •