Page 4 of 9 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 90

Thread: fglrx with kernel 3.4 and 3.5

  1. #31
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4

    Quote Originally Posted by PelPix View Post
    Still crashing when xorg starts on Xubuntu
    It will do if you're running xserver 1.12. It's a known issue (possibly something to do with libpciaccess on Debian judging by the reports on http://ati.cchtml.com/show_bug.cgi?id=522).

    Workround is to go back to 1.11 for now - or move to Arch!
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  2. #32
    Join Date
    Apr 2011
    Beans
    13

    Re: fglrx with kernel 3.4

    Quote Originally Posted by jfernyhough View Post
    OK, so until we're able to edit posts new details are here.

    .
    .
    .

    3) Build the packages (this will place the packages in the parent directory):
    $ ./ati-installer.sh 8.980 --buildpkg Ubuntu/quantal

    4) Change to the parent directory and install the debs:
    $ cd ..
    $ sudo dpkg -i *.deb
    I got an error in step 3
    Code:
    # empty ld.so.conf for the fake multi-arch alternative for PXpress
    echo "" > "/tmp/fglrx.6oPJEn/debian/fglrx/usr/lib/pxpress/alt_ld.so.conf"
    # Generate modaliases
    sh -e debian/modaliases/fglrx_supported \
                    lib/modules/fglrx/build_mod/fglrxko_pci_ids.h fglrx fglrx > \
                    debian/fglrx.modaliases
    dh_modaliases
    rm debian/fglrx.modaliases
    #Run the normal stuff
    dh binary-arch
       dh_auto_install -a -Nfglrx -Nfglrx-amdcccle
       dh_install -a -Nfglrx -Nfglrx-amdcccle
       dh_installdocs -a -Nfglrx
       dh_installchangelogs -a -Nfglrx
       dh_installexamples -a -Nfglrx
       dh_installman -a -Nfglrx
       dh_installcatalogs -a -Nfglrx
       dh_installcron -a -Nfglrx
       dh_installdebconf -a -Nfglrx
       dh_installemacsen -a -Nfglrx
       dh_installifupdown -a -Nfglrx
       dh_installinfo -a -Nfglrx
       dh_pysupport -a -Nfglrx
    dh_pysupport: This program is deprecated, you should use dh_python2 instead. Migration guide: http://deb.li/dhs2p
       dh_installinit -a -Nfglrx
       dh_installmenu -a -Nfglrx
       dh_installmime -a -Nfglrx
       dh_installmodules -a -Nfglrx
       dh_installlogcheck -a -Nfglrx
       dh_installlogrotate -a -Nfglrx
       dh_installpam -a -Nfglrx
       dh_installppp -a -Nfglrx
       dh_installudev -a -Nfglrx
       dh_installwm -a -Nfglrx
       dh_installxfonts -a -Nfglrx
       dh_installgsettings -a -Nfglrx
       dh_bugfiles -a -Nfglrx
       dh_ucf -a -Nfglrx
       dh_lintian -a -Nfglrx
       dh_gconf -a -Nfglrx
       dh_icons -a -Nfglrx
       dh_perl -a -Nfglrx
       dh_usrlocal -a -Nfglrx
       dh_link -a -Nfglrx
       dh_compress -a
       dh_fixperms -a
       dh_strip -a
       dh_makeshlibs -a
    objdump: debian/fglrx/usr/lib/pxpress/ld.so.conf: File format not recognized
    objdump: debian/fglrx/usr/lib/pxpress/alt_ld.so.conf: File truncated
    objdump: debian/fglrx/usr/lib/fglrx/ld.so.conf: File format not recognized
    objdump: debian/fglrx/usr/lib/fglrx/alt_ld.so.conf: File truncated
       debian/rules override_dh_shlibdeps
    make[1]: Entering directory `/tmp/fglrx.6oPJEn'
    dh_shlibdeps -l/tmp/fglrx.6oPJEn/debian/fglrx/usr/lib/fglrx:/tmp/fglrx.6oPJEn/debian/fglrx/usr/lib32/fglrx -Xlib32
    dpkg-shlibdeps: warning: debian/fglrx/usr/lib/fglrx/libAMDXvBA.so.1.0 contains an unresolvable reference to symbol dlsym: it's probably a plugin
    dpkg-shlibdeps: warning: 21 other similar warnings have been skipped (use -v to see them all)
    dpkg-shlibdeps: warning: debian/fglrx/usr/lib/fglrx/bin/atieventsd contains an unresolvable reference to symbol XauFileName: it's probably a plugin
    dpkg-shlibdeps: warning: debian/fglrx/usr/lib/fglrx/libGL.so.1.2 contains an unresolvable reference to symbol XOpenDisplay: it's probably a plugin
    dpkg-shlibdeps: warning: 31 other similar warnings have been skipped (use -v to see them all)
    dpkg-shlibdeps: error: no dependency information found for /usr/share/ati/lib64/libQtCore.so.4 (used by debian/fglrx/usr/lib/fglrx/bin/amdnotifyui)
    dh_shlibdeps: dpkg-shlibdeps -Tdebian/fglrx.substvars debian/fglrx/usr/lib/fglrx/libAMDXvBA.so.1.0 debian/fglrx/usr/lib/fglrx/bin/fglrxinfo debian/fglrx/usr/lib/fglrx/bin/aticonfig debian/fglrx/usr/lib/fglrx/bin/atiodcli debian/fglrx/usr/lib/fglrx/bin/fgl_glxgears debian/fglrx/usr/lib/fglrx/bin/amdnotifyui debian/fglrx/usr/lib/fglrx/bin/atieventsd debian/fglrx/usr/lib/fglrx/bin/atiode debian/fglrx/usr/lib/fglrx/libamdocl64.so debian/fglrx/usr/lib/fglrx/libatiadlxx.so debian/fglrx/usr/lib/fglrx/libaticalrt.so debian/fglrx/usr/lib/fglrx/libSlotMaximizerAg.so debian/fglrx/usr/lib/fglrx/libGL.so.1.2 debian/fglrx/usr/lib/fglrx/libfglrx_dm.so.1.0 debian/fglrx/usr/lib/fglrx/libXvBAW.so.1.0 debian/fglrx/usr/lib/fglrx/dri/fglrx_dri.so debian/fglrx/usr/lib/fglrx/libaticalcl.so debian/fglrx/usr/lib/fglrx/libSlotMaximizerBe.so debian/fglrx/usr/lib/fglrx/libaticaldd.so debian/fglrx/usr/lib/fglrx/libatiuki.so.1.0 debian/fglrx/usr/lib/fglrx/libOpenCL.so.1 debian/fglrx/usr/lib/fglrx/xorg/modules/glesx.so debian/fglrx/usr/lib/fglrx/xorg/modules/extensions/libglx.so debian/fglrx/usr/lib/fglrx/xorg/modules/amdxmm.so debian/fglrx/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so debian/fglrx/usr/lib/fglrx/xorg/modules/linux/libfglrxdrm.so returned exit code 2
    make[1]: *** [override_dh_shlibdeps] Error 2
    make[1]: Leaving directory `/tmp/fglrx.6oPJEn'
    make: *** [binary-arch] Error 2
    dpkg-buildpackage: error: debian/rules binary gave error exit status 2
    Xorg 1.12, i cant force version in synaptic, how will i downgrade?
    Last edited by AIPHEE; July 11th, 2012 at 01:08 PM.

  3. #33
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4

    Quote Originally Posted by AIPHEE View Post
    I got an error in step 3
    What card do you have?
    [Xorg 1.12, i cant force version in synaptic, how will i downgrade?
    Get xserver-xorg and xserver-common from Launchpad, e.g.:
    https://launchpad.net/ubuntu/quantal...11.4-0ubuntu11
    https://launchpad.net/ubuntu/+source...11.4-0ubuntu11

    Install manually ($ sudo dpkg -i ), you may end up removing other drivers (video, input); this didn't make much of a difference to me. If in doubt just use the open-source radeon driver (e.g. move your /etx/X11/xorg.conf out of the way, or delete it).
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  4. #34
    Join Date
    Apr 2011
    Beans
    13

    Re: fglrx with kernel 3.4 and 3.5

    Well, only think i had from that downgrade is dpkg brakege. Im using OS drivers now, but AFAIK they cant downclock and i would like to play HoN and Zero-k sometimes (also psychonauts are in front of me). Well, i guess ill just wait for official drivers and will be switching to Win for games.

  5. #35
    Join Date
    Mar 2010
    Location
    Germany
    Beans
    32
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: fglrx with kernel 3.4 and 3.5

    The patch works for me for Kernel 3.5 but I have another problem. When I create and install the debs from the ati......run file everything works fine but Unity 3D is gone. I always just get Unity 2D. When I use fglrx 8.960 from the repository (which does not support Kernel 3.5) Unity is working in 3D mode. Is there any ways for me to fix this? What is the great difference between the debs from the repository and the ones created out of the .run file? Btw I use Ubuntu 12.04 but I need 27 more posts before I can change my details.
    Last edited by cYbercOsmOnauT; July 23rd, 2012 at 11:43 PM.

  6. #36
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    Need a bit more info. What card do you have? (You need a different driver if you have a Radeon 2000, 3000, or 4000-series card.)
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  7. #37
    Join Date
    Mar 2010
    Location
    Germany
    Beans
    32
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: fglrx with kernel 3.4 and 3.5

    Sure
    Code:
    tekin@Ubuntu-Studio:~$ fglrxinfo 
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: ATI Mobility Radeon HD 4500 Series
    OpenGL version string: 3.3.11627 Compatibility Profile Context

  8. #38
    Join Date
    Mar 2010
    Location
    Germany
    Beans
    32
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: fglrx with kernel 3.4 and 3.5

    AFAIK the 4500 series are supported and not inside the legacy support.

  9. #39
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: fglrx with kernel 3.4 and 3.5

    Quote Originally Posted by cYbercOsmOnauT View Post
    AFAIK the 4500 series are supported and not inside the legacy support.
    You need the legacy driver for 12.6 and up: http://support.amd.com/us/kbarticles...yproducts.aspx

    The kernel 3.5 patch should still work, but I haven't tried it with the legacy driver.
    Last edited by jfernyhough; July 24th, 2012 at 01:42 AM. Reason: for 12.6 and up
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  10. #40
    Join Date
    Mar 2010
    Location
    Germany
    Beans
    32
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: fglrx with kernel 3.4 and 3.5

    Quote Originally Posted by jfernyhough View Post
    You need the legacy driver for 12.6 and up: http://support.amd.com/us/kbarticles...yproducts.aspx

    The kernel 3.5 patch should still work, but I haven't tried it with the legacy driver.
    I already tried the normal driver. Everything works fine. Just Unity doesn't allow 3D mode.
    But okay. Let me try out the legacy one. If that one also doesn't work I will need to stay at the fglrx from the repository and Kernel 3.3.x :'(

Page 4 of 9 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •