It doesn't seem as though the patch for 8.960 to add kernel 3.5 support works correctly - at least for me, either with 8.960 from the repo or manually patching 8.980. Having to go back to 3.4 (liquorix) for now.