Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Ubuntu started in chinese (pinyin)

  1. #1
    Join Date
    Mar 2006
    Beans
    46

    Angry locale issue - Ubuntu started in chinese (pinyin)

    Hi,

    I booted my ubuntu 12.04 today and the whole interface changed to chinese (pinyin apparently...)
    I didn't change it on purpose and I can't find a way to go back to the default english... Could someone help me ?

    Here are some screenshots of my system now:

    -Upon login I'm greeted with a prompt window to change all my folder names:

    It says "you have logged in to a new language" is this some option from the login screen ??

    -I tried to go to the Language configuration (the blue icon) but when I select 'English' and click the first button below (which should be 'apply system wide' nothing changes.


    -On the second tab of the language configuration, the selected language is also English(U.S)



    I really do not understand how the system language could change like that as I did not do it on purpose...
    How can I switch back ?

    Thanks
    Last edited by MasterZ; May 24th, 2012 at 06:22 PM. Reason: made a better title

  2. #2
    Join Date
    Mar 2006
    Beans
    46

    Re: Ubuntu started in chinese (pinyin)

    I still can't find a way to change the language.

    I've seen that something had changed my /etc/default/locale settings to zh_CN; so I changed that manually:
    Code:
    $ cat /etc/default/locale 
    LANG=en_GB.UTF-8
    LANGUAGE="en_GB.utf8:en"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_MONETARY="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    Same thing for /etc/environment I changed it back too:
    Code:
    $ cat /etc/environment 
    PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
    LANGUAGE="en_GB.UTF-8:en"
    LANG="en_GB.UTF-8"
    LC_NUMERIC="en_GB.UTF-8"
    LC_TIME="en_GB.UTF-8"
    LC_MONETARY="en_GB.UTF-8"
    LC_PAPER="en_GB.UTF-8"
    LC_IDENTIFICATION="en_GB.UTF-8"
    LC_NAME="en_GB.UTF-8"
    LC_ADDRESS="en_GB.UTF-8"
    LC_TELEPHONE="en_GB.UTF-8"
    LC_MEASUREMENT="en_GB.UTF-8"
    Still after a reboot my X session continues to displays system messages and other stuff in chinese...

    I do not know where this setting comes from, but when I check my session locale from a terminal I get:
    Code:
    $ locale
    LANG=zh_CN.UTF-8
    LANGUAGE=zh_CN:en
    LC_CTYPE="zh_CN.UTF-8"
    LC_NUMERIC=en_GB.UTF-8
    LC_TIME=en_GB.UTF-8
    LC_COLLATE="zh_CN.UTF-8"
    LC_MONETARY=en_GB.UTF-8
    LC_MESSAGES="zh_CN.UTF-8"
    LC_PAPER=en_GB.UTF-8
    LC_NAME=en_GB.UTF-8
    LC_ADDRESS=en_GB.UTF-8
    LC_TELEPHONE=en_GB.UTF-8
    LC_MEASUREMENT=en_GB.UTF-8
    LC_IDENTIFICATION=en_GB.UTF-8
    LC_ALL=
    The only thing I can do now is try to backup and delete all the contents of my Homedir and pray that it goes back to normal... Otherwise I'll have to reinstall the whole system.

    or if anybody has an idea ?

  3. #3
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,630

    Re: Ubuntu started in chinese (pinyin)

    did you try
    Code:
    sudo dpkg-reconfigure locales
    and a reboot?

  4. #4
    Join Date
    Mar 2006
    Beans
    46

    Re: Ubuntu started in chinese (pinyin)

    Hi,

    Yes I tried that, I had a message about all en_* locales being up to date but it did not change anything.

    I removed ALL files and directories from my home dir and now I'm back to english.
    I will copy back my important files in the home dir and redo the compiz configurations and all that stuff manually.

    Something had changed my files in /etc that's for sure, so it must be something I installed, because this requires root privileges...
    Everything I installed came from the repositories, except for actkbd, a keyboard mapping driver, which I had to compile and make install...

    I'll still try to track whatever did this and report my findings here, if any.

    I hope it won't happen again though...

  5. #5
    Join Date
    Nov 2008
    Location
    Milky Way
    Beans
    141
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu started in chinese (pinyin)

    From the language configuration screen, drag English to the top of the list, then click Apply System Wide. I think this is how you reset the language.

    P.S., though not relevant, I think I see simplified chinese characters, not pinyin !
    Common sense is the collection of prejudices acquired by age eighteen.
    -Albert Einstein

  6. #6
    Join Date
    Aug 2012
    Beans
    1

    Re: Ubuntu started in chinese (pinyin)

    Hi guys,

    I had the same bug. I went to ~/.pam_environment file and changed this two variables:
    LANGUAGE="en_GB:en"
    LANG="en_GB.UTF-8"
    And everything went back to normal.

    Hope that helps

  7. #7
    Join Date
    Aug 2010
    Beans
    212
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu started in chinese (pinyin)

    I had the same problem, but it was resolved using the system settings panel. Of course it was rather challenging to figure out which panel to use, since the name was in CHINESE...

    I am simply gobsmacked that anything in a modern OS would (expletive deleted) up the user's language preference with no action from the user, and no warning. Has this been logged as a bug?

    Seriously, what's up? If it happened only to me, I'd just chalk it up as a fluke. But it happened to me once in 10.04, once in 12.04 and I'm stunned to see other people are affected too.

  8. #8
    Join Date
    Sep 2007
    Location
    Milwaukee, WI
    Beans
    268
    Distro
    Ubuntu Development Release

    Re: Ubuntu started in chinese (pinyin)

    I just ran into this problem. I hadn't even installed anything or updated. I was using my Windows partition, rebooted into Ubuntu and found a lot of Chinese characters.

    Luckily, I stumbled through the language selection dialog and got English back.

    But what's the cause of this? Is there any sort of log of when/how the language got changed in the first place?

  9. #9
    Join Date
    Jul 2009
    Beans
    571
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu started in chinese (pinyin)

    I got this working by launching the System Settings.

    1. Just click on blue flag
    2. Popup window, can't remember what I clicked.
    3. Click on the red circles for your guide.
    4. Finally LOGOUT.

    PS DON'T EVER EVER RENAME YOUR FOLDERS if it prompts you. UNTIL YOU'VE CHANGED Your Language back to ENGLISH, JUST LEAVE IT THERE HANGING.

    Seriously Ubuntu, cmon!
    Attached Images Attached Images
    Last edited by AlexanderDGreat; February 24th, 2013 at 05:24 PM.
    It's OK, everything we know will become obsolete at some time.

  10. #10
    Join Date
    Sep 2007
    Location
    Milwaukee, WI
    Beans
    268
    Distro
    Ubuntu Development Release

    Re: Ubuntu started in chinese (pinyin)

    No one knows the cause of this? It's concerning that something as important as the system language can get changed without user interaction....

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •