Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: courier-imap: authentication failed after a while

  1. #1
    Join Date
    Jul 2009
    Location
    France
    Beans
    37
    Distro
    Ubuntu 12.04 Precise Pangolin

    courier-imap: authentication failed after a while

    Hi,

    Authentication failed for imapd and imapd-ssl after a while for some users, not always the same ones, at different times (between half an hour and few days). My MDA is courier-imap and courier-imap-ssl.

    The logs (mails.log) using thunderbird with ssl:
    Code:
    May 21 17:47:03 clement-desktop imapd-ssl: Connection, ip=[::ffff:192.168.1.11]
    Same using roundcube without ssl:
    Code:
    May 21 17:48:09 clement-desktop imapd: Connection, ip=[::ffff:192.168.1.11]
    Same thing with ssl.

    Roundcube logs:
    Code:
    [23-May-2012 19:38:27 +0200]: IMAP Error: Login failed for ****** from xx.xxx.xxx.xxx. AUTHENTICATE PLAIN:  in /usr/share/roundcube/program/include/rcube_imap.php on line 205 (POST /roundcube/?_task=login&_action=login)
    I tried to restart some service: courier-imap, courier-imap-ssl, courier-authdaemon, saslauthd. But still not working. The only way I found is to reboot the server :/
    I'm not sure, but I think it's since I upgraded from 10.04 to 12.04. Before that, it worked fine.

    Any idea ?
    Thanks

    Edit: This post solved my problem :
    http://ubuntuforums.org/showpost.php...2&postcount=16
    Last edited by clement.analogue; June 12th, 2012 at 12:22 PM.

  2. #2
    Join Date
    Oct 2011
    Beans
    11

    Re: courier-imap: authentication failed after a while

    I have the same issue after updating to 12.04. Tried to restart saslauthd, postfix, courier-imap all of it. Nothing works, only reboot of the server.
    To note is that the users look authenticated in the maillog, only error I can find is in auth.log: postfix/smtpd[13906]: unable to dlopen /usr/lib/sasl2/libsql.so.2: libmysqlclient.so.16: cannot open shared object file: No such file or direct

    Not sure if this is caused by the other bug my installation is suffering from.

  3. #3
    Join Date
    Jul 2009
    Location
    France
    Beans
    37
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: courier-imap: authentication failed after a while

    Nothing happened in the auth.log file.

  4. #4
    Join Date
    Jul 2009
    Location
    France
    Beans
    37
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: courier-imap: authentication failed after a while

    up

  5. #5
    Join Date
    Dec 2009
    Beans
    8
    Distro
    Kubuntu 11.04 Natty Narwhal

    Re: courier-imap: authentication failed after a while

    Been having the same issue. telnet to the imap server simply disconnects when trying to login, eg:

    Code:
    $ telnet localhost imap
    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc.  See COPYING for distribution information. 
    . login user correctpassword
    Connection closed by foreign host.
    For me killing the gam_server process makes me able to connect to the imap server and access my emails.

    See this thread and bugreport
    http://ubuntuforums.org/showthread.php?t=1970712
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/890756

  6. #6
    Join Date
    Jul 2009
    Location
    France
    Beans
    37
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: courier-imap: authentication failed after a while

    I saw the bug and the thread. This post solved my problem :
    http://ubuntuforums.org/showpost.php...2&postcount=16

  7. #7
    Join Date
    Oct 2011
    Beans
    11

    Re: courier-imap: authentication failed after a while

    Hoping for this to solve my problems! Thanks in advance!

  8. #8
    Join Date
    Jan 2005
    Location
    Western Pennsylvania
    Beans
    90
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: courier-imap: authentication failed after a while

    Encountered this problem on a new 12.04 server after moving a configuration over from an old 8.04 server. Troubling and frustrating!
    Colin Dean
    ubuntu on rahab (amd64!), convoy, dartagnan, xubuntu on frog. oubuntu on m8i (openbox+xcompmgr). lfs on vojistilo. dd-wrt on foney, susie, link, tank. trustix on linuxbox.

  9. #9
    Join Date
    May 2009
    Location
    Somerset
    Beans
    22
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: courier-imap: authentication failed after a while

    I had this problem during the Beta.
    please check This post, It seems like the same issue.

    rgds
    J

  10. #10
    Join Date
    Jul 2009
    Location
    France
    Beans
    37
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: courier-imap: authentication failed after a while

    I already solved the problem and the solution is in this thread. I edited the fisrt message to give the link which solved the issue.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •