Page 15 of 16 FirstFirst ... 513141516 LastLast
Results 141 to 150 of 157

Thread: GMA500 (Poulsbo) gma500_gfx

  1. #141
    Join Date
    May 2010
    Beans
    3

    Re: GMA500 (Poulsbo) gma500_gfx

    Quote Originally Posted by mikewhatever View Post
    What do you get from ls /sys/class/backlight/?
    $ ls /sys/class/backlight/
    acpi_video0 psb-bl

    when I manually manipuate psb-bl, it actually changes values!
    Last edited by soapstarjoe; March 31st, 2013 at 12:33 AM.

  2. #142
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: GMA500 (Poulsbo) gma500_gfx

    Great! Try using these scripts, obviously, modified for you particular needs.
    Hope it works.

  3. #143
    Join Date
    Apr 2013
    Beans
    4

    Re: GMA500 (Poulsbo) gma500_gfx

    I think the wiki helps a lot.

  4. #144
    Join Date
    Nov 2007
    Location
    Moscow, Russia
    Beans
    1
    Distro
    Xubuntu 9.04 Jaunty Jackalope

    Re: GMA500 (Poulsbo) gma500_gfx

    Hi guys!

    I'm using GMA500 on a tablet with Ubuntu 12.10 Quantal. Everything is nice except for one little thing — resuming from suspend / hibernate. I'm using "pm-hibernate --quirk-vbemode-restore" for testing. After resuming everything seems to work but the video is totally "trashed". I mean, it's only garbage everywhere (in command line & Xorg). However, I can see blinking cursor in the command line and blindly login, run some commands to see a bit of green garbage ☺

    I've tried all the things I've googled & thought about:
    * fbdev / modesetting driver in /usr/share/X11/xorg.conf.d/20-gpu.conf;
    * xserver-xorg-video-fbdev from Ringtail and from xorg-edgers (however, the problem should be on the kernel level because of being not only in the X, shouldn't it?);
    * all the quirks as pm-hibernate arguments and in /etc/pm/config.d/gma500;
    * edited, moved, removed scripts in /usr/lib/pm-utils/sleep.d (98video-quirk-db-handler, 99video, even tried to add 99remove-annoying-quirks);
    * tried a lot of kernel options in /etc/default/grub (my current GRUB_CMDLINE_LINUX_DEFAULT is "quiet splash mem=1920mb console=tty1 acpi=force"; also tried nomodeset, noacpi, and others);
    * updated kernel to 3.6.3-030603-generic from mainline.

    "Fix suspend" from https://wiki.ubuntu.com/HardwareSupp...eoCardsPoulsbo looks like the common panacea. But not in my case. Any ideas? Thanks a lot in advance!


    P.S.
    # lspci -nnk | grep -iA3 vga
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:4102] (rev 04)
    Subsystem: Intel Corporation Device [8086:4102]
    Kernel driver in use: gma500
    Kernel modules: gma500_gfx

  5. #145
    Join Date
    Apr 2013
    Beans
    1

    Re: GMA500 (Poulsbo) gma500_gfx

    I installed linux mint 14 on my netbook with GMA500 accer. If I choose to use cinnamon performance drops dramatically. Questions: supported the GMA500 (Poulsbo) gma500_gfx for mint 14? or what is more recommendable?

    (Eu instalei o linux mint 14 em meu netbook accer com gma500. Se opto por usar o cinnamon o desempenho cai drasticamente. Perguntas: há suporte no GMA500 (Poulsbo) gma500_gfx para o mint 14? ou o que é mais recomendável?)

  6. #146
    ahallubuntu is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Jul 2005
    Beans
    2,050

    Re: GMA500 (Poulsbo) gma500_gfx

    Quote Originally Posted by mpw View Post
    Hello,

    I tried to use the modesetting-driver to be able to use xrandr. I installed the package from the repo and added the config file.

    But when I reboot, the screen stays black. I use Ubuntu 12.04 on a Sony Vaio X series.
    I had the same problem on an Acer AO751H that has Ubuntu 12.04.1 on it. The Wiki instructions (to use ppaorg-edgers/ppa ) result in a black screen upon reboot. I had to go into recovery mode and remove the modesetting driver and the PPA, then I was able to boot again.

    FYI, I also tried upgrading to 12.04.2 from 12.04.1 and that broke a couple of things. So I am starting over and installing 12.04.2 from scratch. Everything works fine except the trick to make suspend/resume work correctly needs a tweak: the Ubuntu Wiki for Poulsbo/GMA500 says to do this:

    Code:
    gksu gedit /etc/pm/config.d/gma500
    Add in the following code and save the file:
    
    ADD_PARAMETERS='--quirk-vbemode-restore'
    For 12.04.2, you need to remove one of leading dashes for the parameter, so the added line should be:

    ADD_PARAMETERS='-quirk-vbemode-restore'

    otherwise, you'll get a black screen at resume. Remove the one dash and it works great. I figured this out from the ArchLinux Wiki:

    https://wiki.archlinux.org/index.php/Poulsbo

    FYI, modesetting seems to work by default in 12.04.2 . It's a shame I've had to spend hours re-installing 12.04.2 from scratch, though...

  7. #147
    Join Date
    Oct 2007
    Beans
    24
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: GMA500 (Poulsbo) gma500_gfx

    Has anyone tried kernel 3.10 rc2? suspend works perfectly on my Acer Aspire 751h, it wakes up in a second, never worked like that before.

  8. #148
    ahallubuntu is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Jul 2005
    Beans
    2,050

    Re: GMA500 (Poulsbo) gma500_gfx

    I've used Ubuntu 12.04.2 on my AO751h netbook for a couple of weeks full time. It works pretty well except for two things: 1) a very weird freezing bug (see below) and 2) I still can't get hibernation to work reliably. I guess I can live without hibernation, because suspend/resume seems very reliable. With 11.04, resume would not work maybe 1/5 times and I'd have to do a hard shut down to clear it. I suspended/resumed dozens of times in the last few weeks and never needed to do that, even once.

    Now the weird freezing bug: when playing a video or even listening to an mp3 file, I noticed that once in a while, the media would sort of freeze until I hit a key or moved the mouse. It wasn't a complete freeze; the audio would repeat in a 1/2 second loop, endlessly. Very odd. I wasn't even sure how to describe the bug let alone fix it, but it was extremely annoying. Think about watching a movie on an airplane and having to move your mouse every minute (sometimes more often, sometimes less) just to get it the movie to continue playing.

    After some research, I found that this bug is not entirely uncommon. It appears to be related to be related to low power states of the CPU and can happen on different systems. I guess somehow the CPU can get stuck in the lowest power state and nothing happens until something wakes it up. In more advanced systems, you may be able to disable certain power management features in BIOS Setup - but of course, Acer's BIOS options for the AO751h are extremely minimal and no such options are available.

    I found this article - rather, the first answer by Michael Goldshteyn - extremely helpful:

    http://stackoverflow.com/questions/1...-linux-kernels

    It seems that between kernel 3.2 and 3.5, for Intel CPUs, the cpu_idle driver changed from the old one called "acpi_idle" to a newer (better?) driver called "intel_idle." In any event, I never saw this problem on the AO751h with the older kernels, so I decided to revert the older "acpi_idle" - and after doing so - no freezes! The problem was easiest to reproduce simply by playing a video in totem, closing all other windows, running on battery, and disabling the wireless card - and after a half hour of playing I haven't had the video freeze once!

    Anyway, using the link above, here's how I got the kernel to revert to "acpi_idle" in Ubuntu 12.04.2:

    Edit the file /etc/default/grub:

    Code:
    gksu gedit /etc/default/grub
    and find the familiar line "GRUB_CMDLINE_LINUX_DEFAULT" where you've probably already added other options to make the AO751h work properly. To the list of options already there, add this one (separated by a space from the other options on that line):

    Code:
    intel_idle.max_cstate=0
    Save the file, then run:

    Code:
    sudo update-grub
    Then reboot.

    This doesn't actually disable power saving states; according to Michael Goldshteyn, it simply tells the kernel to revert to the old acpi_idle driver. I verified that indeed this is exactly what happens on my AO751h. I don't know what the effect of this change might be on, say, battery life - for all I know, battery life may be even better with the old driver on the AO751h. Who knows? The Atom CPU doesn't consume much power, anyway. I'm willing to live with the same kind of battery life/performance we got with the older kernels, which is all this change really does.

  9. #149
    ahallubuntu is offline Chocolate-Covered Ubuntu Beans
    Join Date
    Jul 2005
    Beans
    2,050

    Re: GMA500 (Poulsbo) gma500_gfx

    I realize after posting the above that the freezing issue I mention may not be directly related to the gma500_gfx driver - but it will affect many people who use this driver (e.g. netbooks), probably not just users of the AO751h. I still hope it helps someone!

  10. #150
    Join Date
    Jul 2009
    Beans
    75

    Re: GMA500 (Poulsbo) gma500_gfx

    @ahallubuntu: Thanks for that hint.

    Kernel 3.12 is able to use two dashes again. By the way, I can confirm my Sony Vaio X series runs nicely with Kernel 3.12.

    One problem left: After standby, the screen brightness is resettet to maximum. Not that a big problem, but if someone has a nice fix, I'd take it.

    /edit: I just found out, that Kernel 3.12 does not need the special standby settings "-quirk-vbemode-restore" anymore! I removed the file /etc/pm/config.d/gma500, which contained the quirk-vbemode-restore-parameter and just did "sudo pm-suspend" and it worked! And the awaking is much much faster now! That's cool.

    Thanks to the (unkown to me) kernel developer who fixed that!

    But still remaining the brightness maximum issue.
    Last edited by mpw; November 17th, 2013 at 04:43 PM.

Page 15 of 16 FirstFirst ... 513141516 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •