Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: Ubuntu 12.04 and Atheros AR9485 wireless

  1. #21
    Join Date
    Feb 2008
    Beans
    100

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    Ok so there is this page dedicated to Acer S3 in linux.
    http://www.linlap.com/wiki/acer+aspire+s3
    I have used it for a few things and I dont know why I just thought to reference it for this. But it says specifically
    One person has reported problems with the wireless chip, after some time wireless connections just disconnected. So, if you experience such problems you can fix it by compiling the Compat wireless drivers for the 3.0 kernel. Heres how :

    First download the “build-essential”, “automake”, package in the Ubuntu Software center.

    Download the file following this link:
    http://www.orbit-lab.org/kernel/comp...-3.0-2.tar.bz2
    Uncompress it using archive manager or another solution.

    Compile and run it.
    Which sounds really promising, but when I run sudo make, I get
    http://pastebin.com/LsQZKa55

    a linux mint thread where someone got the same error trying to install compat-wireless said it was "entering the wrong headers. Try to install the latest linux-headers 3.4" I'm trying that next (so far my tangent stack is 4 deep)

  2. #22
    Join Date
    Feb 2008
    Beans
    1

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    Unfortunately nothing that is mentioned in this thread helped me. I have asus zenbook with AR9485 and under ubuntu (12.10) and fedora 17 singal and connection quality is low. At the same time if I boot into Windows I have no problems at all.
    Is there anybody that solved low signal problem under linux for zenbook with AR9485?

  3. #23
    Join Date
    Oct 2012
    Beans
    3

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    I can also confirm wireless issues with this setup. I thought it would be helpful here to document all of the fixes I've tried, as well as my machine info. I'm very interested in finding a solution to this problem, so I'm happy to provide any additional debug information that I can.

    I am running Ubuntu 12.04 x64 on an ASUS Zenbook UX31E. Here is the relevant information about my machine:

    Code:
    > uname -a
    Linux XXXX 3.5.0-17-generic #28~precise1-Ubuntu SMP Tue Oct 9 22:04:42 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    Code:
    12:02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
    (As you can see I upgraded to the 3.5 kernel based on this Community Wiki page to try to solve the problem)

    Code:
    > ifconfig
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:181 errors:0 dropped:0 overruns:0 frame:0
              TX packets:181 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:19626 (19.6 KB)  TX bytes:19626 (19.6 KB)
    
    wlan0     Link encap:Ethernet  HWaddr e0:b9:a5:d3:00:49  
              inet addr:192.17.252.116  Bcast:192.17.255.255  Mask:255.255.248.0
              inet6 addr: fe80::e2b9:a5ff:fed3:49/64 Scope:Link
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:621 errors:0 dropped:0 overruns:0 frame:0
              TX packets:696 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:562366 (562.3 KB)  TX bytes:98495 (98.4 KB)
    Code:
    > iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=27 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
    (Note that power management is off; also note that it claims I'm not currently associated with an access point, even though I am -- I believe this to be an unrelated bug)

    Now for things I've tried to fix the problem:


    1. Kernel update to 3.5
    2. Disable hardware crypto:
      Code:
       /etc/modprobe.d > cat ath9k.conf
      options ath9k nohwcrypt=1
    3. Disable ANI (I'm not really sure exactly what this does, I tried it on a whim based on this thread)
      Code:
       /sys/kernel/debug/ieee80211/phy0/ath9k # cat disable_ani
      1
    4. When I am at home or somewhere with a fixed router, I set the BSSID of the access point in the Network Manager. Note that this does solve the problem in my case! However, it is not good enough, because when I am at work or other places, I cannot set this BSSID, and thus still get terrible performance.

    I can't think of any other specific changes I've made at this point, but I've been working on this for over a month now, so I may have done something else that I've since forgotten about.


    With regards to the problem, my wireless card appears to simply drop out periodically. The length of time ranges from a few seconds to a few minutes, but it seems to be doing this on a fairly consistent basis. This manifests itself in the syslog in a number of different ways. The most common message I see is the following:


    Code:
    Oct 30 13:17:35 midget337 wpa_supplicant[1171]: CTRL-EVENT-DISCONNECTED bssid=0e:06:1a:d3:00:49 reason=4
    Oct 30 13:17:35 midget337 NetworkManager[1130]: <info> (wlan0): supplicant interface state: completed -> disconnected
    Oct 30 13:17:35 midget337 NetworkManager[1130]: <info> (wlan0): supplicant interface state: disconnected -> scanning
    Oct 30 13:17:35 midget337 wpa_supplicant[1171]: Trying to authenticate with 0e:06:1a:c4:64:da (SSID='IllinoisNet' freq=2437 MHz)
    Oct 30 13:17:35 midget337 kernel: [  302.305824] wlan0: authenticate with 0e:06:1a:c4:64:da
    Oct 30 13:17:35 midget337 kernel: [  302.310674] wlan0: direct probe to 0e:06:1a:c4:64:da (try 1/3)
    Oct 30 13:17:35 midget337 NetworkManager[1130]: <info> (wlan0): supplicant interface state: scanning -> authenticating
    Oct 30 13:17:36 midget337 kernel: [  302.513105] wlan0: direct probe to 0e:06:1a:c4:64:da (try 2/3)
    Oct 30 13:17:36 midget337 kernel: [  302.716883] wlan0: direct probe to 0e:06:1a:c4:64:da (try 3/3)
    Oct 30 13:17:36 midget337 kernel: [  302.920618] wlan0: authentication with 0e:06:1a:c4:64:da timed out
    Oct 30 13:17:42 midget337 kernel: [  308.548716] wlan0: authenticate with 0e:01:1a:d3:00:49
    Oct 30 13:17:42 midget337 wpa_supplicant[1171]: Trying to authenticate with 0e:01:1a:d3:00:49 (SSID='IllinoisNet' freq=2412 MHz)
    Oct 30 13:17:42 midget337 kernel: [  308.555199] wlan0: send auth to 0e:01:1a:d3:00:49 (try 1/3)
    Oct 30 13:17:42 midget337 wpa_supplicant[1171]: Trying to associate with 0e:01:1a:d3:00:49 (SSID='IllinoisNet' freq=2412 MHz)
    Oct 30 13:17:42 midget337 kernel: [  308.563381] wlan0: authenticated
    Oct 30 13:17:42 midget337 NetworkManager[1130]: <info> (wlan0): supplicant interface state: authenticating -> associating
    Oct 30 13:17:42 midget337 kernel: [  308.569844] wlan0: associate with 0e:01:1a:d3:00:49 (try 1/3)
    Oct 30 13:17:42 midget337 wpa_supplicant[1171]: Associated with 0e:01:1a:d3:00:49
    Note that wpa_supplicant has gone from a connected state to disconnected, and the reason given is '4' -- looking in the code for wpa_supplicant, this corresponds to WLAN_REASON_DISASSOC_DUE_TO_INACTIVITY. I'm not really sure what this means, but I found a forum thread that suggested it was some sort of power management issue.


    In other cases, I also see messages like the following in my syslog:


    Code:
    Oct 30 08:54:01 midget337 wpa_supplicant[1233]: CTRL-EVENT-CONNECTED - Connection to 06:0b:1a:d3:00:49 completed (reauth) [id=0 id_str=]
    Oct 30 08:54:01 midget337 NetworkManager[1189]: <info> (wlan0): supplicant interface state: associating -> completed
    Oct 30 08:54:43 midget337 pptp[25457]: nm-pptp-service-25438 log[logecho:pptp_ctrl.c:677]: Echo Request received.
    Oct 30 08:54:43 midget337 pptp[25457]: nm-pptp-service-25438 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply'
    Oct 30 08:55:15 midget337 wpa_supplicant[1233]: Trying to authenticate with 00:0c:e6:6f:47:72 (SSID='UIUCnet' freq=2462 MHz)
    Oct 30 08:55:15 midget337 kernel: [76182.617695] wlan0: authenticate with 00:0c:e6:6f:47:72
    Oct 30 08:55:15 midget337 NetworkManager[1189]: <info> (wlan0): supplicant interface state: completed -> authenticating
    Oct 30 08:55:15 midget337 kernel: [76182.622261] wlan0: No basic rates, using min rate instead.
    Oct 30 08:55:15 midget337 kernel: [76182.622357] wlan0: direct probe to 00:0c:e6:6f:47:72 (try 1/3)
    Oct 30 08:55:15 midget337 kernel: [76182.825056] wlan0: direct probe to 00:0c:e6:6f:47:72 (try 2/3)
    Oct 30 08:55:15 midget337 kernel: [76183.028781] wlan0: direct probe to 00:0c:e6:6f:47:72 (try 3/3)
    Oct 30 08:55:16 midget337 kernel: [76183.232315] wlan0: authentication with 00:0c:e6:6f:47:72 timed out
    Oct 30 08:55:21 midget337 wpa_supplicant[1233]: Trying to authenticate with 06:0b:1a:d3:00:49 (SSID='UIUCnet' freq=2462 MHz)
    Oct 30 08:55:21 midget337 kernel: [76188.866615] wlan0: authenticate with 06:0b:1a:d3:00:49
    Oct 30 08:55:21 midget337 kernel: [76188.881750] wlan0: send auth to 06:0b:1a:d3:00:49 (try 1/3)
    Oct 30 08:55:21 midget337 wpa_supplicant[1233]: Trying to associate with 06:0b:1a:d3:00:49 (SSID='UIUCnet' freq=2462 MHz)
    Oct 30 08:55:21 midget337 kernel: [76188.883548] wlan0: authenticated
    Oct 30 08:55:21 midget337 NetworkManager[1189]: <info> (wlan0): supplicant interface state: authenticating -> associating
    Oct 30 08:55:21 midget337 wpa_supplicant[1233]: Associated with 06:0b:1a:d3:00:49
    While the messages in the log are different (maybe because the AP is unsecured in this case?), the behaviour is nearly identical -- every 30-600 seconds, the wireless card tries to "reauth".

    Are there any suggestions as to what might be going on here? I've seen some suggestions that the 3.6 kernel has better wireless support. Should I try upgrading to this? Is there any other information on my machine I can provide? I haven't seen a formal bug report for this issue anywhere, is it worth filing one?

    Thanks for your help!

  4. #24
    Join Date
    Oct 2012
    Beans
    3

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    Hi, all,

    I've found some further information that may be useful. First, here is another post from a guy that looks like he's having exactly the same problem. He had one further suggestion to try, that is to disable ipv6. I did this, and it did not help.

    Next, there are a whole host of different bug reports that are of varying degrees of similarity to the issue talked about here. This bug report is the closest one I've been able to find.

    Finally, and perhaps most usefully, I found a thread suggesting that the scanning behaviour of NetworkManager is causing wireless to hang. Apparently, NetworkManager scans for new channels exactly every 2 minutes, which can cause the wireless to hang. I went back and looked at my syslog again, and I'm getting disconnection events exactly every 2 minutes, which makes me suspect that this might be the problem.

    According to that thread, there's no way to disable this behaviour except by modifying the NetworkManager source (though the thread is two years old at this point). Anyways, I'm going to attempt to update my networkmanager code via the procedure described and see if that helps my connectivity issues. I'll report back once I'm done.

  5. #25
    Join Date
    Nov 2012
    Beans
    2

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    Hello to the community!

    Am using ubuntu on my ux21 for almost a year now and actually hadn't faced this problem until the system upgraded to 12.10. After the upgrade my wifi connection got disconnected every couple of minutes with:

    "All devices are disconnected, going to restore regulatory settings".

    The problems exists in current 3.5 kernel, but if I boot up with the 3.2.0-32-generic kernel I no more get this message and wireless connection gets stable again!

    Hope this info will help somehow. And please, do share it with the devs, if possible, as I'm not sure where exactly to post that, so this could be fixed in the latest kernel versions. Tx

    UPD: 3.2.0-32 does not help either. I was mistaken. Problem disappeared only for a couple of hours after booting into 3.2 kernel - now I still get All devices are disconnected message every couple of minutes. That makes me really mad.. =(
    Last edited by wag1; November 7th, 2012 at 09:55 PM. Reason: UPD

  6. #26
    Join Date
    Oct 2012
    Beans
    3

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    I can confirm that modifying the code (as described in my previous post) does not solve the problem. I still disconnect and reconnect frequently. I think I may see about upgrading to the 3.6 kernel; I've read a few places that the wireless support in this kernel is a lot better, but I'm not optimistic...

  7. #27
    Join Date
    Apr 2012
    Beans
    15

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    The bug is declared
    - here, for Canonical : https://bugs.launchpad.net/ubuntu/+s...ux/+bug/971809
    - here, in the kernel : https://bugzilla.kernel.org/show_bug.cgi?id=49201

    Feel free to help or provide information.

  8. #28

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    I have an Asus U36JC laptop with an Atheros AR9285 card (which I understand is similar to the AR9485 card), and the problem (in may case, network activity stopping after a few minutes, requiring reboot or disconnecting and reconnecting) started for me when I tossed my 'g' router and got an 'n' router.

    The problem went away when I changed the router settings to use only 'b' and 'g' but not 'n'.

    Admittedly not an ideal solution, but easier than recompiling.
    Last edited by Potential Business User; January 27th, 2013 at 03:53 AM. Reason: clarity

  9. #29
    Join Date
    Mar 2013
    Beans
    1

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    I have no idea why, and not sure if it'll help but think its worth mentioning. i have a packard bell dot s, with a "AR9485" anyways it will not connect on wifi, will just keep re-trying... until i unplug my power lead... then it will connect first time for reasons i don't understand, and then if i plug my power back in... it'll just carry on staying connected

  10. #30
    Join Date
    Apr 2007
    Location
    GTA
    Beans
    18
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Ubuntu 12.04 and Atheros AR9485 wireless

    Hmm.. weird, this worked for me as well. I had ping up, pinging 8.8.8.8 with no response. The second I unplugged power, I start getting responses.

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •