Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 43

Thread: Trouble installing Canon LBP 3100 Printer

  1. #11
    Join Date
    Apr 2012
    Beans
    38

    Re: Trouble installing Canon LBP 3100 Printer

    Hello maxim40

    Here is how to run your LBP3000 in Ubuntu 12.04-64bits.

    For a LBP3000, the simplest way is to download drivers from the PPA mickael-gruz.
    The 64bits Maverick version works well with 12.04.

    1) Download and install transitional package "gs-esp" :2) Download and install from the PPA depot the 2 packages :3) Restart cups :
    sudo service cups restart
    4) Modify the file /etc/modprobe.d/blacklist-cups-usblp.conf as indicated in my post #9

    5) See my post #5 in : http://ubuntuforums.org/showthread.php?t=1983091
    Starting at point#1 and of course change LBP6300 with LBP3000
    If you succeed to print, see my post#6 in this thread for auot-ccpd management.
    Good luck

  2. #12
    Join Date
    Nov 2008
    Beans
    4

    Re: Trouble installing Canon LBP 3100 Printer

    Thank you very much for your help.

    I had a problem with ia32-libs.

    I have download the file "ia32-libs_20090808ubuntu26_amd64.deb" but when i try to install it the install package button is disabled so i cannot continue.

    Do you know why?



    Quote Originally Posted by Sivella View Post
    Hello maxim40

    Here is how to run your LBP3000 in Ubuntu 12.04-64bits.

    For a LBP3000, the simplest way is to download drivers from the PPA mickael-gruz.
    The 64bits Maverick version works well with 12.04.

    1) Download and install transitional package "gs-esp" :2) Download and install from the PPA depot the 2 packages :3) Restart cups :4) Modify the file /etc/modprobe.d/blacklist-cups-usblp.conf as indicated in my post #9

    5) See my post #5 in : http://ubuntuforums.org/showthread.php?t=1983091
    Starting at point#1 and of course change LBP6300 with LBP3000
    If you succeed to print, see my post#6 in this thread for auot-ccpd management.
    Good luck

  3. #13
    Join Date
    Apr 2012
    Beans
    38

    Re: Trouble installing Canon LBP 3100 Printer

    Try command line in a terminal.

    First move in the directory where this package is (with "cd" command), then :
    sudo dpkg -i ia32-libs_20090808ubuntu26_amd64.deb
    May be it doesn't work in graphic mode because a transitional package ia32-libs exists for 12.04 and the application is reluctant to install a downgraded version ?

  4. #14
    Join Date
    Nov 2008
    Beans
    4

    Re: Trouble installing Canon LBP 3100 Printer

    Hi Sivella,

    I try it but again i have an error. I think you are right, the problem might be this. How can i install it?

    Thank you

    root@Core-i5:/home/dionysos/Downloads# sudo dpkg -i ia32-libs_20090808ubuntu26_amd64.deb
    dpkg: regarding ia32-libs_20090808ubuntu26_amd64.deb containing ia32-libs, pre-dependency problem:
    ia32-libs pre-depends on libc6-i386 (>= 2.9-18 )
    dpkg: error processing ia32-libs_20090808ubuntu26_amd64.deb (--install):
    pre-dependency problem - not installing ia32-libs
    Errors were encountered while processing:
    ia32-libs_20090808ubuntu26_amd64.deb


    Quote Originally Posted by Sivella View Post
    Try command line in a terminal.

    First move in the directory where this package is (with "cd" command), then :
    May be it doesn't work in graphic mode because a transitional package ia32-libs exists for 12.04 and the application is reluctant to install a downgraded version ?

  5. #15
    Join Date
    Apr 2012
    Beans
    38

    Re: Trouble installing Canon LBP 3100 Printer

    Before installing ia32-libs, you must install dependencies :
    lib32asound2,
    lib32ffi6,
    lib32bz2-1.0,
    lib32gcc1,
    lib32stdc++6,
    lib32z1,
    lib32ncurses5,
    lib32ncursesw5,
    libc6-i386,
    You can use the 12.04 version they work...

    Reading you error message, I think libc6-i386 is missing. Could you check it ?

  6. #16
    Join Date
    Nov 2008
    Beans
    4

    Re: Trouble installing Canon LBP 3100 Printer

    I finally made it, thank you very very much. The only think that i want to mention, for other users also, is that i have to restart printer in order to print.

    Quote Originally Posted by Sivella View Post
    Before installing ia32-libs, you must install dependencies :
    lib32asound2,
    lib32ffi6,
    lib32bz2-1.0,
    lib32gcc1,
    lib32stdc++6,
    lib32z1,
    lib32ncurses5,
    lib32ncursesw5,
    libc6-i386,
    You can use the 12.04 version they work...

    Reading you error message, I think libc6-i386 is missing. Could you check it ?

  7. #17
    Join Date
    Jun 2012
    Beans
    1

    Smile Re: Trouble installing Canon LBP 3100 Printer

    Thanks Sivella for excellent installation instructions for the printer. My printer is canon LBP 2900, I had substituted this for LBP 3100. I am very much new to ubuntu, and I had installed ubuntu 12.04. As I am not technically well versed, I copied all the commands to terminal and everything worked fine. When I had hit the road block this instruction to cancel blacklist usblp really helped.

  8. #18
    Join Date
    Apr 2005
    Beans
    1,848

    Re: Trouble installing Canon LBP 3100 Printer

    thanks very much for this excellent guide; (post #4)

    I have my LBP3100B running well now on Mint 13 (32bit):

    c'est tres bien! merci a vous

    the directory /var/fif0 was not created with the initial .deb drivers so I was able to do this with the commands you advised;

  9. #19
    Join Date
    Oct 2012
    Beans
    10

    Smile Re: Trouble installing Canon LBP 3100 Printer

    Hi,
    please follow instructions at the following web page:

    http://ubuntuforums.org/showthread.p...5#post12350075
    (#12)

    and You will solve the problem with Canon CAPT printer drivers!

    tonidito

  10. #20
    Join Date
    Dec 2012
    Beans
    1

    Re: Trouble installing Canon LBP 3100 Printer

    Quote Originally Posted by Sivella View Post
    Ok, 32bits is the simplest

    Firts, in : System Settings --> Printing
    Remove any printer(s).

    I assume you have installed cndrvcups-common_2.40-1_i386.deb first, and then cndrvcups-capt_2.40-1_i386.deb without any error messages.

    1) Create the following directories/file if they are missing:
    2) Register the printer:
    CNCUPSLBP3150CAPTK.ppd is not a mistake...

    3) Register the printer with ccpd daemon:
    4) Start ccpd daemon:
    Test install:
    will open the Statusmonitor window. If the message "Ready to print" is displayed --> all is OK.
    Try to print something.

    In System Settings --> Printing set your LBP3100 as default (right click on LBP3100 icon)
    Probably on next boot, a "new" LBP3100-2 will appear. Don't worry about that and ignore it (the default is LBP-3100).

    If it works well, I will explain you how to manage automatically ccpd daemon.

    Good luck.


    Hi, I am using canon LBP6000. I have no problem installing ndrvcups-common_2.40-1_i386.deb first, and then cndrvcups-capt_2.40-1_i386.deb

    I followed every step and changed this line
    sudo /usr/sbin/lpadmin -p LBP6000 -m CNCUPSLBP6018CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E
    Everything went fine until I typed this in the terminal
    captstatusui -P LBP6000
    It showed
    *** captstatusui Socket Error ***
    I don't know what did I do wrong. Could you please tell me my mistakes?

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •