Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 42

Thread: How to use GIMP 2.8 on Lucid 10.04.4 LTS

  1. #11
    Join Date
    Jul 2009
    Beans
    3

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    shreepads: I followed your instruction and needless to say that they worked out perfectly. Many thanks for your effort!

    If I find the time I will try to write a shell script that will do all necessary steps automatically. I will provide this script here for downloading. Maybe I'll get it done this weekend.

    There's just one thing I would like to chance but I am not very good at this kind of stuff: can the building procedure be changed to that effect that the resulting executable will be a staticaly linked binary that can be installed in /usr/local or in /opt using apt?

  2. #12
    Join Date
    Apr 2007
    Beans
    195

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Quote Originally Posted by otto06217 View Post
    Nice, nice, nice!!!

    Subsequent it give me some hope for building my Gimp standalone package for older Ubuntu Distros: https://launchpad.net/~otto-kesselgu...imp-standalone

    'til then

    Otto
    Any chance of this for Natty? It's newer than 10.04.4, but it's at the limit for my video card's compatibility to the Ubuntu release cycle. I use Xubuntu.

    I have just managed to get it (GIMP 2.8 ) running using WINE instead of the long instructions. The requirements were giving me a headache. So, I do have it running in 11.04, but it would be nice if it was a PPA.

    Not much love for the older systems anymore! There was a time when Linux was friendly to older systems.
    Last edited by 42dorian; July 5th, 2012 at 07:53 AM.

  3. #13
    Join Date
    Jun 2007
    Beans
    322

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Quote Originally Posted by Wolfgang.Klein View Post
    shreepads: I followed your instruction and needless to say that they worked out perfectly. Many thanks for your effort!

    If I find the time I will try to write a shell script that will do all necessary steps automatically. I will provide this script here for downloading. Maybe I'll get it done this weekend.

    There's just one thing I would like to chance but I am not very good at this kind of stuff: can the building procedure be changed to that effect that the resulting executable will be a staticaly linked binary that can be installed in /usr/local or in /opt using apt?
    Glad someone found it useful!

    I'm not sure I understand your question re statically linked library in /usr/local or /opt. Do you want to do a full install? I'm not sure I'd recommend that, too many dependency packages need to be upgraded, which may break the system.

    Sorry, but am quite new to this compile and install business!
    Intel C2D E7200 || Intel DG33FB mobo || 4 GB RAM || 64 bit Lucid/ Precise Desktops || WD Caviar Black 1TB, Green 2TB; Corsair Force 3 60GB
    Dell U2412M || Palit Sonic GT 240 (OC'd NVidia card) || Logitech Quickcam Connect || Acer 3300U Scanner

  4. #14
    Join Date
    Aug 2011
    Beans
    10

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Thank you very much, it works
    The interface is little bit ugly due the GTK+ version, but I don't mind. It works )

  5. #15
    Join Date
    Nov 2008
    Beans
    1

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Wow, thx so much! Actually I just installed 10.04 (after kicking 12.04) and since I'm doing a new setup from scratch I thought let's see about gimp2.8. Reading the INSTALL-file (and about all that dependencies...) let me decide to use the default gimp2.6(?) from the repository when I stumbled over your tutorial.

    I have to say, perfect step by step copy and past tutorial. Better is just not possible.

    Thx so much and keep on rocking,...

  6. #16
    Join Date
    Jan 2011
    Beans
    5

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Ran into a few problems... But after installing needed packages everything compiled and installed and I now have Gimp 2.8 installed on Lucid. Thank you!

    -lmgh81

  7. #17
    Join Date
    Aug 2012
    Beans
    1

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    When trying to compile GTK+ I keep on getting this error:
    $>./configure --prefix=/home/robin/Gimp/Gimp2.8/build/
    ...
    $>make -j2
    ...
    /usr/share/gir-1.0/GdkPixbuf-2.0.gir: Incompatible version 1.0 (supported: 1.2)
    make[4]: *** [Gdk-2.0.gir] Error 1
    make[4]: Leaving directory `/home/robin/Gimp/Gimp2.8/src/gtk+-2.24.10/gdk'
    make[3]: *** [all-recursive] Error 1
    make[3]: Leaving directory `/home/robin/Gimp/Gimp2.8/src/gtk+-2.24.10/gdk'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/home/robin/Gimp/Gimp2.8/src/gtk+-2.24.10/gdk'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/robin/Gimp/Gimp2.8/src/gtk+-2.24.10'
    make: *** [all] Error 2

    I've been googling but I can't find the solution...

    Thanks a lot,
    Robin



    EDIT-----
    Gave it a new try today, clean directories. Then it worked fine. Great tutorial!
    Last edited by denUil; August 16th, 2012 at 09:50 PM. Reason: resolved issue

  8. #18
    Join Date
    Sep 2006
    Beans
    25

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Thank you very much.

    While configuring gobject-introspection, I had errors for flex and bison, quickly remedied through Synaptic.

    I have not had a chance to deal with:

    Code:
    Gtk-Message: Failed to load module "canberra-gtk-module"
    Gtk-Message: Failed to load module "canberra-gtk-module"
    While parsing XMP metadata:
    Error on line 14 char 1: End of element <xmpMM:DerivedFrom> not expected in
    this context
    
    Metadata parasite seems to be corrupt
    ^C./gimp-2.8: terminated: Interrupt
    /home/user/Gimp/Gimp2.8/build/lib/gimp/2.0/plug-ins/script-fu terminated:
    Interrupt
    user@user:~/Gimp/Gimp2.8/build/bin$ ./gimp-2.8
    Gtk-Message: Failed to load module "canberra-gtk-module"
    Gtk-Message: Failed to load module "canberra-gtk-module"
    While parsing XMP metadata:
    Error on line 14 char 1: End of element <xmpMM:DerivedFrom> not expected in
    this context
    
    Metadata parasite seems to be corrupt
    Gtk-Message: Failed to load module "canberra-gtk-module"
    Though I will be looking into it as soon as I get the chance.

    Despite this however, gimp works fine, so far.
    "Second to the right, and straight on till morning."

  9. #19
    Join Date
    Aug 2011
    Beans
    10

    Lightbulb Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Hi, I've created precompiled package with your instruction, it should works, it has 130 downloads and nobody has complained yet

    Here is the link http://sourceforge.net/projects/gimp28/files/

    Enjoy it (if it doesn't work, please warn me)

  10. #20
    Join Date
    Jul 2010
    Beans
    55
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to use GIMP 2.8 on Lucid 10.04.4 LTS

    Hi Guys,

    I've got to admit I freaked out a bit trying to follow the original instructions so I tried to use Otto's PPA and the package from Miskopo.

    Otto's PPA hasn't upgraded Gimp from 2.7 to 2.8 for me.

    Miskopo - when I try and install your package I keep getting: Gimp/Gimp2.8/build/bin/gimp-2.8: not found

    I have placed the files in the home folder. Any further advice would be appreciated.

    Gimp is an amazing piece of software. 2.7 has everything for me but it crashes when I try and use fonts selection. I love the new single window mode and that's why I don't want to go back to 2.6.9.

    Thanks in advance for any help!!

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •