Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Folder Sharing

  1. #11
    Join Date
    Jan 2009
    Location
    Germany
    Beans
    24
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Folder Sharing

    Thanks mate worked flawlessly
    *edit: I had "no" instead of "false" though

  2. #12
    Join Date
    Dec 2009
    Beans
    5,304

    Re: Folder Sharing

    Quote Originally Posted by dodjob View Post
    Thanks mate worked flawlessly
    *edit: I had "no" instead of "false" though
    Despite claims to the contrary Samba is remarkably flexible allowing yes/true and no/false. It also allows for misspelled words: writeable / writable.


  3. #13
    Join Date
    Jul 2007
    Beans
    3

    Re: Folder Sharing

    Quote Originally Posted by Morbius1 View Post
    [1] Do not ever use gadmin-samba again for as long as you live.

    [2] Purging the "samba" package will not resolve your discombobulated smb.conf file since that file doesn't come from the "samba" package.

    [3] Restore a factory fresh copy of smb.conf:

    (**) Make sure the following file exists: /usr/share/samba/smb.conf

    (**) Make a backup of your current smb.conf
    Code:
      sudo cp /etc/samba/smb.conf /etc/samba/smb.confMOD
    (**) Start with a fresh one:
    Code:
    sudo cp -a /usr/share/samba/smb.conf /etc/samba/
    (**) Correct one mistake in the new one:
    Find the line:
    and change it to:
    (**) Restart samba
    Code:
    sudo service smbd restart

    Thanks very very very much for this man - I was trying this file sharing feature for days, and finally today it works!!
    Next question would be: why did Canonical allow to leave "encrypt passwords = no" as default in the smb.conf file, and this even up until the days of raring ringtail?
    I know it's just a default, but do you have an idea of how many noobs (like me :°) you might have lost?

  4. #14
    Join Date
    Dec 2009
    Beans
    5,304

    Re: Folder Sharing

    Quote Originally Posted by pgradone View Post
    Thanks very very very much for this man - I was trying this file sharing feature for days, and finally today it works!!
    Next question would be: why did Canonical allow to leave "encrypt passwords = no" as default in the smb.conf file, and this even up until the days of raring ringtail?
    I know it's just a default, but do you have an idea of how many noobs (like me :°) you might have lost?
    I'm going to let you in on a secret that confounds even long time users of Samba. The file at /etc/samba/smb.conf is not the samba configuration file. It's a file that the local administrator of the box ( you ! ) uses to add to or override the default settings of samba. There is no "file" that contains the default settings there is only a way to see the defaults by running a command. Let's take "encrypt passwords" as an example.

    By running the following command you can see that the default setting of Samba has that parameter set to Yes:
    Code:
    testparm -sv /dev/null | grep "encrypt passwords"
    Unless you have encountered a bug somewhere during the install the standard smb.conf file has no affect on this state of this parameter. This command will show you the affect of the default smb.conf on that default setting
    Code:
    testparm -s | grep "encrypt passwords"
    You will notice that there isn't even a mention of "encrypt passwords" in the output. You can even add it to the file ( set to yes ) and testparm will still show it missing since adding it has no affect on the default settings.

    The file at /usr/share/samba/smb.conf is another matter and comes from the samba-common package. It doesn't come from Ubuntu it comes from the Samba factory. Why it has encrypt passwords set to No is a mystery but it's not Ubuntu's doing it's Samba's.
    Last edited by Morbius1; June 20th, 2013 at 02:05 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •