Results 1 to 6 of 6

Thread: /etc/lightdm/lightdm.conf

  1. #1
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,853
    Distro
    Ubuntu 14.04 Trusty Tahr

    /etc/lightdm/lightdm.conf

    It looks like file /etc/lightdm/lightdm.conf is depreciated when control of LighDM is concerned... Am I wrong...? It seems that current status of LightDM session is written elsewhere...
    Update₁: Am I right in thinking that ~/.dmrc is now place where data about current session is saved...? /etc/lightdm/lightdm.conf is left for other stuff...
    Last edited by zika; May 17th, 2012 at 12:54 PM.

  2. #2
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: /etc/lightdm/lightdm.conf

    Quote Originally Posted by zika View Post
    It looks like file /etc/lightdm/lightdm.conf is depreciated when control of LighDM is concerned... Am I wrong...? It seems that current status of LightDM session is written elsewhere...
    Update₁: Am I right in thinking that ~/.dmrc is now place where data about current session is saved...? /etc/lightdm/lightdm.conf is left for other stuff...
    I have the following lines in /etc/lightdm/lightdm.conf. All others are commented.

    [LightDM]
    minimum-vt=7
    seats=seat-0
    [GuestAccount]
    enabled=false
    [SeatDefaults]
    user-session=gnome
    allow-guest=false
    greeter-session=lightdm-gtk-greeter

  3. #3
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,853
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: /etc/lightdm/lightdm.conf

    Quote Originally Posted by Harry33 View Post
    I have the following lines in /etc/lightdm/lightdm.conf. All others are commented.

    [LightDM]
    minimum-vt=7
    seats=seat-0
    [GuestAccount]
    enabled=false
    [SeatDefaults]
    user-session=gnome
    allow-guest=false
    greeter-session=lightdm-gtk-greeter
    I've never had first two sections of Your .conf file...
    Lately it does not matter what is in
    Code:
    [SeatDefaults]
    user-session=gnome
    because only what is in ~/.dmrc seems to matter and that is changed if I change user session from greeter...
    Code:
    :~$ cat /etc/lightdm/lightdm.conf 
    [SeatDefaults]
    #greeter-session=lightdm-gtk-greeter
    greeter-session=unity-greeter
    #user-session=gnome-classic
    #user-session=ubuntu-2d
    #user-session=ubuntu
    #user-session=fluxbox
    #user-session=openbox
    #user-session=gnome-shell
    #user-session=xsession
    #user-session=gnome-fallback
    user-session=cinnamon
    autologin-user=zika
    allow-guest=false
    greeter-hide-users=true
    I'll investigate further...
    Update₁: ~/.dmrc is not the place to edit... It is generated by LightDM at the start and not read before start... It is a derviative of some other file where information about the latest session used is stored... /etc/lightdm/lightdm.conf is not used at least for user-session... Investigating still...
    Code:
    :~$ cat .dmrc 
    [Desktop]
    Language=en_US
    Layout=rs    latin
    Session=cinnamon
    Langlist=en_US:en
    LCMess=en_US.UTF-8
    Update₂: All this is problem if there is greeter-session=unity-greeter in use. If it is greeter-session=lightdm-gtk-greeter there is no problem and everything as we used it to be...
    Last edited by zika; May 17th, 2012 at 05:16 PM.

  4. #4
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: /etc/lightdm/lightdm.conf

    Quote Originally Posted by zika View Post
    I've never had first two sections of Your .conf file...

    ...

    Update₂: All this is problem if there is greeter-session=unity-greeter in use. If it is greeter-session=lightdm-gtk-greeter there is no problem and everything as we used it to be...
    Well is this when you have lightdm-gtk-greeter installed, for example with gnome-shell?
    And further, if you do not have unity-greeter installed at all?

  5. #5
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,853
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: /etc/lightdm/lightdm.conf

    Quote Originally Posted by Harry33 View Post
    Well is this when you have lightdm-gtk-greeter installed, for example with gnome-shell?
    And further, if you do not have unity-greeter installed at all?
    To clarify:

    - it happens only with unity-greeter i.e. unity greeter does not honor setting user-session in /etc/lightdm/lightdm.conf

    - lightdm-gtk-greeter does not have problem with this, it honors setting user-session in /etc/lightdm/lightdm.conf

    - it does not depend on a session I use...

    - I noticed this awhile in precise but did not give it any attention until today a user on our Forum did have problem with advice I gave him how to use setting user-session in /etc/lightdm/lightdm.conf... It does not bother me personally much since I use startx very often...

    I did not try with unity-greeter not installed at all...

  6. #6
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    6,537
    Distro
    Ubuntu Development Release

    Re: /etc/lightdm/lightdm.conf

    I also have noticed changes. In my 11.10 which has been upgraded to 12.04 /etc/lightdm has a unity-greeter.conf where the path to the lightDM background image is recorded as well as the theme.

    But in 12.10 unity-greeter.conf is absent from /etc/lightdm. I have been searching for the script that holds the reference to the lightDM background image. I have been unsuccessful.

    I also have a 12.04 that I converted to 12.10 and it has a unity-greeter.conf in /etc/lightdm but the 12.10 that I install from a daily ISO image does not have unity-greeter.conf in /etc/lightdm

    There is a /usr/share/unity-greeter with icons. And in /usr/share/xsessions there are three files which I cannot open. Their properties say this:

    GNOME
    Command gnome-session--session=gnome
    comment This session logs you into Gnome

    Ubuntu
    Command UBUNTU gnome-session--session=ubuntu
    Comment This session logs you into Ubuntu

    UBUNTU 2D
    Command gnome-session--ubuntu-2D
    Comment This session logs you into Ubuntu 2D mode

    They are desktop configuration files but when I try to open one I get "Could not acquire name on session bus."

    There is a usr/share/gnome-session/sessions folder with

    gnome.session
    ubuntu.session
    ubuntu-2D.session

    and these files will open in Gedit but do not have references to the login background image, which is what I am looking for.

    Regards.
    Last edited by grahammechanical; May 17th, 2012 at 08:10 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •