Results 1 to 6 of 6

Thread: How To Run Luckybackup Super User Cron Job Without Login

  1. #1
    Join Date
    Mar 2008
    Location
    Santa Barbara, CA USA
    Beans
    146
    Distro
    Ubuntu 12.10 Quantal Quetzal

    How To Run Luckybackup Super User Cron Job Without Login

    Is there a way to run a Luckybackup Super User cron job without being prompted to log in? Ever since upgrading to Precise - the only way I can get Luckybackup to work properly is by running the Super User version instead of the regular one. The regular version acts as though it is running OK, but no new files get written to the location it is set to write to, and I get an rsync broken pipe error... The Super User version works perfectly.

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,663
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How To Run Luckybackup Super User Cron Job Without Login

    Hi Precipitous.

    Are you backing up locally or to a remote host?

    Regards.

  3. #3
    Join Date
    Mar 2008
    Location
    Santa Barbara, CA USA
    Beans
    146
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: How To Run Luckybackup Super User Cron Job Without Login

    Quote Originally Posted by papibe View Post
    Hi Precipitous.

    Are you backing up locally or to a remote host?

    Regards.
    I am backing up locally to an external USB drive.

  4. #4
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,663
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How To Run Luckybackup Super User Cron Job Without Login

    It looks like a permissions problem.

    Is it NTFS or something else? Remember that NTFS does not support users, and the permissions and ownership are set on the mount options.

    Is it always mounted, or just for the backup? The command 'mount' requires root privileges (there is other ways to mount).

    Do you have any directory set for privacy (like 000 permissions)? Even your user won't be able to write to those directories in case they are set that way.

    Just some thoughts.
    Regards.

  5. #5
    Join Date
    Mar 2008
    Location
    Santa Barbara, CA USA
    Beans
    146
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: How To Run Luckybackup Super User Cron Job Without Login

    Quote Originally Posted by papibe View Post
    It looks like a permissions problem.

    Is it NTFS or something else? Remember that NTFS does not support users, and the permissions and ownership are set on the mount options.

    Is it always mounted, or just for the backup? The command 'mount' requires root privileges (there is other ways to mount).

    Do you have any directory set for privacy (like 000 permissions)? Even your user won't be able to write to those directories in case they are set that way.

    Just some thoughts.
    Regards.
    The drive I am backing up to is formatted with ext4. The reason I am having to run Luckybackup Superuser is that ever since upgrading to Precise when I run Luckybackup as a regular user I get Rsync Broken Pipe errors and no files get written to the backup location. Running as Superuser everything works fine. Although I can easily run the backup manually I would like to be able to set it up as a Cron job that is totally automated. I just don't know how to do so without being prompted for a root login password.

  6. #6
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,663
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How To Run Luckybackup Super User Cron Job Without Login

    You may create a crontab for root, instead of your regular user:
    Code:
    sudo crontab -e
    That way you shouldn't have password issues.

    Regards.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •