Results 1 to 10 of 34

Thread: ubuntu 12.04 sound problem

Hybrid View

  1. #1
    Join Date
    May 2012
    Beans
    5

    Angry ubuntu 12.04 sound problem

    Hi,

    I am using an intel DG31PR motherboard that has realtek audio. Ever since I have installed Ubuntu 12, the audio is not working right. I hear the sound (from the speaker) but its mostly absent. Basically there is a lot of stuttering/choppiness. If I use a headphone, it works fine.

    I have my alsa diagnostic tool output up at: http://www.alsa-project.org/db/?f=ba...8a9446c277a2a3

    I have tried all I could but nothings working for me. I must mention that before this I was using xubuntu 11 which worked just fine (I never updated it because I found that one of the updates to xubuntu 11 caused the same problem that I am facing now).

    Any help would be appreciated. I would be forced to look back at other options if this does not get solved soon.

    Thanks!

    Aditya

  2. #2
    Join Date
    May 2012
    Beans
    5

    Re: ubuntu 12.04 sound problem

    Since no one replied I started snooping around myself. Till now what I have found is that the alsa output thinks that I have a Realtek ALC662 but in reality what Intel DG31PR comes with is ALC888. So that might be a problem, I am guessing.

    Right now I do not have access to my system but soon I will and will try and see a fix for that. Will update it here.

  3. #3
    Join Date
    Feb 2012
    Location
    Norway
    Beans
    191
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: ubuntu 12.04 sound problem

    Hey mate!

    Since your headphones are working fine I would guess it is rather a problem with the way the sound is going to your speakers, obviously.. I am probably stating the obvious, but have you played around with different mixers (e.g. gnome alsa mixer, alsamixer in terminal [command: # alsamixer] etc) to see if that sorts things out?

  4. #4
    Join Date
    May 2012
    Beans
    5

    Re: ubuntu 12.04 sound problem

    ah, we have a reply at last.

    Yes, I did some tweakings with alsamixer (only alsamixer, nothing else) and did not help.

    The sound from the speaker is MOSTLY absent and when I hear some, for those microseconds that its there, its choppy.

    Any help or thoughts appreciated!

  5. #5
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    10,486
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: ubuntu 12.04 sound problem

    Moved to the multimedia forum.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  6. #6
    Join Date
    Oct 2010
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ubuntu 12.04 sound problem

    Have you looked in the software centre for a different sound system to try? or uninstall what you currently have and reinstall it??

  7. #7
    Join Date
    May 2012
    Beans
    5

    Wink Re: ubuntu 12.04 sound problem

    Solved!

    Here's what I did:

    added this line at the end of /etc/modprobe.d/alsa-base.conf:

    options snd-hda-intel model=generic

    That was all. I think I had tried it earlier too but somehow it was not working. Maybe I had tried too much.

    But I think the problem was indeed that it was trying to use the ALC888 as ALC662 and that was not happening.

    Thanks for the responses. Now I can stick to Ubuntu and try to get friendly with Unity

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •