Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Alt-Tab and Alt-4 don't work

  1. #11
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,879
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Alt-Tab and Alt-4 don't work

    At my place Alt-Tab does work in Unity, FluxBox and OpenBox but not in Gnome-slassic(a.k.a. fallback)...

  2. #12
    Join Date
    Apr 2006
    Location
    New Hampshire, U.S.A.
    Beans
    2,491
    Distro
    Ubuntu Development Release

    Unhappy Re: Alt-Tab and Alt-4 don't work

    Quote Originally Posted by zika View Post
    At my place Alt-Tab does work in Unity, FluxBox and OpenBox but not in Gnome-slassic(a.k.a. fallback)...
    Update keeps killing Alt-Tab and Alt-F4. I don't know why the developers keep removing function....

    Jerry

  3. #13
    Join Date
    Jun 2007
    Beans
    13,064

    Re: Alt-Tab and Alt-4 don't work

    Alt-Tab and Alt-F4 work in all sessions here by default with the exception of Alt-Tab in Classic (compiz). In that case one of the switchers needs to be enabled in ccsm
    So don't see the "developers" causing anything in this regard

  4. #14
    Join Date
    Apr 2006
    Location
    New Hampshire, U.S.A.
    Beans
    2,491
    Distro
    Ubuntu Development Release

    Wink Re: Alt-Tab and Alt-4 don't work

    Quote Originally Posted by mc4man View Post
    Alt-Tab and Alt-F4 work in all sessions here by default with the exception of Alt-Tab in Classic (compiz). In that case one of the switchers needs to be enabled in ccsm
    So don't see the "developers" causing anything in this regard
    Well, this is quantal quetzal Unity-2D. I guess I'm not as lucky as you are. No big deal, just adds to the manual things to do on a new install. I do a lot of installs on "unstable" development ubuntu's on four pc's looking for bugs.

    Jerry

  5. #15
    Join Date
    May 2008
    Location
    Brooklyn
    Beans
    160
    Distro
    Kubuntu 13.04 Raring Ringtail

    Question Re: Alt-Tab and Alt-4 don't work

    Quote Originally Posted by jerrylamos View Post
    Found the fix. Somehow Disabled now so re-activated them in System Settings Keboard Shortcuts.

    Jerry
    Jerry,

    I'm gratified you found it in the settings. Now please share that with us: What did you do to get at those settings? Like, how did you find the dialog box where you you can set those settings?

    Please start from the top menu. BTW, I'm using the Gnome classic desktop but if you can direct us to the correct starting point it should make no difference.

    Thanks.
    -- Rasputin Paskudniak II (In pursuit of undomesticated, semi-aquatic avians)

  6. #16
    Join Date
    Apr 2006
    Location
    New Hampshire, U.S.A.
    Beans
    2,491
    Distro
    Ubuntu Development Release

    Wink Re: Alt-Tab and Alt-4 don't work

    Quote Originally Posted by rpaskudniak View Post
    Jerry,

    I'm gratified you found it in the settings. Now please share that with us: What did you do to get at those settings? Like, how did you find the dialog box where you you can set those settings?

    Please start from the top menu. BTW, I'm using the Gnome classic desktop but if you can direct us to the correct starting point it should make no difference.

    Thanks.
    Let me try. I think Unity keeps changing underneath me.
    Top right applet
    System Settings
    Keyboard
    Keyboard
    Shortcuts
    Windows
    Close Window
    Go to right end of line, press "Alt-F4"
    back up to Shortcuts
    Navigation
    Switch Applications
    Go to right end of line, press "Alt-Tab"
    press close

    Isn't this fun. Ctrl-Alt-Del doesn't do anything even though it is in the Shortcuts.

    Only thing I know about Gnome Classic is 10.04 LTS which I'm running on two notebooks - one because Quantal Quetzal doesn't supprt wireless, the other because Unity Overhead is sluggish on 1 GHz 512 MB.

    On 10.04, there is a vaguely similar set of menu choices

    System
    Preferences
    Keyboard Shortcuts
    whole bunch of similar shortcuts organized in a long list instead of categories.
    Ctrl-Alt-Del does work, gets Shutdown, Restart, Suspend, Hibernate. I use this all the time on 10.04.

    Do note in general for what I do, Unity requires a lot more keystrokes/mouse actions than 10.04 does. Could well depend on what applications you use.

    Have fun. I wonder what long standing defaults will change next.

    Jerry

  7. #17
    Join Date
    Nov 2011
    Location
    West Virginia
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Alt-Tab and Alt-4 don't work

    Quote Originally Posted by jerrylamos View Post
    Isn't this fun. Ctrl-Alt-Del doesn't do anything
    Works for me.

  8. #18
    Join Date
    Apr 2006
    Location
    New Hampshire, U.S.A.
    Beans
    2,491
    Distro
    Ubuntu Development Release

    Cool Re: Alt-Tab and Alt-4 don't work

    Updates are still disabling Alt-F4 and Alt-Tab. At least system settings still works.

    Jerry

  9. #19
    Join Date
    May 2008
    Location
    Brooklyn
    Beans
    160
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Alt-Tab and Alt-4 don't work

    I win! Though at the cost of publicly confessing to jerkhood.

    I've been looking for the executable because I did not see it in the [Applications]->[System Tools]->[Preferences] menu. In fact, I couldn't see the Preferences menu at all. Why?

    Because my inner Mr. Spock was logically searching the [System Tools] menu alphabetically. Well, an inspired madness had me do a sequential scan down the menu and there it was - near the top of the {system Tools] menu. And there I found the CompizConfig-settings-manager, the very thing that many have stated is the solution to this problem.

    Scroll to the bottom category, Windows Management, check the box on Application Switcher, close the application and voila! Alt-Tab now works. And I've banging my head on the wall for this solution for over 2 weeks!

    BTW, the executable name is simply ccsm. (Path: /usr/bin/ccsm)

    I need to post this in a few threads.

    Yes, I claim it is a bug in the upgrade that application switching becomes disabled. But with an easy workaround, if you know where to look. (no always my strongest point._
    Last edited by rpaskudniak; June 10th, 2012 at 08:05 AM. Reason: Problem solved;
    -- Rasputin Paskudniak II (In pursuit of undomesticated, semi-aquatic avians)

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •