Results 1 to 4 of 4

Thread: dell m5030

  1. #1
    Join Date
    Apr 2006
    Beans
    57
    Distro
    Dapper Drake Testing/

    dell m5030

    Tring to install Ubuntu on a Dell m5030

    AMD Athlon II P360
    Ati Radeon 4250 Video Card
    4GB memory

    Can not install any verion Ubuntu.Gets to backround Screen and stops.

    Kubuntu will install Ok

  2. #2
    Join Date
    May 2008
    Beans
    4

    Smile Re: dell m5030

    I have a Dell M5030 running Ubuntu 11.10, when you install ubuntu hit and hold shift key to get menu then hit F6 I think to set boot options to nomodeset. This will allow you to install Ubuntu 11.10. Do not set auto login you have to set login to 2d to get a desktop. I am not quite sure if it is F6 or F5 but a menu will let you set nomodeset. Now after you log in to the desktop go ahead and do update install all drivers need for video. Once done reboot and make all change you want to spice up your machine. I hope this helps and sorry for the poor typing and spotty tech help not too goood at it.

  3. #3
    Join Date
    Apr 2012
    Beans
    30

    Re: dell m5030

    Quote Originally Posted by fred0843 View Post
    Tring to install Ubuntu on a Dell m5030

    AMD Athlon II P360
    Ati Radeon 4250 Video Card
    4GB memory

    Can not install any verion Ubuntu.Gets to backround Screen and stops.

    Kubuntu will install Ok
    glad to help a fellow m5030 user

    just use the (e)dit option at bootup and replace "quiet splash" with nomodeset
    hit f10 and you are set.

    try it.
    thanks

  4. #4
    Join Date
    Jan 2007
    Location
    Ridgeland WI US
    Beans
    464
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: dell m5030

    Thanks all,

    I had the same problem - boot to hung screen.
    My fix was to edit /boot/grub/grub.cfg to add nomodeset. I left quiet splash there. Now I boot from grub with no manual edits.

    Beware if you do this. The next kernel update will rewrite grub.cfg. You will have to tweak this every kernel upgrade that affects the version number.

    Looks like the correct fix is to edit /etc/grub.d/10-linux
    I tried this and it worked for me.
    Add this code around line 73 after the $vt_handoff loop:
    Code:
    for word in $GRUB_CMDLINE_LINUX_DEFAULT; do
      if [ "$word" = splash ]; then
        GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT nomodeset"
      fi
    done
    Then # update-grub2
    Each new kernel will run a new update-grub2 which now adds nomodeset to each menuentry in the 10_linux section, not elsewhere.
    Gigabyte GA-MA790GPT-UD3H - AMD Phenom II x3 720 - 8 GB RAM - 2009 - My first PC from parts!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •