Results 1 to 8 of 8

Thread: Audio & video sound stuttering in 12.04

  1. #1
    Join Date
    Jul 2008
    Beans
    120
    Distro
    Ubuntu 13.10 Saucy Salamander

    Question Audio & video sound stuttering in 12.04

    In a new 64 bit install of ubuntu 12.04 I get randomly choppy / stuttered sound in videos like http://watchtheguild.com and with ogg and mp3 sound playback. I only get the stuttering with the unity/gnome desktop, not if I log in with KDE.

    I've seen this with previous versions of ubuntu, so it's not necessarily a new issue with 12.04. I've uploaded my also info as a gzipped text file since I was 1k over the text file limit.

    I used thi script to generate the file:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    UPDATE: In case it was 64 bit not being ready for prime-time, I removed it and installed 32 bit ubuntu 12.04. I get the same exact issue. I'm attaching the 32 bit alsa debug file, too.
    Attached Files Attached Files
    Last edited by andrewdied; May 19th, 2012 at 10:26 PM. Reason: Updated information (64 vs 32 bit)

  2. #2
    Join Date
    Jul 2008
    Location
    Los Angeles, CA
    Beans
    30
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Audio & video sound stuttering in 12.04

    Do you have pulseaudio installed on your system?

    Rudy
    Desktop Dell 400sc, CPU Pentium 4 Dual Core,
    RAM 4G Dual Channel, Video ATI All In Wonder 8500 (128M), MyGica A680B-W7 USB HDTV Stick, Pioneer DVD-ROM/CD Burner, Turtle Beach Santa Cruz

  3. #3
    Join Date
    Jul 2008
    Beans
    120
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Audio & video sound stuttering in 12.04

    Yup. I'd tried disabling it based on some other posts, but all that did was make it so my laptop soft keys for sound didn't work -- sound was still stuttering.

  4. #4
    Join Date
    Jul 2008
    Location
    Los Angeles, CA
    Beans
    30
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Audio & video sound stuttering in 12.04

    I'm not sure what you mean by "disabling" it. You pretty much have to uninstall pulseaudio to get rid of it. Nothing else works in my experience.

    Rudy
    Desktop Dell 400sc, CPU Pentium 4 Dual Core,
    RAM 4G Dual Channel, Video ATI All In Wonder 8500 (128M), MyGica A680B-W7 USB HDTV Stick, Pioneer DVD-ROM/CD Burner, Turtle Beach Santa Cruz

  5. #5
    Join Date
    Feb 2012
    Location
    United States
    Beans
    104
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Audio & video sound stuttering in 12.04

    Maybe this problem is similar to that adityeah was having a while ago? My sound through alsa was stuttering almost like his, and his fix did the trick for me. (Still no sound from the internal speakers on my laptop, but at least I can get consistent sound from my headphone jack all the time, instead of sometimes!)

    http://ubuntuforums.org/showthread.php?t=1979191

  6. #6
    Join Date
    Jul 2008
    Beans
    120
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Audio & video sound stuttering in 12.04

    Quote Originally Posted by RudyG View Post
    I'm not sure what you mean by "disabling" it. You pretty much have to uninstall pulseaudio to get rid of it. Nothing else works in my experience.

    Rudy
    I followed the steps from this post: http://ubuntuforums.org/showthread.php?t=1471262&page=4

    What happened was I lost my soft keys for managing sound (volume, etc.) and it still stuttered. Looks like I'm using 1:1.1-0ubuntu15 version of pulseaudio (apt-cache showpackage pulseaudio).

  7. #7
    Join Date
    Jul 2008
    Beans
    120
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Audio & video sound stuttering in 12.04

    Quote Originally Posted by johnluke728 View Post
    Maybe this problem is similar to that adityeah was having a while ago? My sound through alsa was stuttering almost like his, and his fix did the trick for me. (Still no sound from the internal speakers on my laptop, but at least I can get consistent sound from my headphone jack all the time, instead of sometimes!)

    http://ubuntuforums.org/showthread.php?t=1979191
    Thanks for the link. I tried it, and it caused what showed in gnome alsa mixer to be completely blank -- no buttons to click, no options dropdowns. Blank like that it shows I have "Realtek ID 768". If I've left the modprobe file alone it shows "Realtek ALC268".

    Any idea how I otherwise tweak what drivers it's using, or why kde would work and not gnome/unity?
    Last edited by andrewdied; May 28th, 2012 at 02:25 AM. Reason: more info

  8. #8
    Join Date
    Jul 2008
    Beans
    1

    Re: Audio & video sound stuttering in 12.04

    Hi. I have similar problems with my IBM T60 with: "Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)"

    Sound works fine on Unity 2d and other non compiz shells.
    When I use Unity 3d sound stutter while watching full screen movies in mplayer or from youtube, listenning to music on banshee an switching appilcation windows.

    Trick with changing settings in /ets/modprobe.d/alsa-base.conf does not work.
    Now I have:
    snd-hda-intel model=thinkpad (sound stutter)
    I also tried:
    snd-hda-intel model=basic (sound works but still stutter)
    and
    options snd-hda-intel model=generic (sound does not work at all)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •