Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Mousekeys too slow

  1. #11
    Join Date
    Nov 2009
    Beans
    17

    Re: Mousekeys too slow

    OK. So, anybody have a workaround?

    I've thought of two. The first (and worst) is to put in a cronjob to run as often as possible to basically run this command:

    Code:
    xkbset ma 5 10 10 5 10
    That would be overkill, though.

    I've also thought about just re-directing the / * and - keys to run a script, but so far I haven't made progress on that. They seem already captured at a pretty low level.

    Barring any tips on getting Workaround 2 to work or a suggestion on a 3rd attempt, can anybody offer any insight into which package this should be reported against?

  2. #12
    Join Date
    Jan 2013
    Beans
    1

    Re: Mousekeys too slow

    Quote Originally Posted by bogustrumper View Post
    Sorry to resurrect an old thread, but since the above is relevant to my issue I thought I'd repost.

    I'm using mousekeys and a cheap wireless keyboard to use Ubuntu as a living room PC. Works great for most of what I want. However, I'm having a problem with mousekeys that's very closely related to this.

    I go through and set up everything using xkbset to get the cursor smoothly moving across the screen. Then I decide "Hmm, I need to right click. OK, press -, then 5 will be right click. OK, now time to press / and make 5 a left click again. Why, oh why, does my cursor jump all over the place now?"

    So, basically, after every press of / * - to change which button mouseclicks is simulating, I have to re-run xkbset. Really, really frustrating. If someone points me to a bugzilla page for this, I'd appreciate it. I'm tracking down all kinds of weird stuff related to mousekeys... seems like it's a neglected feature that's working its way out.

    [...]

    Any help with how to get these settings to stick around through normal mousekey use would be appreciated.
    I have that issue too, my solution was to use the "watch" command every second so basically I did:

    Code:
    watch -n 1  xkbset ma 60 10 10 5 10
    You could try to run it at startup, I haven't tested that yet.
    For more info in the "watch" command go here.
    Last edited by Grandsome; January 20th, 2013 at 07:30 PM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •