Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Nvidia problems after 12.04 Upgrade - white screen after boot

  1. #11
    Join Date
    Aug 2006
    Location
    Glasgow, Scotland
    Beans
    138
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    The 295.49 driver is now available from the precise-proposed repository.

    I was running 295.33 on my kubuntu precise install, and now it's happily running 295.49. No issues so far (10 mins!).
    Last edited by Pablo Pablovski; May 9th, 2012 at 10:57 PM.

  2. #12
    Join Date
    May 2012
    Beans
    4

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Okay, after a few hours of forum research (what fun!) I see what the issue is now. NVIDIA drivers 96 and 173 series are not compatible with X.org in Ubuntu 12.04. Luckily, Nvidia have confirmed they're working on an update to the 173 series, which is the one I need. So it's just a case of waiting for the update!

  3. #13
    Join Date
    Jan 2009
    Location
    Portland, OR
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Bogan

    I recall a previous resolution problem with a previous upgrade concerning the nvidia resolutions.

    Unfortunately, I do not recall the solution at the time, but it was probably an install of a legacy nvidia driver from the nvidia site.

    fwiw, nvidia lists the following legacy drivers for linux:
    unix drivers

    fyi, I started upgrading to GRUB2 last night.

    I used the guide here:
    GRUB2

    Everything was working well, so I then put this command into the terminal:
    Code:
    sudo upgrade-from-grub-legacy
    I did not run the following command right afterwards (now I wish I had):
    Code:
    rm -f /boot/grub/menu.lst*
    upon reboot, I was expecting to see the GRUB2 menu and the initialization for GRUB1.5 still came up, followed immediately by the dreaded error 15.

    GRUB2 is definitely installed, it worked through the chainloader, just now have to figure out how to purge the rest of the GRUB1.5 elements.

    more later...

    Quote Originally Posted by bogan View Post
    Hi!, keithwalker,

    This is a bit weird! The nvidia-current 295.40 driver is the bugged one all the fuss is about, but in anycase it does not support your video card!!

    The driver you want is v173.14.30, listed in Synaptic Package Manager as "nvidia-73"; you can install it from there, or, probably better still from Nvidia Driver Downloads under "GeForce>5 FX series.

    You may need to remove the existing driver and purge it, if the nvidia install does not do so; then reinstall.

    However, If it ain't broke, don't Fix it.

    If the nvidia-installer cmd was not found, that means there was no nvidia driver properly installed, at the time.

    Edit: As for the incomplete install, grub1.5 is ancient you should have grub2, which shows in the grub boot menu title as Grub 1.99!

    I suggest you run:
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get -f install
    sudo dpkg -a
    sudo apt-get autoremove
    If that does not fix it you will need to remove grub1.5 and install grub 2, but that is more complex.

    Chao!, bogan.
    Last edited by keithwwalker; May 10th, 2012 at 01:05 AM.

  4. #14
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi!, checkmateuk,

    You Posted:
    I have downloaded the v294.49 driver, but when I install it I have to apparently use the 'sudo service lightdm stop' command but when I do, everything shuts off and I'm left with a black screen with a little bit of text at the top about 'checking battery state' or something to that effect with a flashing cursor underneath. Am I supposed to know how to log back in from that point as I haven't seen it explained anywhere!
    That is because you are still in the Graphics mode [Ctrl+Alt+F7] but you have closed the Manager; so press 'Ctrl+Alt+F1' or F2-F6 and you will get a tty [Text Terminal] log-in prompt.

    There do whatever you need to do and then press 'Ctrl+Alt+F7' to return to graphics mode, or reboot.

    You can download the 173.xx driver from nvidia.com>Driver Downloads either by using the search function or selecting "beta & older drivers", though the 'latest' version is dated AUG 2010. [See the comment above about its incompatibility with 12.04 Xorg!]

    Chao!, bogan.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  5. #15
    Join Date
    Jan 2009
    Location
    Portland, OR
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Well I solved my Grub problem with Rescatux
    You insert it like you would a live boot disk cd, but it has a graphical interface which makes restoring your GRUB2 booter almost idiot proof!

    When I booted my disc, it too gave a 'grayed' out screen, but there was enough legibility for me to select the proper buttons to restore the GRUB2 program.

    Now the only remaining task is to restore my full screen resolution. I will try the nvidia drivers mentioned earlier in the thread.

    Thanks for the help!
    kw
    Last edited by keithwwalker; May 11th, 2012 at 06:57 AM.

  6. #16
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi!, All.

    There is a new nvidia driver version 295.53 available from nvidia downloads. This Link is for the 32 bit version, check you get the correct one.
    http://www.nvidia.co.uk/object/linux...driver-uk.html

    Edit: Updated Thursday May 17th;

    Code:
    nvidia-installer --latest
    now returns: v295.53 and the currently installed version, without altering anything.


    Code:
    nvidia-installer -f
    will install 295.53 after un-installing the previous version.

    NVNews says of version 295.53:
    QUOTE:
    Please note: This NVIDIA Linux graphics driver release supports GeForce 6xxx and newer NVIDIA GPUs,
    GeForce4 and older GPUs are supported through the 96.43.xx and 71.86.xx NVIDIA legacy graphics drivers.
    GeForce FX GPUs are supported through the 173.14.xx NVIDIA legacy graphics drivers.


    bogan.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  7. #17
    Join Date
    Apr 2010
    Beans
    69
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    I'm also having the grey screen issue with a cutout where Unity should be, and it's not displaying any open windows from either a LiveCD or fresh install.
    My PC is a Sony Vaio VGC-V2M with the GeForceFX 5700 on board GPU.

    Has anyone got the current 173 driver running correctly? I'd love to get Ubuntu 12.04LTS installed on this machine.

    Cheers....
    Dave
    Desktop - Sony Vaio VGC-V2M - Ubuntu 10.04.3
    Netbook - Acer Aspire One AO751h - Joli OS 1.2

  8. #18
    Join Date
    Jan 2009
    Location
    Portland, OR
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Instructions on how to load the driver here:
    http://ubuntuforums.org/showpost.php...8&postcount=13
    However, when I do automated updates, the driver is booted, and you have to load it manually again.... Wish Nvidia and Ubuntu dealt with this better.

    Quote Originally Posted by m0dcm View Post
    I'm also having the grey screen issue with a cutout where Unity should be, and it's not displaying any open windows from either a LiveCD or fresh install.
    My PC is a Sony Vaio VGC-V2M with the GeForceFX 5700 on board GPU.

    Has anyone got the current 173 driver running correctly? I'd love to get Ubuntu 12.04LTS installed on this machine.

    Cheers....

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •