Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Nvidia problems after 12.04 Upgrade - white screen after boot

  1. #1
    Join Date
    Jan 2009
    Location
    Portland, OR
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    [Solved] Nvidia problems after 12.04 Upgrade - white screen after boot

    This problem is solved, go to this thread for details of the updated nVidia driver:
    http://ubuntuforums.org/showthread.php?t=1977972
    Beware, that the Ubuntu update packager seems to remove the nVidia driver settings at this time, so update at your own risk!
    For instructions on the nVidia problem refer to the above mentioned thread, for the Grub1.5 to 2.0 issue read on, thanks!
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~
    I did the automatic upgrade from 11.10 to 12.04 and when the pc rebooted the GRUB 1.5 menu did not update to 12.04.

    I am running a dual boot system with the other partition running winxp.

    Anyway, in GRUB I select 11.10 (doesn't matter which version), and 12.10 boots up.

    Problem is the colors are washed out so much that I can barely see the sign in screen and the top bar.

    After I log in, I briefly see my old wallpaper (but not my desktop icons), then a white screen pops up and I can not see ANYTHING on the screen.

    I can ctrl-alt-f1 to get into the terminal, and that is barely legible (but something).

    Can anyone advise or link to one of these two possible solutions?

    Is there a way to do a complete new 12.04 installation on the ubuntu partition without wiping the data on the winxp or ubuntu partition (I have almost 15 years of my data on that partition)? If I use a CD, it tells me that I will delete everything. Further, trying to boot on the CD is not working anymore.

    Alternatively, it seems there is a layer over the screen, can this be disabled somehow, or how can I install the updates for a previous nvidia version or a fix?

    This is extremely frustrating, never had a problem like this, 11.10 ran perfect.
    Last edited by keithwwalker; May 20th, 2012 at 11:26 PM.

  2. #2
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi!, keithwalker,

    You Posted:
    Alternatively, it seems there is a layer over the screen, can this be disabled somehow, or how can I install the updates for a previous nvidia version or a fix?
    I think the 'invisibility' problem is a matter of the default Themes not being compatible with Gnome3, or vica versa. See my thread:http://ubuntuforums.org/showthread.php?t=1966094
    Though your description seems a bit more complex than just that.

    Do your Launcher Icons show up in Ubuntu 3D or gnome classic?

    What video card do you have, and is there an integrated GPU as well?

    I would suggest, instead of installing a previous nvidia driver, that you install the latest version 295.49: if you have an internet connection
    Code:
    sudo nvidia-installer -f
    will un-install the present driver and download and substitute 295.49.

    You have to run it from a text terminal without the x-server running. 'Ctrl_Alt+F1' and login at the tty prompt. If you come from a GUI started terminal you will need to enter
    Code:
    sudo service lightdm stop
    and enter 'Ctrl_Alt+F1' or F2 & login again at the tty, before entering the 'nvidia-installer -f' code.

    Afterwards reboot.

    Post here if you need more info.

    Chao!, bogan.
    Last edited by bogan; May 8th, 2012 at 03:36 PM. Reason: correction
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  3. #3
    Join Date
    Jun 2008
    Beans
    34

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    It seems like I'm having a similar issue with my install from Lucid.
    Quote Originally Posted by thatsmyboy View Post
    Just did a "fresh" install of Precise (12.04) over a lucid LTS box. I'm not sure which driver I'm using , so information to locate that would be welcome. as it stands I'm stuck looking at the desktop and navigating from there to applications - more likely clicking a document to launch the associated app.

  4. #4
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi!, thatsmyboy,

    If you have an nvidia gpu card, from a terminal run:
    Code:
     cat /sys/module/nvidia/version
    or, if you have an Internet connection
    Code:
    sudo nvidia-installer --latest
    You Posted:
    I'm stuck looking at the desktop and navigating from there to applications
    Which sounds as if you are running Gnome or Gnome Classic, but it is not obvious to me what the problem is you want help to solve, unless you are still running Lucid or have a 'White on White' Theme problem.

    Please Post details of your computer, especially video card.

    Also please clarify to what point your system boots, do you get a GUI Login screen, with the Unity Launcher and topbar Icons after login, or do you have the Applications Menu header top left, or both?

    Chao!, bogan.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  5. #5
    Join Date
    Jan 2009
    Location
    Portland, OR
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Thank you for the response Bogan.
    I am using Gnome Classic.
    My pc is a VCG-V620G all in one pc (desktop with pc built into back of lcd panel with laptop gpu)
    The gpu is a NVIDIA GeForce FX Go 5700.

    The GUI launcher is legible, but the colors are off.
    After login, the launcher icons do not show up, but I see a 'white shadow' where the launcher bar should be.
    The topbar is barely legible.
    The desktop screen seems to have a white layer atop it, but even before that loads after login, you can not see any desktop icons.

    I will try your advice and report back, thanks!

    Well I tried the
    Code:
    sudo nvidia-installer -f
    it said 'command not found'

    Will now try
    Code:
    sudo nvidia-installer --latest
    kww
    Last edited by keithwwalker; May 9th, 2012 at 04:53 AM.

  6. #6
    Join Date
    Jan 2009
    Location
    Portland, OR
    Beans
    64
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    My screen now renders correctly. I upgraded the nvidia driver with this command:

    Code:
    sudo apt-get install nvidia-current
    The current nvidia driver 295.40 loaded.
    There was some weird text flying by indicating that some packages weren't loaded in.

    Anyway, cut to the chase and the driver loaded in. I would say that this episode is solved, but the driver only offers two resolutions at this time:
    800x600
    1024x768

    Unfortunately, my resolution is 1280 x 768, but I will get by.

    When I find the resolution solution, I will post that and change the thread to solved.

    My upgrade build didn't complete, as GRUB 1.5 doesn't show 12.04 options as loading (still shows 11.10 and XP), even though I am clearly on 12.04. I will search or start another thread for that problem though.

    Thanks again!

  7. #7
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi!, keithwalker,

    This is a bit weird! The nvidia-current 295.40 driver is the bugged one all the fuss is about, but in anycase it does not support your video card!!

    The driver you want is v173.14.30, listed in Synaptic Package Manager as "nvidia-73"; you can install it from there, or, probably better still from Nvidia Driver Downloads under "GeForce>5 FX series.

    You may need to remove the existing driver and purge it, if the nvidia install does not do so; then reinstall.

    However, If it ain't broke, don't Fix it.

    If the nvidia-installer cmd was not found, that means there was no nvidia driver properly installed, at the time.

    Edit: As for the incomplete install, grub1.5 is ancient you should have grub2, which shows in the grub boot menu title as Grub 1.99!

    I suggest you run:
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get -f install
    sudo dpkg -a
    sudo apt-get autoremove
    If that does not fix it you will need to remove grub1.5 and install grub 2, but that is more complex.

    Chao!, bogan.
    Last edited by bogan; May 9th, 2012 at 09:53 AM.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  8. #8
    Join Date
    May 2012
    Beans
    4

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi, I'm having problems with this white screen issue too.
    If I install the 'latest' Nvidia driver (v295.40) I get offered a maximum screen resolution of 1024x768 (I want 1280x1024)
    However, attempts to install the v173.14.30 driver just throw up the message:
    The following packages have unmet dependencies:

    nvidia-173: Depends: x11-common (>= 1:7.0.0) but 1:7.6+12ubuntu1 is to be installed
    Depends: xorg-video-abi-10 but it is not going to be installed
    Depends: xserver-xorg-core (>= 2:1.8.99.905-1ubuntu3) but 2:1.11.4-0ubuntu10.2 is to be installed
    I hear the v295.49 might solve some issues, but as a newbie I have no idea how to get this version!

  9. #9
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi!, checkmateuk,

    Download the 295.49 driver from nvidia.com /Driver downloads and run the file from a text terminal. but be sure it is the right version for your video card, it is not for FX series cards.

    Check out MAFoElffen's Step-by-Step Trouble shooter in the Sticky of 'Installations & Upgrades': Post #1. There is a full Index in Post #2.
    http://ubuntuforums.org/showthread.p...43535&page=101

    The instructions you want are in Post #280 about page 71.

    Chao!, bogan.
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  10. #10
    Join Date
    May 2012
    Beans
    4

    Re: Nvidia problems after 12.04 Upgrade - white screen after boot

    Hi Bogan, many thanks for your prompt reply! Let me clarify:

    I do indeed have an FX series card - it's a GeForce FX 5700. With the clean Ubuntu 12.04 install I get the 'White Screen of Death'. I have to select 2D mode to run anything, but it's painfully slow.

    With installation of the v295.40 (aka. 'Latest') driver I get everything successfully working, except my screen is no longer detected (Displays calls it 'Laptop') and I'm left with a maximum selectable resolution of 1024x768.

    When I attempt to install the recommended driver for my series of graphics card (v173.14.30) I get the message mentioned in my post below.

    So if I can't install the older driver and the new one isn't supposed to be compatible with an ageing FX5700, what are my options?

    I have downloaded the v294.49 driver, but when I install it I have to apparently use the
    sudo service lightdm stop
    command but when I do, everything shuts off and I'm left with a black screen with a little bit of text at the top about 'checking battery state' or something to that effect with a flashing cursor underneath. Am I supposed to know how to log back in from that point as I haven't seen it explained anywhere!

    EDIT: I managed to install the 294.49 driver, but this resulted in the same resolution problem (except this time my max selectable was 800x600!). How can I get the 173.x driver installed despite the 'unmet dependencies'?
    Last edited by checkmateuk; May 9th, 2012 at 09:57 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •