Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Lemur Ultra, 12.04: no HDMI device in sound settings

  1. #11
    Join Date
    Nov 2006
    Beans
    124

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Quote Originally Posted by isantop View Post
    My guess is that this is related to the Intel Graphics issue. Try fixing that problem and see if that comes back.
    What intel graphics issue?

    Anyway, my previous post is bogus. I have since realized that when I issue the pulseaudio --kill command, it does kill the daemon, but it then starts right back up under a new pid. So I really was restarting it without realizing it. I guess my next attempt will be to see if there is some sort of udev event when I plug in the HDMI cable. If so, it might be possible to create a rule which restarts pulseaudio. Seems kludgy, but it ought to work.

  2. #12
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,557
    Distro
    Ubuntu

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Quote Originally Posted by shochatd View Post
    What intel graphics issue?

    Anyway, my previous post is bogus. I have since realized that when I issue the pulseaudio --kill command, it does kill the daemon, but it then starts right back up under a new pid. So I really was restarting it without realizing it. I guess my next attempt will be to see if there is some sort of udev event when I plug in the HDMI cable. If so, it might be possible to create a rule which restarts pulseaudio. Seems kludgy, but it ought to work.
    Please see this thread: http://ubuntuforums.org/showthread.php?t=2014669
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  3. #13
    Join Date
    Apr 2012
    Beans
    131
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Quote Originally Posted by shochatd View Post
    when I issue the pulseaudio --kill command
    In case it helps anyone else, you have to issue that command as the logged in user, not as root.

    For me, while this correctly makes the HDMI sound device appear, it does not make HDMI sound output work. That is, using Settings/Sound and then selecting the HDMI device and then using "Test Sound" produces no sound (whereas selecting Headphones or selecting Analogue Output and using "Test Sound" produces sound and from the correct place).

    Any suggestions?

  4. #14
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,557
    Distro
    Ubuntu

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Quote Originally Posted by Newbunto View Post
    In case it helps anyone else, you have to issue that command as the logged in user, not as root.

    For me, while this correctly makes the HDMI sound device appear, it does not make HDMI sound output work. That is, using Settings/Sound and then selecting the HDMI device and then using "Test Sound" produces no sound (whereas selecting Headphones or selecting Analogue Output and using "Test Sound" produces sound and from the correct place).

    Any suggestions?
    Please test the sound using an audio file or video, as the test sound item has been known to be unreliable when using configurations with more than two audio channels.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  5. #15
    Join Date
    Apr 2012
    Beans
    131
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Unfortunately, no difference. Using Rhythmbox on an MP3 file. Plays fine through Headphones (really external speakers) or built-in speakers. No sound through HDMI.

    The Sound Output device is showing as:

    HDMI / DisplayPort 2
    GF116 High Definition Audio Controller

    The mode is "Digital Stereo (HDMI) Output".

    NB: This is a bonp5.

  6. #16
    Join Date
    Mar 2007
    Location
    Massachusetts
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Quote Originally Posted by Newbunto View Post
    Unfortunately, no difference. Using Rhythmbox on an MP3 file. Plays fine through Headphones (really external speakers) or built-in speakers. No sound through HDMI.

    The Sound Output device is showing as:

    HDMI / DisplayPort 2
    GF116 High Definition Audio Controller

    The mode is "Digital Stereo (HDMI) Output".

    NB: This is a bonp5.
    What is your bonp5 connected to via HDMI?

    Is the TV/Monitor set to play sound from the HDMI?

    Are you sure that the HDMI cable is good and compatible with both the bonp5 and the TV/Monitor?

  7. #17
    Join Date
    Apr 2012
    Beans
    131
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Quote Originally Posted by jbelmonte View Post
    What ...?
    All good questions and they did lead to the answer. Thanks!

    I am embarrassed to admit that the explanation was very simple ... monitor does not have built-in speakers (I assumed it did) and I did not have speakers plugged in to the audio-out connector of the monitor.

    Plugging speakers into the monitor confirms that sound via HDMI does work.

    So, yes, sound is enabled on the monitor (there is mute and volume control) and the HDMI cable is adequate for this combination (I haven't heard of an HDMI cable where sound doesn't work - as far as I know sound data is just carried on the same pins as video data, interspersed).

    (Like the person who started this thread, the HDMI device does not appear for me automatically in the Sound settings but we have a workaround for that.)

  8. #18
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,557
    Distro
    Ubuntu

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    Quote Originally Posted by Newbunto View Post
    All good questions and they did lead to the answer. Thanks!

    I am embarrassed to admit that the explanation was very simple ... monitor does not have built-in speakers (I assumed it did) and I did not have speakers plugged in to the audio-out connector of the monitor.

    Plugging speakers into the monitor confirms that sound via HDMI does work.

    So, yes, sound is enabled on the monitor (there is mute and volume control) and the HDMI cable is adequate for this combination (I haven't heard of an HDMI cable where sound doesn't work - as far as I know sound data is just carried on the same pins as video data, interspersed).

    (Like the person who started this thread, the HDMI device does not appear for me automatically in the Sound settings but we have a workaround for that.)
    I believe they're separate pins, but the same cable.

    Sounds good, I'm glad you got it figured out. That's one thing you do have to be careful for.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  9. #19
    Join Date
    Nov 2006
    Beans
    124

    Re: Lemur Ultra, 12.04: no HDMI device in sound settings

    I decided to give this one more try before 12.10 comes along and it appears to be fixed. I have taken numerous updates (including several kernel updates) since I last tried so no idea when exactly the fix arrived. Now, plugging in the HDMI cable (attached to my TV at the other end) causes the HDMI to appear as an available output in Sound Settings. No restart required. No killing of Pulse Audio required. There is still the minor issue that unplugging the HDMI does not revert things completely -- the HDMI stays on the list and the Workspace Switcher thinks the display is still extended. But it seems that all it takes is one sleep/wakeup cycle to get things back to the no HDMI one-display state. However, this thread was about the HDMI not becoming available when first connected to the Lemur Ultra, so that appears to be fixed.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •