Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: My server can't ping anything

  1. #11
    Join Date
    Mar 2012
    Beans
    13

    Re: My server can't ping anything

    It's possible that they block ICMP echo req by default but I really don't know that. I did ask them (via email), so let's see what they'll reply. Is there anything else I could do?

  2. #12
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: My server can't ping anything

    Not much until they reply. Everything seems configured correctly. Maybe they are blocking ping to try to make attacks more difficult.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  3. #13
    Join Date
    Mar 2012
    Beans
    13

    Re: My server can't ping anything

    Ok. Thank you for your help so far.

  4. #14
    Join Date
    Mar 2012
    Beans
    13

    Re: My server can't ping anything

    I got a response from my hosting company regarding the ping issue. They say they are not blocking ICMP/Ping by default. So a ping should work. But it isn't. What can do now?

  5. #15
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: My server can't ping anything

    Did you check in /var/log/ufw.log whether ufw is blocking some icmp traffic?

    That is the best way to know if ufw is blocking it. If it's not, you need to look into other possibilities, like network, etc.

    I have read again your iptables list and the before.rules and can't see anything wrong.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  6. #16
    Join Date
    Mar 2012
    Beans
    13

    Re: My server can't ping anything

    There are some [UFW BLOCK] lines in the log but nothing that would be indicating a problem with outgoing pings...

    A ping to localhost is just working fine.

    I did also traceroute somedomain.com. It dies on the router on my provider. Does this mean they do block pings? Is their firewall too strict?

    Code:
    traceroute to bbc.co.uk (212.58.241.131), 30 hops max, 60 byte packets
     1  cc.dd.ny.adsl (XXX.XX.XX.97)  3.313 ms  3.948 ms  4.614 ms
     2  * * *
     3  * * *
     4  * * *
     5  * * *
     6  * * *
     7  * * *
     8  * * *
    ...
    30  * * *

  7. #17
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: My server can't ping anything

    It sounds like it. But they replied the opposite, under the assumption that person knew what he/she was talking about.

    I suggest you follow up that support ticket/question and send them the above tracert result. Let them know you have tried lots of things to investigate this and it seems the only explanation is that they do block pings since your firewall is not blocking them (nothing in the log) and you have internet access, it's not like you don't.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •