Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How do I enable nvidia drivers in recovery mode?

  1. #1
    Join Date
    Nov 2011
    Beans
    1,552
    Distro
    Xubuntu 14.10 Utopic Unicorn

    How do I enable nvidia drivers in recovery mode?

    How do I enable nvidia drivers in recovery mode?

    I installed 12.04 in text mode with the alternate ISO, 64-bit. That booted into a solid purple screen. In recovery, lsmod shows nouveau is loaded. jockey says nvidia_current and nvidia_current_updates are "disabled" and complains that modinfo cannot find their modules.

    apt says nvidia-common is installed and is the newest version.

    I've updated from recovery mode, which included a new kernel. No change. FailsafeX in recovery mode doesn't work, just puts me back to the main recovery menu.

    (As an aside, the *only* way I have successfully installed 12.04 on this GTX 550TI is to install 11.10 and then upgrade. Thought text-mode would work.)

  2. #2
    Join Date
    Dec 2006
    Location
    N. Virginia, USA
    Beans
    504
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: How do I enable nvidia drivers in recovery mode?

    The proprietary nVidia drivers in the 12.04 repositories have a serious bug that affects a number of cards. The current nvidia-common and nvidia-common-upgrades should be uninstalled in a text mode (including Ctrl-Alt-F2) along with nvidia-config and nvidia-config-updates. Download the nVidia 295.49 drivers from nVidia's site and install those from the .run file by following the directions in their readme file. Should work fine.
    Linux User #448337
    Tanker Bob's PDA Page; Tanker Bob's MTR Blog
    Gigabyte EP45-UD3L MB, Q9650 Core 2 Quad @ 3.3 GHz (OC), 8 GB OCZ Platinum DDR2 SDRAM, EVGA GeForce 8800 GTS w/640MB, 40 GB Intel SSD, 2.0 TB x2 SATA RAID1, Ubuntu 13.04 x86_64

  3. #3
    Join Date
    Nov 2011
    Beans
    1,552
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: How do I enable nvidia drivers in recovery mode?

    Quote Originally Posted by Tanker Bob View Post
    The proprietary nVidia drivers in the 12.04 repositories have a serious bug that affects a number of cards. The current nvidia-common and nvidia-common-upgrades should be uninstalled in a text mode (including Ctrl-Alt-F2) along with nvidia-config and nvidia-config-updates. Download the nVidia 295.49 drivers from nVidia's site and install those from the .run file by following the directions in their readme file. Should work fine.

    I've used Nvidia's drivers in 12.04 with this card with no problems before. I needed to reinstall and used the alternate ISO to avoid needing to install 11.10 first. !2.04 won't install here on my Nvidia card because of that bug. It boots and quits before getting to the boot screen. Going with 11.10 and then a dist-upgrade to 12.04 they're installed and work fine.

  4. #4
    Join Date
    Dec 2006
    Location
    N. Virginia, USA
    Beans
    504
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: How do I enable nvidia drivers in recovery mode?

    Sorry, I misunderstood. Glad that your issue is solved.
    Linux User #448337
    Tanker Bob's PDA Page; Tanker Bob's MTR Blog
    Gigabyte EP45-UD3L MB, Q9650 Core 2 Quad @ 3.3 GHz (OC), 8 GB OCZ Platinum DDR2 SDRAM, EVGA GeForce 8800 GTS w/640MB, 40 GB Intel SSD, 2.0 TB x2 SATA RAID1, Ubuntu 13.04 x86_64

  5. #5
    Join Date
    Nov 2011
    Beans
    1,552
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: How do I enable nvidia drivers in recovery mode?

    OK, I'm at the grub menu, trying to set "nomodeset". I see a rather suspiciously long list of options, including the following:

    setparams 'Ubuntu, with Linux 3.2.0.24-generic
    recordfail
    gfxmode $linux_gfx_mode
    insmod gzio
    ins mod part_msdos
    insmod ext2
    set root='(hd0,msdos1)
    .....

    That doesn't look like any set of boot options I've seen.

    [Edit: Well, interesting: I did add nomodeset to that set of boot options and it booted into lubuntu. And, yes, I did download the *Ubuntu 12.04* ISO. Very strange.]
    Last edited by buzzingrobot; May 5th, 2012 at 05:07 PM.

  6. #6
    Join Date
    Nov 2011
    Beans
    1,552
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: How do I enable nvidia drivers in recovery mode?

    Quote Originally Posted by Tanker Bob View Post
    Sorry, I misunderstood. Glad that your issue is solved.
    It isn't solved. I've been at this 6 hours.

  7. #7
    Join Date
    Dec 2006
    Location
    N. Virginia, USA
    Beans
    504
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: How do I enable nvidia drivers in recovery mode?

    Quote Originally Posted by buzzingrobot View Post
    It isn't solved. I've been at this 6 hours.
    That's about how long it took me until I learned about the nVidia 295.40 issues.

    To answer your question about recovery mode, you need to edit /etc/X11/xorg.conf to activate the nVidia drivers. I'll post my entire xorg.conf file here so that you can cut and past what you wish. The key line for your question is Device "nvidia".

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 295.49  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Tue May  1 00:54:24 PDT 2012
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Coolbits" "5"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Linux User #448337
    Tanker Bob's PDA Page; Tanker Bob's MTR Blog
    Gigabyte EP45-UD3L MB, Q9650 Core 2 Quad @ 3.3 GHz (OC), 8 GB OCZ Platinum DDR2 SDRAM, EVGA GeForce 8800 GTS w/640MB, 40 GB Intel SSD, 2.0 TB x2 SATA RAID1, Ubuntu 13.04 x86_64

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How do I enable nvidia drivers in recovery mode?

    Have you used nomodeset on first boot after install? My nVidia is older but has same issue.

    How to set NOMODESET and other kernel boot options in grub2
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions
    I had to do this with my Nvidia 9600GT:
    To install Ubuntu, boot from the cd press any key at accessibility circle and keyboard, press F6 and then select the nomodeset option.
    USB boot - At the menu press tab on the first option to edit the boot options and replaced the 'splash' option with 'nomodeset'.
    then
    On first boot after install, press e on getting the GRUB bootloader.
    Hold shift from BIOS boot to get menu if only one system installed.
    Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place
    Press Ctrl and X to boot (low graphics mode), install nVidia driver suggested my Ubuntu

    From command line you can purge & reinstal or install:

    Manual install:
    sudo apt-get --reinstall nvidia-current
    sudo modprobe nvidia

    Different thread had this - I think the purge housecleans out old settings as well:
    sudo apt-get update
    sudo apt-get remove --purge nvidia-*
    sudo apt-get install nvidia-current
    sudo apt-get upgrade
    sudo reboot
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #9
    Join Date
    Nov 2011
    Beans
    1,552
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: How do I enable nvidia drivers in recovery mode?

    Thanks, Bob. There is no xorg.conf here.

    I purged nvidia_common. Apt wanted to remove ubuntu-desktop*, too. I said yes, figuring why not at this point. When I reinstalled nvidia_common and ubuntu-desktop, it brought down hundreds of KDE files. then as I mentioned before, it booted into Lubuntu. Very strange.

    I'm burning 11.10 on USB to go that route. I know that works. 12.04 LiveCD's do not boot here (altho all the betas did). A 12.04 USB boots, but that's what led to this thread.

    Why did I reinstall if I had a working 12.04? I installed KDE on it. Liked it and installed Kubuntu. But, I didn't like Kubuntu as much as KDE on Ubuntu. Not as polished. Jumpy. Hence, this reinstall quagmire. Shudda left well enough alone, lol.

  10. #10
    Join Date
    Nov 2011
    Beans
    1,552
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: How do I enable nvidia drivers in recovery mode?

    Quote Originally Posted by oldfred View Post
    Have you used nomodeset on first boot after install? My nVidia is older but has same issue.
    [/QUOTE]

    Thanks, Fred. I did try nomodeset. See upthread for the weird boot options I saw when i got into the grub menu. I'm thinking something was really wrong with the ISO I downloaded.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •