Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Keyboard Layout Nightmare

  1. #1
    Join Date
    Mar 2009
    Beans
    46

    Keyboard Layout Nightmare

    I wanna setup three keyboard language layouts: English(US), Romanian and Russian(phonetic)
    Previously there was a simple fine way of setting keyboard language via settings. Now, it is a nightmare. First of all, layouts and languages are spread around all settings(keyboard layout, language settings, keyboard input method, input method switcher). In some settings(IBus preferences) there is no Romanian layout option even though I have it in other places. Even though IBus is started with default settings(Ctrl Space to activate and Alt Shift_L to change layout) it does not work at all.

    Please help me to set up my three languages and switch them with Alt+Left Shift.

    Regards,
    Christian.

  2. #2
    Join Date
    Jun 2008
    Beans
    1,096
    Distro
    Ubuntu Studio

    Re: Keyboard Layout Nightmare

    Which version of ubuntu Studio?

  3. #3
    Join Date
    Mar 2009
    Beans
    46

    Re: Keyboard Layout Nightmare

    12.04

  4. #4
    Join Date
    Jun 2008
    Beans
    1,096
    Distro
    Ubuntu Studio

    Re: Keyboard Layout Nightmare

    Working with layouts in Xfce is simply bad. It gave me all kinds of bugs.
    So, I find out that the best thing to do is to make a startup script for setxkbmap command. Something like this

    Code:
    setxkbmap -option compose:rwin,lv3:ralt_switch,grp:alt_shift_toggle us,ru -variant ,
    You need to find out the names for layouts and variants you need. Look here /usr/share/X11/xkb/symbols
    Open each definition you need to find out the variants
    I guess ro is for romania, so

    Code:
    setxkbmap -option compose:rwin,lv3:ralt_switch,grp:alt_shift_toggle us,ro,ru -variant ,,
    Last edited by jejeman; May 5th, 2012 at 04:55 PM.

  5. #5
    Join Date
    Jun 2008
    Beans
    1,096
    Distro
    Ubuntu Studio

    Re: Keyboard Layout Nightmare

    Other way to go is to install xfce4-xkb-plugin. It's really buggy, never does what it should. Broke shortcuts input in Blender.

    That's why i recommended script.

  6. #6
    Join Date
    Mar 2009
    Beans
    46

    Re: Keyboard Layout Nightmare

    Thank you for your answers Jejeman. My problem is that I cannot switch the keyboard, the shortcuts do not work at all. I can set any language but I am not able to switch them because the iBus does not respond as expected. Previously I had keboard layouts, I was able to set any shortcut but now all that is gone.

  7. #7
    Join Date
    Mar 2009
    Beans
    46

    Re: Keyboard Layout Nightmare

    Here is the solution I found on a different thread( http://ubuntuforums.org/search.php?d...&starteronly=1 ) and it really works for me (quote from user LewisTM):

    1) Go to the Settings Manager/Keyboard/Layout tab and ensure that "Use system defaults" is set. Do not modify the rest.
    2) Install xfce4-goodies or just xfce4-xkb-plugin
    3) This will allow you to add a Keyboard Layouts plugin to your panel. Do so then right-click it and choose Properties.
    4) Set everything to your liking: layout, switch keys, etc.

  8. #8
    Join Date
    Mar 2012
    Beans
    10

    Re: Keyboard Layout Nightmare

    hello, dle Ionescu

    Can you please detail steps 3 & 4. Where is the new Keyboard Layout that should appear after I installed the plug-in?

    I'm a beginner Ubuntu user and I'm facing the same challenge. I would like to easily switch between Ro/ En/ De/ Fr

    I completed steps 1 & 2 from your explanation, and I'm also running the last Ubuntu Studio.

    Mersi fain,
    Adi

  9. #9
    Join Date
    Mar 2012
    Beans
    10

    Re: Keyboard Layout Nightmare

    Just to give you all the details, after I installed the plug-in, my setting are:

    Settings >> Input Method Switcher >> ibus (this was my original setting to switch between Fr/En) - do I live it like this?

    Settings >> Settings Manager >> Keyboard >> Application Shortcuts >> xfce4-display-settings --minimal

    Thanks again!

  10. #10
    Join Date
    Oct 2012
    Beans
    5

    Re: Keyboard Layout Nightmare

    Dear Ionescu, Sir, a million thank you! (can I also write to you in Romanian? or is against the forum policies? don't know... however) you made my day!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •