Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Workspace switcher only showing primary screen in Gnome-shell

  1. #1
    Join Date
    Jan 2010
    Beans
    17

    Workspace switcher only showing primary screen in Gnome-shell

    I have tweaked Gnome-shell (3.4) to have workspaces extend over both screens in my dual-monitor setup.
    Everything is working fine, except that the workspace switcher/pager only shows the windows on the primary screen.

    This is a bit confusing because I have to browse all the workspaces to find the windows that are on the secondary screen.

    Does any solution exist to this problem ?

  2. #2
    Join Date
    Oct 2006
    Location
    Austin, Texas, USA
    Beans
    36
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Workspace switcher only showing primary screen in Gnome-shell

    I have the same issue. I would suggest you try to install dconf-editor using the Software Center. Run it from a command like (sudo dconf-editor) and navigate to org/gnome/shell/overrides. You'll see a setting there related to multiple desktops switching, it should be the last setting listed. It will be checked to provide the behavior you are seeing. Uncheck it, close dconf-editor and see what switching desktops looks like. You may need to log out of Gnome and log back in.

    I tried this on my Ubuntu 12.04 (upgraded from 11.10) but it didn't seem to work. I do think this is the correct way to change this behavior though.

  3. #3
    Join Date
    Jan 2010
    Beans
    17

    Re: Workspace switcher only showing primary screen in Gnome-shell

    No, checking the option you are mentioning will /disable/ workspace switching on the secondary monitor.
    I don't want to change this behavior: I only want the pager to /display/ the windows that are on the secondary monitor (for each workspace).

    Best regards,
    M

  4. #4
    Join Date
    Oct 2009
    Location
    Austria
    Beans
    44
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Workspace switcher only showing primary screen in Gnome-shell

    I need this feature too. But this seems not to be possible at all ...

    Not even through an extension or plugin ...

  5. #5
    Join Date
    Apr 2012
    Beans
    6

    Re: Workspace switcher only showing primary screen in Gnome-shell

    The previously described solution by PirateFanAZ works:

    Open dconf-editor > org > gnome > shell > overrides

    Uncheck the box labeled "workspace-only-on-primary"

    I did not even have to restart Gnome, it worked right away.

    At least it works with an out-of-the-box Arch Linux with current Gnome installed... Your milage might vary with current Ubuntu.
    Last edited by draptik; July 2nd, 2012 at 08:13 PM.

  6. #6
    Join Date
    Jun 2006
    Location
    Brisbane Australia
    Beans
    713

    Re: Workspace switcher only showing primary screen in Gnome-shell

    Quote Originally Posted by draptik View Post
    The previously described solution by PirateFanAZ works:
    Yes, but as the OP says above that is not the problem he is describing here. Also, changing that dconf setting is cumbersome and old advice anyhow. Recently that setting was added as a simple toggle button in gnome-tweak tool which is more or less the "official" place to set gnome-shell options.

  7. #7
    Join Date
    Oct 2009
    Location
    Austria
    Beans
    44
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Workspace switcher only showing primary screen in Gnome-shell

    Doesn't even one of the gnome shell dev team use more than one screen?

    It's really shocking how such basic bug has never been fixed ...

  8. #8
    Join Date
    Jul 2011
    Location
    /dev/sda1
    Beans
    352
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Workspace switcher only showing primary screen in Gnome-shell

    The workspace selection is for the primary monitor only.

  9. #9
    Join Date
    Jun 2006
    Location
    Brisbane Australia
    Beans
    713

    Re: Workspace switcher only showing primary screen in Gnome-shell

    Quote Originally Posted by lolpenguin View Post
    The workspace selection is for the primary monitor only.
    That's just the default option. If you want it on all monitors then change it by just pressing the button in gnome-tweak-tool/Shell.

  10. #10
    Join Date
    Oct 2009
    Location
    Austria
    Beans
    44
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Workspace switcher only showing primary screen in Gnome-shell

    It's interesting, but all over the internet people ask the same question and always get the same wrong answer ... :-\

    @markbl: di you read the previous posts? michael and me already have this option enabled. Switching itself is NOT the problem - IT WORKS!

    The problem is, that the workspace SWITCHER is only displayed at one screen (as the thread title says ...).

    You can't drag a window to another workspace on the second screen, because there is no workspace preview for that screen where you could drop that window.

    If you want to drag a window from workspace 1/screen 2 to workspace 2/screen 2 it's not possible. You have to move it to workspace 2/screen 1 (this is shown on the workspace switcher), switch there and then move it to the second screen ...
    horrible ...
    Last edited by mojo2012; July 13th, 2012 at 08:06 AM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •