Results 1 to 10 of 10

Thread: 12.04 volume maxed at login

  1. #1
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,140
    Distro
    Xubuntu 13.04 Raring Ringtail

    12.04 volume maxed at login

    using hdmi audio via my gtx 550 ti gpu
    when i login my volume is at 100% but it is set at 30% (according to the applet)
    when i lower the vole it drops to what the applet says
    anyone know a command to set the volume at login to the applets volume?
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  2. #2
    Join Date
    Mar 2008
    Beans
    90
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 12.04 volume maxed at login

    What you describe is exactly the same as a bug I filed back in 2010:
    https://bugs.launchpad.net/ubuntu/+s...io/+bug/598308

    I have yet to find a solution, but there are some possible solutions listed in the bugs comments.
    Last edited by buddyd16; May 2nd, 2012 at 03:42 PM.
    Desktop: Home Built Core i7 - Ubuntu/Windows
    Netbook: Asus Eeepc 900HA - Arch w/ Openbox
    Laptop:2010 Macbook Pro 13 - Mac osx w/ Ubuntu/Fedora Virtual Machines
    Tablet:Asus Transformer 32gb

  3. #3
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,140
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: 12.04 volume maxed at login

    running either of these scripts at login works
    Code:
    #!/bin/sh
    VOL=`amixer get Master | sed 's/back /\n/;s/ \[/\n/' | tail -2 | head -1`
    amixer set Master $(($VOL+1)) > /dev/null
    amixer set Master $VOL
    or (simulates pressing volume keys on keyboard ** xdotool is not installed by default)
    Code:
    #!/bin/sh
    xdotool key XF86AudioLowerVolume
    xdotool key XF86AudioRaiseVolume
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  4. #4
    Join Date
    Mar 2008
    Beans
    90
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 12.04 volume maxed at login

    excellent thanks for the scripts, I will make sure to give them a try.

    Does this take care of the login sound playing at max level or does this script run after that sound clip plays?
    Desktop: Home Built Core i7 - Ubuntu/Windows
    Netbook: Asus Eeepc 900HA - Arch w/ Openbox
    Laptop:2010 Macbook Pro 13 - Mac osx w/ Ubuntu/Fedora Virtual Machines
    Tablet:Asus Transformer 32gb

  5. #5
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,140
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: 12.04 volume maxed at login

    before or during (determined at random)
    you could make the login sound play in the script to make it go before
    Code:
    #!/bin/sh
    VOL=`amixer get Master | sed 's/back /\n/;s/ \[/\n/' | tail -2 | head -1` 
    amixer set Master $(($VOL+1)) > /dev/null 
    amixer set Master $VOL
    /usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
    simply add to start up and remove the login sound from startup since it will be in the script
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  6. #6
    Join Date
    Sep 2011
    Beans
    71
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 volume maxed at login

    I too am having this problem but these scripts do not work as my device (HDMI out through a HD5770) isn't visible in amixer. Any ideas?

  7. #7
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,140
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: 12.04 volume maxed at login

    not even the xdotool script?
    how do you control your volume? can you?
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  8. #8
    Join Date
    Sep 2011
    Beans
    71
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 volume maxed at login

    It's all present and correct in the applet and sound settings but there's no sign of it on amixer, which is bizarre.

  9. #9
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,140
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: 12.04 volume maxed at login

    Code:
    pacmd set-sink-volume 0 3500
    does that affect your volume?
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  10. #10
    Join Date
    Sep 2011
    Beans
    71
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 volume maxed at login

    Yes! That's perfect - I'll add it to a startup script. Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •