Quote Originally Posted by pbrane View Post
One more thing you can do that is sometimes helpful
Code:
sudo apt-get build-dep emacs
That should install the basic dependencies for emacs. Of course if a newer version of emacs requires something the current version does not then this probably won't help.
Also, this pulls the dependencies that are required to compile the Ubuntu package. If there is some option that you want but was disabled in the Ubuntu package, and requires an additional dependency, you will need to install it separately. Likewise if you want to disable some option that the Ubuntu package was compiled with: if the dependenvy is present, it may be auto-enabled, so you will have to disable it manually at the configuration step.