Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: Courier IMAP issues after Precise upgrade

  1. #1
    Join Date
    Dec 2006
    Beans
    26

    Courier IMAP issues after Precise upgrade

    After upgrading from 11.10 to 12.04 it seems as though Courier IMAP is having issues.
    Once I log in it seems as though the connection is dropped.
    See the output below showing that I can connect, can interact with the server but can't login.

    sy@twistie [505] log >nc localhost 143
    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2011 Double Precision, Inc. See COPYING for distribution information.
    1 LOGIN my@email.com wrongpassword
    1 NO Login failed.
    1 LOGIN my@email.com correctpassword
    sy@twistie [505] log >

    I've upped the debug level for courier and here's the output of a login attempt from the mail.debug log.

    May 1 19:54:31 twistie imapd: Connection, ip=[::ffff:127.0.0.1]
    May 1 19:54:33 twistie authdaemond: received auth request, service=imap, authtype=login
    May 1 19:54:33 twistie authdaemond: authmysql: trying this module
    May 1 19:54:33 twistie authdaemond: SQL query: SELECT email, password, "", 5000, 5000, "/home/vmail", CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/'), quota, "", "" FROM users WHERE email = 'my@email.com'
    May 1 19:54:33 twistie authdaemond: password matches successfully
    May 1 19:54:33 twistie authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/home/vmail, address=my@email.com, fullname=<null>, maildir=email.com/my/, quota=0, options=<null>
    May 1 19:54:33 twistie authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/home/vmail, address=my@email.com, fullname=<null>, maildir=email.com/my/, quota=0, options=<null>

    This looks to me as though it gets authenticated but then nothing happens and the connection drops.

    The weird bit is this does work perfectly for a few hours but then I start getting this problem. Restarting the courier processes doesn't fix it but a reboot of the system does until it fails again after a few hours.

    There's nothing obvious in the logs and this has worked for the past five years or so.
    I'm stumped as to where to look next. Does anyone have any idea on what the issue could be?

  2. #2
    Join Date
    Aug 2010
    Beans
    12
    Distro
    Ubuntu

    Re: Courier IMAP issues after Precise upgrade

    I'm so glad I'm not the only person suffering from this! Upgraded my dev machine everything ran fine for several hours then pushed the same updates to my production machine.

    ~24 hours later I'm having this exact issue on both machines.


    [edit]
    Well rebooting the server really does work. Ubuntu is certainly getting windows down pretty good. -_-

    Back on topic I have as much debugging turned on as I can. I'll see what it tells me if it goes down again tomorrow.
    Last edited by credomane; May 1st, 2012 at 09:57 PM.

  3. #3
    Join Date
    Nov 2009
    Beans
    8

    Re: Courier IMAP issues after Precise upgrade

    I am having the same issue, it will work for a few minutes/hours, then it becomes unresponsive.

    Roundcube and thuderbird are both failing so I don't think it is client related.

  4. #4
    Join Date
    Dec 2006
    Beans
    26

    Re: Courier IMAP issues after Precise upgrade

    At least I'm not the only one who has this problem and I'm not the only one who's stumped by it.

    What set up do you guys have? I'm using virtual domains, stored in mysql.

    I also have SquirrelMail running. It seems to run longer when I don't use SquirrelMail but I may be imagining that.

    POP seems unaffected and continues to work even when IMAP dies.

  5. #5
    Join Date
    Nov 2009
    Beans
    8

    Cool Re: Courier IMAP issues after Precise upgrade

    Yeah, the courier mail server is also still running, so no e-mail gets lost fortunately (I see it coming in while imapd is down).

    I also use virtual domains, with a mysql backend, my mail is stored here:
    /var/mail/virtual/.../

    /var/log/mail.err shows these but they seem unrelated:
    Apr 30 19:45:16 cartman imapd: tlscache.c: removing /var/lib/courier/couriersslcache
    Apr 30 19:45:16 cartman imapd: tls_cache_walk: : Invalid argument
    Apr 30 19:45:16 cartman imapd: tlscache.c: : No such file or directory

    I also noticed that it seems to live longer when i don't use roundcube.

    Both roundcube and SquirrelMail are written in PHP, so maybe the PHP-Imap driver is crashing the deamon? I am using Apache/2.2.22 (Ubuntu) and PHP 5.3.10-1ubuntu3.

  6. #6
    Join Date
    Jan 2007
    Beans
    11

    Re: Courier IMAP issues after Precise upgrade

    Same here, after upgrade to 12.04.
    In mail.log, everything seems to function, except after a while, when not functioning any more, the last line in the batch never show up:
    "imapd-ssl: LOGIN, user=xxxxxxx, ip=[::ffffxx.x.x.xx], port=[51730], protocol=IMAP"
    That line is there when connecting now, after a reboot, but after some hours, like you wrote, it's not there, and my email client says it could not connect to the server.

    Whats happening?
    Reboot has always been the trick with windows, but never once, in the last ten years I've been using linuxes as servers.

  7. #7
    Join Date
    Jan 2007
    Beans
    11

    Re: Courier IMAP issues after Precise upgrade

    Seems like an old bug, reported here and here.

    Will try the supposedly working fix: to replace package "gamin" with "fam". Anxious to see the result.
    Last edited by satosh; May 2nd, 2012 at 09:06 PM.

  8. #8
    Join Date
    Dec 2006
    Beans
    26

    Re: Courier IMAP issues after Precise upgrade

    Thanks Satosh,

    I've run;

    sudo apt-get install fam
    sudo apt-get install courier-pop-ssl courier-imap-ssl courier-ssl courier-pop courier-imap courier-base

    I'll report back if this does the trick.

  9. #9
    Join Date
    Dec 2006
    Beans
    26

    Re: Courier IMAP issues after Precise upgrade

    Unfortunately, it seems like this didn't fix it.

    Lasted about 50 minutes before it crashed again.

    Any more ideas?

  10. #10
    Join Date
    Dec 2006
    Beans
    26

    Re: Courier IMAP issues after Precise upgrade

    I'm now trying uninstalling gamin and reinstalling all the courier packages as above.
    I'll report back.

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •