Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: ATI R6XX HDMI audio not working

  1. #1
    Join Date
    Mar 2009
    Beans
    41

    ATI R6XX HDMI audio not working

    Hey,

    So I'm running Precise Pangolin 12.04 64-bit, everything's looking good but I can't output audio through the HDMI port. This works in Windows, so I assume it's a driver issue. The HDMI device itself isn't visible in ubuntu's Sound Settings, but I can see the device in alsamixer. I can also see it if I run aplay -l, lspci, or lsmod.

    However when I do go to the device's alsamixer configurations, all I can see is one box marked S/PDIF with value [00]. I can mute and unmute it, but I can't change the value. There are no other controls for the device.

    I've also tried to output straight to the alsa device from vlc, or with aplay, but that also hasn't worked.

    It's a strange problem because the driver seems to recognize the output device and the proper modules are loaded, but I can't seem to unmute the device and get the audio to work.

  2. #2
    Join Date
    Mar 2009
    Beans
    41

    Re: ATI R6XX HDMI audio not working

    Solved it. Turns out the solution is quite simple. You need to set a kernel flag for:

    radeon.audio=1

    For anyone who's encountered the same problem, you can do this by pressing 'e' in GRUB on your ubuntu boot option, and adding the above line somewhere.

    Otherwise you can edit the entry in /boot/grub/grub.cfg although I would recommend reading up on grub before you break something.

  3. #3
    Join Date
    Mar 2009
    Beans
    19

    Re: ATI R6XX HDMI audio not working

    Is this as simple as just adding that line anywhere in grub.cfg or is there more to it?

  4. #4
    Join Date
    Jun 2007
    Beans
    11,011

    Re: ATI R6XX HDMI audio not working

    sikemo, I put the instructions in youre thread, but I'll echo them here in case someone comes across this in a search:

    For open-source HDMI audio, you'll need to add radeon.audio=1 (inside the quotes next to "quiet splash") to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub and then run:
    Code:
    sudo update-grub
    Otherwise you can edit the entry in /boot/grub/grub.cfg...
    DO NOT edit that file directly (as it warns you).

  5. #5
    Join Date
    Nov 2012
    Beans
    1

    Re: ATI R6XX HDMI audio not working

    Had the same problem using Ubuntu with my AMD A6-3500 APU and Asrock A55M motherboard, HDMI works but no sound.

    confirmed that this fix works for me, thanks!!!

  6. #6
    Join Date
    Dec 2007
    Location
    Chandigarh-India
    Beans
    80
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ATI R6XX HDMI audio not working

    Someone should change the status of this thread to RESOLVED. ( #ADMINS PLEASE NOTE )

    I would like to confirm this as working.

    Goto Launcher > Terminal

    Code:
    SUDO NAUTILUS
    Navigate yourself to /boot/grub/grub.cfg right click edit in Texteditor ...

    Find your usual boot option usually the first entry in grub

    when you find something like insert the line radeon.audio=1 as shown in bold. ( PS don't copy the full code )
    Code:
    fi
    	linux	/boot/vmlinuz-3.5.0-25-generic root=UUID=xxxxxxxxxxxxxxxxxxxxx ro   quiet splash $vt_handoff radeon.audio=1
    	initrd	/boot/initrd.img-3.5.0-25-generic
    f unsure use the at boot time method mentioned above....
    HP Pavillion Dv6516tx -Ubuntu 13.04 - Win Vista - Win 7 - Mac OS X - Server 2008
    Toshiba L640D 10GB -Ubuntu 13.04 20GB-Windows 7
    HTC Explorer Rooted CMW 10.1 JellyBean
    Max Razr Planned Ubuntu Touch

  7. #7

    Re: ATI R6XX HDMI audio not working

    Quote Originally Posted by jskandhari View Post
    Someone should change the status of this thread to RESOLVED. ( #ADMINS PLEASE NOTE )

    I would like to confirm this as working.

    Goto Launcher > Terminal

    Code:
    SUDO NAUTILUS
    Navigate yourself to /boot/grub/grub.cfg right click edit in Texteditor ...

    Find your usual boot option usually the first entry in grub

    when you find something like insert the line radeon.audio=1 as shown in bold. ( PS don't copy the full code )
    Code:
    fi
        linux    /boot/vmlinuz-3.5.0-25-generic root=UUID=xxxxxxxxxxxxxxxxxxxxx ro   quiet splash $vt_handoff radeon.audio=1
        initrd    /boot/initrd.img-3.5.0-25-generic
    f unsure use the at boot time method mentioned above....
    there are two sets of code that are similar to your code snippet in grub.cfg, which line(s) do you edit? just one of them or both?

  8. #8
    Join Date
    Jun 2007
    Beans
    11,011

    Re: ATI R6XX HDMI audio not working

    Quote Originally Posted by webdesigncompanyla View Post
    there are two sets of code that are similar to your code snippet in grub.cfg, which line(s) do you edit? just one of them or both?
    http://ubuntuforums.org/showthread.p...4#post12337464

  9. #9

    Re: ATI R6XX HDMI audio not working

    that didn't answer the question, try reading

  10. #10
    Join Date
    Jun 2007
    Beans
    11,011

    Re: ATI R6XX HDMI audio not working

    Quote Originally Posted by webdesigncompanyla View Post
    that didn't answer the question, try reading
    Yes, it did. It tells you not to edit grub.cfg at all (use /etc/default/grub as directed instead). Sorry, but I can't make it any clearer...

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •