Results 1 to 4 of 4

Thread: No Audio

  1. #1
    Join Date
    May 2008
    Beans
    13

    No Audio

    Not alone.

    Following the steps at: https://help.ubuntu.com/community/So...otingProcedure

    Here is my ALSA-INFO:
    http://pastebin.com/YuBN9t3z

    This command does generate sound:
    aplay -D plughw:1,7 /usr/share/sounds/alsa/Front_Center.wav

    Added the default PCM line to asound.conf, did not fix anything.

    No users get sounds, XBMC no sound, VLC no sound. I can't even use the System Settings -> Sounds -> Hardware Tab -> Test speakers, none of the options can produce sound.

    This is a HTPC, running an upgrade from 11.10 to 12.04.

  2. #2
    Join Date
    May 2008
    Beans
    13

    Re: No Audio

    I will add, the sound indicator icon does not appear once logged in. I've used alsamixer to make sure nothing of importance is muted.

  3. #3
    Join Date
    May 2008
    Beans
    13

    Re: No Audio

    Adding the following to rc.local

    killall pulseaudio; rm -r ~/.pulse*


    This fixed ALSA, oddly, which makes no sense. VLC can properly stream over ALSA and my hw1,7 device (NVIDIA HDMI).

    Pulse seems toast, no sound indicator in gnome, XBMC won't play anything on any setting.

  4. #4
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No Audio

    Forget the built-in gnome sound applet..
    You don't need to fiddle with asound.conf because alsa is working okay..
    I would remove your re-definition of default..

    The HDMI audio codecs are found (aplay -l)
    alsa works (aplay)
    Hot plug HDMI events okay
    ELD for TV okay..(check /proc/asound/card1/eld#1.0)

    Pulse audio or the stupid gnome sound applet is at fault.
    Run pavucontrol & see if your HDMI codec is listed..

    Do you want system wide sound over HDMI?

    You can point VLC & XBMC directly at hw:1,7..
    vlc --aout alsa --alsa-device hw:1,7 (or similar)

    System wide &/or make appear in pulse:
    If pulse/pavucontrol does not list your HDMI out device then you can edit
    #/etc/pulse/default.pa
    load-module module-alsa-sink device=hw:1,7
    #must be only one entry module-alsa-sink in file..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •