Page 1 of 7 123 ... LastLast
Results 1 to 10 of 70

Thread: modem-manager not working

  1. #1
    Join Date
    May 2010
    Beans
    86
    Distro
    Ubuntu 12.04 Precise Pangolin

    Angry modem-manager not working

    Just installed my 12.04 and had restored backup from the 12.04 beta-2 version i was using previously. now my modem is not been detected by ubuntu. Previously it was never a problem(till 11.10). tried to use a third party software "sakis3G". it also didn't worked out(segmentation fault and core dumped). in the beta-2 also, it had problems sometimes but "sakis3G" would have connected to the internet easily. Now it's not working. Please Help!!!
    HP G42-356TU 4GB-RAM, 500GB-HDD
    DUAL BOOT:
    1)UBUNTU 12.04 (PRECISE) 64bit
    2)WIN 7

  2. #2
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: modem-manager not working

    from a fresh cold boot , allow time for the system to settle , then plug the device

    from the terminal

    Code:
    usb-devices
    Code:
    ls -al /dev/serial/by-id
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  3. #3
    Join Date
    May 2010
    Beans
    86
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: modem-manager not working

    still not working.
    what are the commands for?
    the first one produced a lot of information.
    second one there was no such folder.
    should i post the output of first one.
    Last edited by malakar.subhendu; April 30th, 2012 at 04:42 AM. Reason: forget something to add
    HP G42-356TU 4GB-RAM, 500GB-HDD
    DUAL BOOT:
    1)UBUNTU 12.04 (PRECISE) 64bit
    2)WIN 7

  4. #4
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: modem-manager not working

    how to find the device :

    first use lsusb command

    Code:
    lsusb
    it shows a result like
    Code:
    Bus 002 Device 002: ID 0603:00f2 Novatek Microelectronics Corp. 
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 006: ID 12d1:14ac Huawei Technologies Co., Ltd. 
    Bus 001 Device 003: ID 059b:047a Iomega Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    from this info I know the device is
    Code:
    12d1:14ac Huawei Technologies Co., Ltd.
    the usb-devices command , look for block information with the device id's , highlighted

    Code:
    T:  Bus=01 Lev=01 Prnt=01 Port=02 Cnt=02 Dev#=  6 Spd=480 MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=12d1 ProdID=14ac Rev=00.00
    S:  Manufacturer=Huawei Technologies
    S:  Product=HUAWEI Mobile
    C:  #Ifs= 6 Cfg#= 1 Atr=c0 MxPwr=500mA
    I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 1 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 3 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    I:  If#= 5 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    then post the info , like so

    Remember the above is an example , and will explain what the commands do later
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  5. #5
    Join Date
    May 2010
    Beans
    86
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: modem-manager not working

    this is the segment of the modem.
    T: Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 5 Spd=480 MxCh= 0
    D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=1c9e ProdID=9605 Rev=00.00
    S: Manufacturer=USB Modem
    S: Product=USB Modem
    S: SerialNumber=1234567890ABCDEF
    C: #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
    I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    I: If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    HP G42-356TU 4GB-RAM, 500GB-HDD
    DUAL BOOT:
    1)UBUNTU 12.04 (PRECISE) 64bit
    2)WIN 7

  6. #6
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: modem-manager not working

    That be the device , buts has no drivers attached , can try load the driver and ensure the device gets entered in the new id , if not recognise by the driver
    these commands may load the driver

    open up the terminal and enter root
    Code:
    sudo su
    Code:
    modprobe option
    try the usb-devices command

    if the driver has not loaded after that command ( let me know if it has or has not) try this ,

    this command may load the device into the new id
    Code:
    echo 1C9E 9605 > /sys/bus/usb-serial/drivers/option1/new_id
    then check the results with the usb-devices command

    if this works will post details on how to ensure the drivers loads each time the device is plugged in
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  7. #7
    Join Date
    May 2010
    Beans
    86
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: modem-manager not working

    applied both the methods.
    first time it showed the modem and i was able to connect to the internet. then restarted the machine. it does not show the modem now again.
    HP G42-356TU 4GB-RAM, 500GB-HDD
    DUAL BOOT:
    1)UBUNTU 12.04 (PRECISE) 64bit
    2)WIN 7

  8. #8
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: modem-manager not working

    redo the commands as listed , does it show ,

    Also post results of the Device from the terminal

    It Don't show , means nothing From where I sit...

    alexfish
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  9. #9
    Join Date
    May 2010
    Beans
    86
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: modem-manager not working

    reinstalled precise
    but no help.

    doing this
    Code:
    echo 1C9E 9605 > /sys/bus/usb-serial/drivers/option1/new_id

    the modem got detected
    now connected to internet.

    result of usb-devices:

    Code:
    T:  Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  5 Spd=480 MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1c9e ProdID=9605 Rev=00.00
    S:  Manufacturer=USB Modem
    S:  Product=USB Modem
    S:  SerialNumber=1234567890ABCDEF
    C:  #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
    I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    HP G42-356TU 4GB-RAM, 500GB-HDD
    DUAL BOOT:
    1)UBUNTU 12.04 (PRECISE) 64bit
    2)WIN 7

  10. #10
    Join Date
    Sep 2008
    Location
    Filipinas; Formosa
    Beans
    201
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: modem-manager not working

    Quote Originally Posted by alexfish View Post
    That be the device , buts has no drivers attached , can try load the driver and ensure the device gets entered in the new id , if not recognise by the driver
    these commands may load the driver

    open up the terminal and enter root
    Code:
    sudo su
    Code:
    modprobe option
    try the usb-devices command

    if the driver has not loaded after that command ( let me know if it has or has not) try this ,

    this command may load the device into the new id
    Code:
    echo 1C9E 9605 > /sys/bus/usb-serial/drivers/option1/new_id
    then check the results with the usb-devices command

    if this works will post details on how to ensure the drivers loads each time the device is plugged in
    With your permission, I ought to join this thread.

    I have a similar case, though I have a different modem. The drivers were loaded and I can connect to the internet, but it does not retain; I have to enter the same commands whenever I plug the modem. Can you please post how to load the drivers every time the modem is connected.

    Thanks in advance.
    i5-750/P55-UD3P/HD4850 1GB DDR3/4GB DDR3 A-Data Ubuntu 11.04 x64 Natty/Igelle 1.0.0 DSV /Windows7 x64 (for gaming)

Page 1 of 7 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •