Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Ubuntu 12.04 Switches Language

  1. #11
    Join Date
    Jul 2012
    Beans
    29

    Re: Ubuntu 12.04 Switches Language

    I can't believe it took 10 posts for someone to say that Big Blother is watching.

  2. #12
    Join Date
    Mar 2009
    Beans
    18

    Re: Ubuntu 12.04 Switches Language

    My /etc/default/locale was corrent (en_CA for Canadian), by ~/.pam_environment was all chinese though. Simply "rm ~/.pam_environment" and then logging out/in fixed it for me. Mine was the only account on the whole system (out of 4) that even HAD a .pam_environment file! WTF?

  3. #13
    Join Date
    Jul 2008
    Location
    Netherlands
    Beans
    189
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 12.04 Switches Language

    Quote Originally Posted by TeamOliva View Post
    Much easier fix.

    Go to "System Settings"

    Open "User Accounts"

    Change your "Language" to whatever the very 1st selection is.

    Then "Restart"
    Rather late, but still very important:

    I tried this, but the list of languages is in Chinese symbols, so I don't know which one to choose. I need Dutch, but I can't make heads or tails of it.
    "As my tutor, old bubbleface, used to say:"make love and be merry, for tomorrow you may catch some disgusting skin disease."" Rowan Atkinson als The Black Adder

  4. #14
    Join Date
    Jul 2008
    Location
    Netherlands
    Beans
    189
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 12.04 Switches Language

    It's al-right now.

    Here's the thing. In the system settings there is a "language" section, in which a list of languages is shown. The language at the top is the default language. For me, it was Dutch (as it should be), but that clearly wasn't the case, because half of the things on my computer were in Chinese (if not more), some in English, and the rest (which was very little )was in Dutch.

    I don't know what the long-term repercussions are, but I removed Ibus. It started at start-up (though it wasn't in the start-up list), and after I removed it and restarted, I could see that Chinese was at the top of the language list. So I put it to the bottom (rendering it greyed) and put Dutch up top thereby. Then I applied it system wide (I had to guess which of the two buttons did it, but luckily the other button did nothing definite).

    And here's why I removed Ibus: It gave two options to select, and they were both some form of Chinese. So after removing those two from the list didn't do anything (they were back after restarting), I figured: "If I break my computer by removing it, at least I know that I was the one who screwed it up, and not a program". That, and the fact that I have all of my files safely backed up at all times, gave me enough confidence to push through.

    After the restart, everything is back to normal.

    I will however do a virus-scan to be safe.
    "As my tutor, old bubbleface, used to say:"make love and be merry, for tomorrow you may catch some disgusting skin disease."" Rowan Atkinson als The Black Adder

  5. #15
    Join Date
    Feb 2008
    Beans
    5

    Re: Ubuntu 12.04 Switches Language

    This happened to me, even though I am running Mint 14.

    My /etc/default/locale is as follows:
    LANG="en_US.UTF-8"

    but my .pam_environment looks like this:
    Code:
    LANGUAGE=zh_CN:en
    LANG=zh_CN.UTF-8
    LC_NUMERIC=en_US.UTF-8
    LC_TIME=en_US.UTF-8
    LC_MONETARY=en_US.UTF-8
    LC_PAPER=en_US.UTF-8
    LC_NAME=en_US.UTF-8
    LC_ADDRESS=en_US.UTF-8
    LC_TELEPHONE=en_US.UTF-8
    LC_MEASUREMENT=en_US.UTF-8
    LC_IDENTIFICATION=en_US.UTF-8
    I have found a workaround, but not fix:
    in my users .profile at the end I added:
    Code:
    LANG=en_US.UTF-8
    LANGUAGE=en_US:en

    The thing is I don't think this is because of any setting on my normal user. When I switch to root and check locale or locale -a I get the same output. Furthermore, when I do aptitude update, I see it still looking for Chinese translations:
    Code:
    ...
    Hit http://archive.ubuntu.com quantal/main Translation-en                                                                                                          
    Hit http://archive.ubuntu.com quantal/main Translation-zh_CN                                                                                                                                    
    Hit http://security.ubuntu.com quantal-security/restricted amd64 Packages                                                                                          
    Ign http://archive.canonical.com quantal/partner Translation-en_US                                                                                                                              
    Ign http://archive.canonical.com quantal/partner Translation-en      
    ...
    So anyone have any idea what might be causing this and how to fix it properly?

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •