Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Ubuntu 12.04 Switches Language

  1. #1
    Join Date
    Feb 2009
    Beans
    72

    Ubuntu 12.04 Switches Language

    Hi all,

    I did a fresh install of 12.04 two days ago and was not having any problems. However, when I turn on my machine today, somehow the language switched to Chinese. I never once did anything with chinese and the only changes I have made were going back to the gnome panel.

    i tried removing the chinese languages from the terminal and re-installing the english, but still no avail. I eventually went into user accounts and clicked english as the language (which was in Chinese), rebooted, and that worked. Though, I can't figure out why it changed. Is this a bug? If so, how can I find out? Is there anywhere that logs when it is changed?

  2. #2
    Join Date
    Apr 2007
    Location
    Eldorado, NM
    Beans
    4,996
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.04 Switches Language

    This just happened to me! (see earlier post)

    How did you figure out which one was English in the User Accounts list?
    -merlin

  3. #3
    Join Date
    Apr 2007
    Location
    Eldorado, NM
    Beans
    4,996
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.04 Switches Language

    Trial and error solved the problem for now, but is there any way to report this as a bug to be fixed?
    -merlin

  4. #4
    Join Date
    Mar 2007
    Location
    Chicago, IL
    Beans
    19
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Ubuntu 12.04 Switches Language

    i had a fresh install of 12.04 from the weekend. it switched as well.

    definitely making my day non-fun. bugs like these are embarrassing when i'm recommending colleges to give ubuntu a try.

  5. #5
    Join Date
    Sep 2007
    Beans
    5

    Cool Re: Ubuntu 12.04 Switches Language

    Same thing happened here .... anyway to rollback through the terminal?

    Edit:

    gksudo gedit /etc/default/locale

    then modify as follows

    LANG="en_GB"
    LANGUAGE="en_GB:en"

    then reboot
    Last edited by ABE3K; April 30th, 2012 at 06:59 PM. Reason: found out the solution

  6. #6
    Join Date
    Apr 2012
    Beans
    1

    Red face Re: Ubuntu 12.04 Switches Language

    Same problem. It select Chinese without reason after a reboot in a fresh Ubuntu 12.04 (not an upgrade) set to Spanish that worked fine in a spanish environment for two days.

    Is a very frustrating bug. Even if you know gnome-language-selector and you are able to find it in a semi-Chinese environment , the program is useless as any help inside is completely in Chinese (except if you know Chinese, of course).

    To survive to this environment, I open a terminal (Crtl-Alt_T) to change locale LANG=zh_CN.UTF-8 by LANG=es_ES.UTF-8 and then launch gnome-language-selector (from the terminal) to use it in spanish. However, after making the changes to put Spanish first (as root and as normal user) and reboot, the locale is again zh_CN.UTF-8 Then I tried to run (with and without sudo) run locale-gen and dpkg-reconfigure locales, which seem generated well only the en_XX.UTF-8 and es_XX.UTF-8 locales and finally I edit /etc/default/locale to see that all is set with es_ES.UTF-8 or es_ES:en (without any reference to chinese locale): After another reboot seem that the problem was solved.
    Last edited by Francisco Serrano; April 30th, 2012 at 08:34 PM.

  7. #7
    Join Date
    Apr 2012
    Beans
    1

    Re: Ubuntu 12.04 Switches Language

    For me, I had the same bug. However fix was easy, I did change .pam_environment and set both LANG=en_EN and Language=en_EN
    I did also the steps above, but this was not sufficient
    Hope this helps others
    Tobsi

  8. #8
    Join Date
    May 2012
    Beans
    1

    Re: Ubuntu 12.04 Switches Language

    I also had this problem after the first automatic update of 12.04. To recap the solution (by ABE3K and Tobsi):

    1) edit /etc/default/locale:
    LANG="en_GB"
    LANGUAGE="en_GB:en"

    2) edit ~/.pam_environment:
    LANG=en_EN
    Language=en_EN

    Use en_US if you are American. Then reboot.

  9. #9
    Join Date
    Jul 2012
    Beans
    1

    Re: Ubuntu 12.04 Switches Language

    Much easier fix.

    Go to "System Settings"

    Open "User Accounts"

    Change your "Language" to whatever the very 1st selection is.

    Then "Restart"

  10. #10
    Join Date
    Aug 2006
    Location
    Whittier, CA, USA
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.04 Switches Language

    Mine switched to Chinese after setting numeric keypad in System Settings. Maybe the Chinese computer spy operation extends to Ubuntu?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •