Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: suspend works, resume on usb does not

  1. #21
    Join Date
    Apr 2009
    Beans
    3

    Re: suspend works, resume on usb does not

    THX !
    Adding new rule worked great.
    Always something new with Ubuntu

    Remote reciver
    Code:
    Bus 003 Device 002: ID 0471:0815 Philips (or NXP) eHome Infrared Receiver
    and a rule
    Code:
    SUBSYSTEM=="usb", ATTRS{idVendor}=="0471", ATTRS{idProduct}=="0815" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"

  2. #22
    Join Date
    Sep 2009
    Beans
    68
    Distro
    Ubuntu

    Re: suspend works, resume on usb does not

    Hey - is any of this approach good for 12.04 machine that freezes on either suspend or resume? It ofter manages it one, but from then on it will crash.

    I'm assuming my issue is more along the lines of unloading kernel modules that are conflicting, but in any case, its driving me nuts to have to leave on my eexpensive noisy combined fe/be to reecord scheduled items. Was working fine in 10.04 and 11.04...about 3 days on it so far..sigh

  3. #23
    Join Date
    Feb 2012
    Beans
    7

    Re: suspend works, resume on usb does not

    Hi all!

    I am using 13.04 but this method does not work for me.

    Here are my details.


    johan@johan-asus:~$ cat /proc/acpi/wakeup
    Device S-state Status Sysfs node
    P0P1 S4 *disabled
    PEG0 S4 *disabled
    PEG1 S4 *disabled
    PEG2 S4 *disabled
    PEG3 S4 *disabled
    XHC1 S3 *enabled pci:0000:00:14.0
    EHC1 S3 *enabled pci:0000:00:1d.0
    USB1 S3 *disabled
    USB2 S3 *disabled
    USB3 S3 *disabled
    USB4 S3 *disabled
    EHC2 S3 *enabled pci:0000:00:1a.0
    USB5 S3 *disabled
    USB6 S3 *disabled
    USB7 S3 *disabled
    HDEF S4 *disabled pci:0000:00:1b.0
    RP05 S4 *disabled
    RP06 S4 *disabled
    RP07 S4 *disabled
    RP08 S4 *disabled
    WLAN S3 *disabled pci:0000:02:00.0
    RP03 S4 *disabled
    XHCI S3 *disabled
    RP04 S4 *disabled pci:0000:00:1c.3
    GLAN S4 *enabled pci:0000:03:00.2
    XHC S4 *disabled
    SLPB S4 *disabled


    johan@johan-asus:~$ lsusb
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 8087:07da Intel Corp.
    Bus 001 Device 004: ID 058f:a014 Alcor Micro Corp. Asus Integrated Webcam
    johan@johan-asus:~$


    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    echo "enabled" > /sys/bus/usb/devices/usb/4-3/power/wakeup
    exit 0

    (not sure if usb/4-3 is correct how can I verfy this?


    I have created this rule

    johan@johan-asus:~$ sudo gedit /etc/udev/rules.d/90-keyboardwakeup.rules
    [sudo] password for johan:


    SUBSYSTEM=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c52b" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"




    GRUB
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax"








    Many thanks in advance anyone who solves this I can pay 50 $ on paypal! Thanks!
    Last edited by KingOfTheNothing; June 3rd, 2013 at 10:54 AM.

  4. #24
    Join Date
    Sep 2005
    Beans
    35

    Re: suspend works, resume on usb does not

    You have double entries of GRUB_CMDLINE_LINUX_DEFAULT in your grub:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    and at the bottom

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax"

    You should just update the top one to have usbcore.autosuspend=-1 acpi_enforce_resources=lax and remove the bottom one and then run sudo update-grub after. Then reboot.

  5. #25
    Join Date
    Dec 2009
    Location
    US
    Beans
    131
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: suspend works, resume on usb does not

    Thanks to ederopaa. I upgraded one of my frontends (Revo) to 12.04 and tried everything under the sun to get resume to work. I didn't have to modify grub, just added the new rule for my mceusb reciever device ids.

    Edit: Interestingly, lsusb shows my device at bus 004-device 002, but I had to use 4-1 in my rc.local.

    lsusb:
    Bus 004 Device 002: ID 1784:0001 TopSeed Technology Corp. eHome Infrared Transceiver
    rc.local:
    echo enabled > /sys/bus/usb/devices/4-1/power/wakeup
    Last edited by matt06; July 12th, 2013 at 01:40 AM.
    MythTV BE: ECS A780GM-A, X2 240, 2GB, 40GB SSD, 2TB, (2)HVR-1600, Cable + OTA, 10.04 Server 64-bit, MythTV 0.25.3
    MythTV FE: P4M900-M4, Cel 2.0GHz, 1GB, 8400GS 512MB, 4GB CF, MCE, 12.04. FE2: AR3700, 4GB, 250GB, ION, MCE, 12.04

  6. #26
    Join Date
    Sep 2005
    Beans
    5

    Re: suspend works, resume on usb does not

    Damn it was working before ubuntu 12.04 LTS and i had to use wake on lan from my phone until bored today (LTS = Long Term S... ?)

    This in rc.local is fine for me:
    Code:
    for f in /sys/bus/usb/devices/usb*/power/wakeup ; do echo enabled > $f ; done
    Thanks to http://askubuntu.com/questions/12914...hbuntu-upgrade

  7. #27
    Join Date
    Apr 2009
    Beans
    11

    Re: suspend works, resume on usb does not

    Just some observations.
    Apparently the /proc/acpi/wakeup method doesn't work anymore. Mine doesn't even accept any USBs, just UHC1s, ECHs EXPs and AZAL.

    The new (more succesful) methods seem to be toggling all the wakeup files that can be found in the device trees that are either vendor / usb related.
    This is easier than hunting down the wakeup files yourself.
    e.g
    /sys/bus/usb/devices/usb2/power/wakeup (bus?)
    /sys/bus/usb/devices/usb2/2-1/power/wakeup (port?)
    /sys/bus/usb/devices/usb2/2-1/2-1.1/power/wakeup (keyboard - the only value that sticks after reboot)
    /sys/bus/usb/devices/usb2/2-1/2-1.2/power/wakeup (mouse click)

    ..are all wakeup files.
    Somehow, some of them keep resetting back to 'disabled' after reboot. Which is why the need for rc.local or the vendor-rule method.

    I'm not sure what the connection with grub is (don't use grub myself). I managed to get a solution with just rc.local with just the four paths.

  8. #28
    Join Date
    Nov 2013
    Beans
    1

    Re: suspend works, resume on usb does not

    Quote Originally Posted by ederopaa View Post
    jingo_man,

    From your /etc/rc.local try to comment out the first line:

    Code:
    #echo US15 > /proc/acpi/wakeup
    echo enabled > /sys/bus/usb/devices/4-3/power/wakeup
    Then check you devices vendor and product id's with

    Code:
    $lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 005: ID 046d:09a5 Logitech, Inc. Quickcam 3000 For Business
    Bus 003 Device 002: ID 046d:c52e Logitech, Inc.
    and create a new rule with

    Code:
    $ sudo gedit /etc/udev/rules.d/90-keyboardwakeup.rules
    to insert them in the file. In my case 046d and c52e:

    Code:
    SUBSYSTEM=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c52e" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"
    reboot and try it.
    Hi all,

    this works great for my k400 and ubuntu 13.10 but now i get another issue.
    if i use the method above i can wake up the pc with my keyboard but after the boot is done (and also several minutes after) my k400 wont work.
    if i dont use the method above i cant ofcourse wake up my pc with usb but if i wake it up with the power button then my k400 works fine.

    sometimes i have to reinsert the dongle, sometimes i have to reinsert it to a different usb port (front to back).

    another forum suggested to insert
    Code:
    sleep 2
    modprobe -r hid_logitech_dj
    sleep 2
    modprobe hid_logitech_dj


    http://www.raspberrypi.org/phpBB3/vi...p?f=46&t=18139

    this did not help anything at all. i also inserted a sleep 20 ... did not work.

    does anyone else has this issue or solved this? have i done anything wrong? i also inserted the grub cmd lines but that didnt do the trick either.
    hope you can help me.

  9. #29
    Join Date
    Jul 2008
    Beans
    24

    Re: suspend works, resume on usb does not

    I had to return to this subject once again, since my resume stopped working. Still running a Mythbuntu 12.04 on my frontend with Mythtv 0.27.

    The good news is I found a really good solution to my problems. Thanks to Nicolas Bernaerts!

    http://bernaerts.dyndns.org/linux/74...resume-usb-hid

    Before following the instructions I removed my /etc/udev/rules.d/90-mcewakeup.rules -file

    Code:
    sudo rm /etc/udev/rules.d/90-mcewakeup.rules
    and disabled the following wakeup line from /etc/rc.local:

    Code:
    #sudo sh -c "echo enabled > /sys/bus/usb/devices/3-1/power/wakeup"
    and the did a

    Code:
    sudo update-grub
    and a reboot.

    Then I followed the instructions by Nicolas Bernaerts.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •