Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: suspend works, resume on usb does not

  1. #11
    Join Date
    May 2010
    Beans
    8

    Re: suspend works, resume on usb does not

    Agree with fatski. i had a long night trying to figure this out, and now its solved. thank you!!

  2. #12
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Beans
    73
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: suspend works, resume on usb does not

    Thank you! This worked great for me! If people are interested in troubleshooting a little more, I've put more details in this post, including manually toggling the enabled state without udev.

    Your solution works great for my USB keyboard and mouse, but I'm still having trouble getting my laptop's internal keyboard or trackpad to wake the computer. I'm not sure that it's considered a USB device, but I did some troubleshooting. Firstly, I tried
    Code:
    $ find /sys/devices/ -name wakeup
    Then (ignoring the "/sys/devices/platform/serial8250/tty/*" entries) I manually toggled all of the 18 disabled wakup files to enabled. None of them fixed the problem for me... Would anyone know if there's another wakeup file to find, or something else?

  3. #13
    Join Date
    Nov 2011
    Beans
    10

    Re: suspend works, resume on usb does not

    I am confused. Why do the "#echo USB2 >> /proc/acpi/wakeup" lines in rc.local not only no longer work, but if not commented out cause the /proc/acpi/wakeup devices to be disabled (assuming the 90.mcewakeuprules file is in place)?

  4. #14
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Beans
    73
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: suspend works, resume on usb does not

    Has anyone else found that a recent upgrade has broken this workaround? I presume it's the kernel upgrade to 3.2.0-25.

    Since this upgrade, I cannot get my computer to suspend at all. I have a udev rule as described in this thread to allow my mouse to wake up the computer. If I attempt to suspend, the computer immediately wakes back up. I removed the udev rule (or rebooted the computer without the mouse plugged in) and I can suspend fine.

    Oddly enough, if I manually alter the wakeup file instead (as per my post here), e.g. with
    Code:
    $ sudo su
    # echo enabled > /sys/bus/usb/devices/3-1.3/power/wakeup
    I can suspend fine, but the moues no longer wakes the computer up anyway.

  5. #15
    Join Date
    Jul 2008
    Beans
    24

    Re: suspend works, resume on usb does not

    Quote Originally Posted by sparhawkthesecond View Post
    can suspend fine, but the moues no longer wakes the computer up anyway.
    What happens with wake up if you:

    Code:
    sudo update-grub
    (and maybe a reboot)?

  6. #16
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Beans
    73
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: suspend works, resume on usb does not

    Quote Originally Posted by ederopaa View Post
    What happens with wake up if you:

    Code:
    sudo update-grub
    (and maybe a reboot)?
    Fantastic! I did both steps, and that seems to have fixed it. Thank you for your help.

    I do find it odd that this was necessary though. Do you always manually update grub after a kernel update?

    Cheers.

  7. #17
    Join Date
    Jul 2008
    Beans
    24

    Re: suspend works, resume on usb does not

    Quote Originally Posted by sparhawkthesecond View Post
    Do you always manually update grub after a kernel update?
    No, not really. But lately I've had to do this (and fool around with the other stuff in this thread) in order to get suspend/resume to work. Maybe its a bug or maybe it is a feature? So far this has been a question of trial and error for me. I thought of writing up some experiences because I know I'm not alone...I'm just a regular MythTV user.

  8. #18
    Join Date
    Jan 2012
    Location
    Melbourne, Australia
    Beans
    73
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: suspend works, resume on usb does not

    Ah okay. Thanks for sharing your advice. Something to keep in mind I guess.

    Cheers.

  9. #19
    Join Date
    Jul 2012
    Beans
    1

    Re: suspend works, resume on usb does not

    You are god





    Quote Originally Posted by ederopaa View Post
    jingo_man,

    From your /etc/rc.local try to comment out the first line:

    Code:
    #echo US15 > /proc/acpi/wakeup
    echo enabled > /sys/bus/usb/devices/4-3/power/wakeup
    Then check you devices vendor and product id's with

    Code:
    $lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 005: ID 046d:09a5 Logitech, Inc. Quickcam 3000 For Business
    Bus 003 Device 002: ID 046d:c52e Logitech, Inc.
    and create a new rule with

    Code:
    $ sudo gedit /etc/udev/rules.d/90-keyboardwakeup.rules
    to insert them in the file. In my case 046d and c52e:

    Code:
    SUBSYSTEM=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c52e" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"
    reboot and try it.

  10. #20
    Join Date
    Feb 2012
    Beans
    81

    Re: suspend works, resume on usb does not

    Thanks!!

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •