Page 1 of 7 123 ... LastLast
Results 1 to 10 of 67

Thread: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

  1. #1
    Join Date
    Sep 2007
    Location
    Mississauga,ON Canada
    Beans
    78
    Distro
    Xubuntu

    Exclamation Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    Most notable changes are:

    New official gui that has a log viewer built in.
    Gui package now split off from the base cli package.
    Precise support.

    You can see more details and screenshots on the newly updated website - http://www.remastersys.com/ubuntu.html

    Packages you will now see in the repository:

    remastersys - base remastersys package cli only - you must install this
    remastersys-gui - new gui starting with precise - may not work on older versions prior to 11.10
    remastersys-gtk - pygtk gui that should work on lucid and up to and including precise

    Splitting them off means you can just install the cli remastersys package as it is the base working package anyway. If you prefer not to see remastersys on the menu this is all you need.

    Installing either remastersys-gui or remastersys-gtk will provide you with the options to customize the live boot background picture, the system grub background pciture, create a simple plymouth theme and copy user settings to /etc/skel so they are default for your system and live iso.

    The Manual Method

    As root - issue 'sudo su' in the terminal window prior to the following command.

    Download and apply the repository gpg key.

    wget -O - http://www.remastersys.com/ubuntu/remastersys.gpg.key | apt-key add -

    Add the following line that corresponds to your version of Ubuntu to your /etc/apt/sources.list

    #Remastersys Lucid
    deb http://www.remastersys.com/ubuntu lucid main

    #Remastersys Maverick
    deb http://www.remastersys.com/ubuntu maverick main

    #Remastersys Natty
    deb http://www.remastersys.com/ubuntu natty main

    #Remastersys Oneiric
    deb http://www.remastersys.com/ubuntu oneiric main

    #Remastersys Precise
    deb http://www.remastersys.com/ubuntu precise main

    Now just apt-get update or reload in Synaptic to have the new Remastersys signed repository ready to use!

    Contact me if you would like to translate the new gui into your native language and I will provide you with the po file to translate. When I get a few more translations I will make a remastersys-gui-translations package that includes the translations and add it to the repository.
    Last edited by Fragadelic; April 28th, 2012 at 08:36 PM.

  2. #2
    Join Date
    Sep 2007
    Location
    Mississauga,ON Canada
    Beans
    78
    Distro
    Xubuntu

    Exclamation Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    IMPORTANT NOTE for Precise users:


    I have been notified by Canonical that there is currently a bug in casper - https://bugs.launchpad.net/ubuntu/+s...er/+bug/984276

    This affects remastersys users as you need casper for the live boot. I'll be keeping an eye on this as they work to correct the situation.

    They are working on fixing the issue.

  3. #3
    Join Date
    Nov 2011
    Beans
    1

    Talking Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    Hello Fragadelic, Great Tool, i want to thank you for picking development up again.

    To tell you the truth my first encounter with this kind of soft was Relinux, but i could never use it and remastersys was the original and final solution.

    I've managed to create my one and only successful dist with remastersys 2.0.18-1 on 11.10.
    i couldn't get the dist to boot the installation directly.

    I'm still trying to make it work with 3.0.2-1, but can't get it to boot the installation directly and if i install it from the live boot, installation crashes on grub install.

    Live CD Works fine!
    Thank you again for this magnificent software!

  4. #4
    Join Date
    Sep 2007
    Location
    Mississauga,ON Canada
    Beans
    78
    Distro
    Xubuntu

    Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    Is this a system you have upgraded along the way or was it a regular 11.10 install? Grub issues tend to happen when you upgrade from older versions and haven't let it upgrade to grub 2. Ubuntu 10.04(lucid) and newer must have grub2 as that is the only thing the Ubuntu ubiquity installer will setup properly.

    Make sure you get the 3.0.2 version from my repo. You might have to use remastersys-gtk instead of remastersys-gui but you have to first make sure you upgraded the base remastersys to 3.0.2.

  5. #5
    Join Date
    Nov 2011
    Beans
    1

    Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    It's a brand new 11.10, (my first approach to open source ) with the latest updates applied but i haven't upgraded to 12.04 yet.

    The only issue i'm experiencing now with 3.0.2 it's that i have to create a new administrator user from the live boot to install the dist since i can't boot the install from the initial splash screen.

    When i select install on the splash screen, it takes me directly to the live boot.

    Thank you for the quick response.

    Regards

  6. #6
    Join Date
    Sep 2007
    Location
    Mississauga,ON Canada
    Beans
    78
    Distro
    Xubuntu

    Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    Did you by chance set auto login on your original system? If you did, you'll have to undo that. Can you post your most recent remastersys.log. It should be in /home/remastersys/remastersys

  7. #7
    Join Date
    Nov 2011
    Beans
    1

    Smile Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    No, i did not set auto login.
    Sure, i'm uploading it right now.
    Thanks!
    Attached Files Attached Files

  8. #8
    Join Date
    Sep 2007
    Location
    Mississauga,ON Canada
    Beans
    78
    Distro
    Xubuntu

    Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    Looking at your remastersys.log leads me to believe you either have too much in /etc/skel or there are config files with user specific permissions in it.

    What is the output of "sudo du -sh /etc/skel"

    Also post the output of this command - replace username with your user you copied the config files from
    sudo grep -R "username" /etc/skel

  9. #9
    Join Date
    Nov 2011
    Beans
    1

    Arrow Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    Hi,

    Attached is the output of the commands.

    Thanks!
    Attached Files Attached Files

  10. #10
    Join Date
    Sep 2007
    Location
    Mississauga,ON Canada
    Beans
    78
    Distro
    Xubuntu

    Re: Remastersys 3.0.2-1 released supporting Ubuntu Lucid up to Precise

    You have user specific items in /etc/skel which is making the user creation fail.

    What you should do if you want to have more than I normally copy into it with my tool, is to copy your other things over first and then run my user settings copy from the menu which will clean up /etc/skel for you. Anything that is a problem will be removed by my remastersys-skelcopy.

Page 1 of 7 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •