Page 9 of 13 FirstFirst ... 7891011 ... LastLast
Results 81 to 90 of 121

Thread: Cups seems broken under 12.04 LTS...

  1. #81
    Join Date
    Jan 2011
    Beans
    14

    Re: Cups seems broken under 12.04 LTS...

    Since I still get some printing problems here is my erro log.
    I hope that will help somehow
    My problem is, as I posted before that the printer either wont print at all he started but than dont prin anythink (automatic resolution)
    Or he just print the page very small wenn I selcted 300x300 dpi resolution

    I am glad that we make some progress here

    Code:
    W [06/Aug/2012:17:41:10 +0200] failed to CreateProfile:  org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-i560-Gray..' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-i560-RGB..' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Canon-i560' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Generic-PCL-Laser-Printer-Gray..' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Generic-PCL-Laser-Printer' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Generic-PCL-Laser-Printer-Gray..' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Generic-PCL-Laser-Printer' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'PDF-Gray..' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'PDF-RGB..' already exists 
    W [06/Aug/2012:17:41:10 +0200] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-PDF' already exists

  2. #82
    Join Date
    Jan 2011
    Beans
    9

    Re: Cups seems broken under 12.04 LTS...

    Okay I have copied the error log from a job that failed. I hope the person who was working on the Canon issue that asked to see a log reads this - I would like to be able to print!

    ETA: I also tried lpr -H 192.168.1.200:9100 /var/log/cups/error_log
    The result I get is lpr: Error - scheduler not responding.

    Code:
    W [04/Aug/2012:18:03:09 -0700] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MF8000-UFRII-LT-Gray..' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MF8000-UFRII-LT-RGB..' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Canon-MF8000-UFRII-LT' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MF8000-UFRII-LT-Gray..' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MF8000-UFRII-LT-RGB..' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Canon-MF8000-UFRII-LT' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MF8000-UFRII-LT-Gray..' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateProfile: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon-MF8000-UFRII-LT-RGB..' already exists
    W [04/Aug/2012:18:03:09 -0700] failed to CreateDevice: org.freedesktop.ColorManager.AlreadyExists:device id 'cups-Canon-MF8000-UFRII-LT' already exists
    E [04/Aug/2012:18:03:12 -0700] [Job 8] Job stopped due to filter errors; please consult the error_log file for details.
    D [04/Aug/2012:18:03:12 -0700] [Job 8] The following messages were recorded from 18:03:12 to 18:03:12
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Adding start banner page "none".
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Adding end banner page "none".
    D [04/Aug/2012:18:03:12 -0700] [Job 8] File of type application/vnd.cups-pdf-banner queued by "ron".
    D [04/Aug/2012:18:03:12 -0700] [Job 8] hold_until=0
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Queued on "Canon-MF8000-UFRII-LT" by "ron".
    D [04/Aug/2012:18:03:12 -0700] [Job 8] job-sheets=none,none
    D [04/Aug/2012:18:03:12 -0700] [Job 8] argv[0]="Canon-MF8000-UFRII-LT"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] argv[1]="8"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] argv[2]="ron"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] argv[3]="Test Page"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] argv[4]="1"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] argv[5]="job-uuid=urn:uuid:f5f428f6-18b0-3f4a-4448-f55cf2f83d77 job-originating-host-name=localhost time-at-creation=1344128592 time-at-processing=1344128592"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] argv[6]="/var/spool/cups/d00008-001"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[1]="CUPS_DATADIR=/usr/share/cups"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[2]="CUPS_DOCROOT=/usr/share/cups/doc-root"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[5]="CUPS_SERVERBIN=/usr/lib/cups"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[6]="CUPS_SERVERROOT=/etc/cups"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[7]="CUPS_STATEDIR=/var/run/cups"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[8]="HOME=/var/spool/cups/tmp"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[9]="PATH=/usr/lib/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[10]="SERVER_ADMIN=root@ubRMHI"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[11]="SOFTWARE=CUPS/1.5.3"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[12]="TMPDIR=/var/spool/cups/tmp"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[13]="USER=root"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[14]="CUPS_SERVER=/var/run/cups/cups.sock"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[15]="CUPS_ENCRYPTION=IfRequested"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[16]="IPP_PORT=631"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[17]="CHARSET=utf-8"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[18]="LANG=en_US.UTF-8"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[19]="PPD=/etc/cups/ppd/Canon-MF8000-UFRII-LT.ppd"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[20]="RIP_MAX_CACHE=128m"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[21]="CONTENT_TYPE=application/vnd.cups-pdf-banner"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[22]="DEVICE_URI=socket://192.168.1.200:9100"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[23]="PRINTER_INFO=Canon MF8000 UFRII LT"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[24]="PRINTER_LOCATION=192.168.1.200"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[25]="PRINTER=Canon-MF8000-UFRII-LT"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[26]="PRINTER_STATE_REASONS=none"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[27]="CUPS_FILETYPE=document"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[28]="FINAL_CONTENT_TYPE=printer/Canon-MF8000-UFRII-LT"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] envp[29]="AUTH_I****"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Started filter /usr/lib/cups/filter/bannertopdf (PID 1851)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Started filter /usr/lib/cups/filter/pdftopdf (PID 1852)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Started filter /usr/lib/cups/filter/pdftops (PID 1853)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Started filter /usr/lib/cups/filter/pstoufr2cpca (PID 1854)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Started backend /usr/lib/cups/backend/socket (PID 1855)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] pdftops - copying to temp print file "/tmp/0073d50250571"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] STATE: +connecting-to-device
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Looking up "192.168.1.200"...
    D [04/Aug/2012:18:03:12 -0700] [Job 8] hrDeviceDesc="Canon MF8050"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] prtGeneralCurrentLocalization type is 5, expected 2!
    D [04/Aug/2012:18:03:12 -0700] [Job 8] backendWaitLoop(snmp_fd=5, addr=0x7faaee3669b8, side_cb=0x7faaec828180)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Using image rendering resolution 300 dpi
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Started filter pdftops (PID 1856)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Started filter pstops (PID 1857)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Page = 612x792; 14,14 to 598,778
    D [04/Aug/2012:18:03:12 -0700] [Job 8] slow_collate=0, slow_duplex=0, slow_order=0
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Before copy_comments - %!PS-Adobe-3.0
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %!PS-Adobe-3.0
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %Produced by poppler pdftops version: 0.18.4 (http://poppler.freedesktop.org)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %%LanguageLevel: 2
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %%DocumentSuppliedResources: (atend)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %%DocumentMedia: plain 612 792 0 () ()
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %%BoundingBox: 0 0 612 792
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %%Pages: 1
    D [04/Aug/2012:18:03:12 -0700] [Job 8] %%EndComments
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Before copy_prolog - %%BeginDefaults
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Before copy_setup - %%BeginSetup
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Before page loop - %%Page: 1 1
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Copying page 1...
    D [04/Aug/2012:18:03:12 -0700] [Job 8] pagew = 583.7, pagel = 763.7
    D [04/Aug/2012:18:03:12 -0700] [Job 8] bboxx = 0, bboxy = 0, bboxw = 612, bboxl = 792
    D [04/Aug/2012:18:03:12 -0700] [Job 8] PageLeft = 14.2, PageRight = 597.8
    D [04/Aug/2012:18:03:12 -0700] [Job 8] PageTop = 777.8, PageBottom = 14.2
    D [04/Aug/2012:18:03:12 -0700] [Job 8] PageWidth = 612.0, PageLength = 792.0
    D [04/Aug/2012:18:03:12 -0700] [Job 8] Wrote 1 pages...
    D [04/Aug/2012:18:03:12 -0700] [Job 8] PID 1856 (pdftops) exited with no errors.
    D [04/Aug/2012:18:03:12 -0700] [Job 8] PID 1857 (pstops) exited with no errors.
    D [04/Aug/2012:18:03:12 -0700] [Job 8] End of messages
    D [04/Aug/2012:18:03:12 -0700] [Job 8] printer-state=3(idle)
    D [04/Aug/2012:18:03:12 -0700] [Job 8] printer-state-message="/usr/lib/cups/filter/pstoufr2cpca failed"
    D [04/Aug/2012:18:03:12 -0700] [Job 8] printer-state-reasons=none
    Last edited by kf7nnz; August 7th, 2012 at 06:04 AM. Reason: Additional troubleshooting info

  3. #83
    Join Date
    Sep 2006
    Location
    Tokyo, Japan
    Beans
    169

    Re: Cups seems broken under 12.04 LTS...

    I'm just posting to note that this is not a Gutenprint issue, since the driver being used for the MF8000 is the Canon-supplied driver for their UFRII protocol.

    Regards,
    Gernot Hassenpflug
    Gutenprint project Canon backend maintainer
    Learning the mechanism requires good teachers and dedication

  4. #84
    Join Date
    Jan 2011
    Beans
    9

    Re: Cups seems broken under 12.04 LTS...

    Thank you, Gernot. I do still have a gutenprint issue that you could perhaps help me with (see below).

    I am happy to report that I was able to print finally. I had installed the cups-bjnp backend. I found a thread for people having the same issue with earlier 64-bit versions of Ubuntu. They solved the problem by uninstalling the Canon .deb packages created with the alien utility, then creating a symbolic link to /usr/lib from /usr/lib64 like so:

    Code:
    sudo ln -s /usr/lib /usr/lib64
    Then reinstall the .deb packages. I am now able to print. However, the driver doesn't seem to be the one I had originally, for instance, it doesn't show that the printer has duplex printing capabilities. I was hoping to install a better driver, like the gutenprint driver, but I don't know how. Can anyone help? Thanks!

  5. #85
    Join Date
    Apr 2006
    Beans
    996
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cups seems broken under 12.04 LTS...

    I noticed that renaming a printer (which I need so that it has the same name as when there is a windows partition in here) causes a cups misconfiguration the next time you boot.
    Xye incredibly difficult puzzle game with minimal graphics. Also at playdeb
    Got a blog: Will Stay Free

  6. #86
    Join Date
    Sep 2006
    Location
    Tokyo, Japan
    Beans
    169

    Re: Cups seems broken under 12.04 LTS...

    Quote Originally Posted by kf7nnz View Post
    Thank you, Gernot. I do still have a gutenprint issue that you could perhaps help me with (see below).
    /../
    However, the driver doesn't seem to be the one I had originally, for instance, it doesn't show that the printer has duplex printing capabilities. I was hoping to install a better driver, like the gutenprint driver, but I don't know how. Can anyone help? Thanks!
    Hi, glad you could print at last.
    I'm afraid gutenprint, which is a dedicated inkjet driver project with incidentally some non-inkjet drivers as well, does not have support for UFRII protocol. We're pretty in need of programmers for more well-known backends, like PCL support, and if someone would reverse engineer UFRII that would certainly be appreciated, but there is no-one able to do that in the project at this point.
    If your printer has emulation for PCL, or ESC/P2 or PDF or PS, for example, then you could use another driver, such as ones from foomatic (or gutenprint for ESC/P2), perhaps not with all options available, but that is largely a function of the PPD file CUPS has access to (and whether the various CUPS filters correctly set up the options).
    Learning the mechanism requires good teachers and dedication

  7. #87
    Join Date
    Jan 2009
    Location
    bk, ny
    Beans
    191
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cups seems broken under 12.04 LTS...

    when 12.04 dropped I struggled to get my Canon MP530 working -- typically a job would start and then stop halfway through a page -- until I finally got it somehow a couple of months ago. now one of the updates has broken it. now, either a job will stop halfway through a page, or the printer fails to acknowledge a job at all (a step backward from before, when at least the LED would say "PRINTING" even when it wasn't).

    the HP Laserjet 1300 which I have on a print server, is working fine.

    I am anxious to get rid of this Canon which has always been a pita under Linux, however I still have a package of cartridges to get through.

  8. #88
    Join Date
    Jul 2009
    Beans
    110

    Re: Cups seems broken under 12.04 LTS...

    I have no idea what you just said. So, all I have to do to install my Dell 3110cn printer in Ubuntu 12.04 is just type in, " sudo ln -s /usr/lib /usr/lib64 " at the Terminal? If not, then what other steps do I take? Please tell it to me in simple step-by-step fashion for the rest of us dummies. Thanks ;0)

    Quote Originally Posted by kf7nnz View Post
    Thank you, Gernot. I do still have a gutenprint issue that you could perhaps help me with (see below).

    I am happy to report that I was able to print finally. I had installed the cups-bjnp backend. I found a thread for people having the same issue with earlier 64-bit versions of Ubuntu. They solved the problem by uninstalling the Canon .deb packages created with the alien utility, then creating a symbolic link to /usr/lib from /usr/lib64 like so:

    Code:
    sudo ln -s /usr/lib /usr/lib64
    Then reinstall the .deb packages. I am now able to print. However, the driver doesn't seem to be the one I had originally, for instance, it doesn't show that the printer has duplex printing capabilities. I was hoping to install a better driver, like the gutenprint driver, but I don't know how. Can anyone help? Thanks!

  9. #89
    Join Date
    Jan 2011
    Beans
    9

    Re: Cups seems broken under 12.04 LTS...

    Quote Originally Posted by tomasrey88 View Post
    I have no idea what you just said. So, all I have to do to install my Dell 3110cn printer in Ubuntu 12.04 is just type in, " sudo ln -s /usr/lib /usr/lib64 " at the Terminal? If not, then what other steps do I take? Please tell it to me in simple step-by-step fashion for the rest of us dummies. Thanks ;0)
    I'm afraid I can't tell you how to do it for your printer. The steps I was talking about worked for Canon printers in 64-bit versions of Ubuntu. Have you tried installing your Dell printer through the GUI yet? Click System Settings (on the Unity taskbar) | Printing | +Add button and follow the prompts. If that doesn't work then post back here and I will try to help you if I can.

  10. #90
    Join Date
    Aug 2012
    Beans
    1

    Re: Cups seems broken under 12.04 LTS...

    Quote Originally Posted by ray field View Post
    when 12.04 dropped I struggled to get my Canon MP530 working -- typically a job would start and then stop halfway through a page -- until I finally got it somehow a couple of months ago. now one of the updates has broken it. now, either a job will stop halfway through a page, or the printer fails to acknowledge a job at all (a step backward from before, when at least the LED would say "PRINTING" even when it wasn't).

    the HP Laserjet 1300 which I have on a print server, is working fine.

    I am anxious to get rid of this Canon which has always been a pita under Linux, however I still have a package of cartridges to get through.

    Possible work-around (it worked for me)
    I also have a Canon MP530 - after upgrading to 12.04 from 11.10 I noticed my print speed slowed down noticeably (almost 5 minutes for a 1 page b&w document)!

    So I tried a few 'out of the box' tests to see if I could get back to reasonable print speeds with my Canon.

    1 - Installed Fuduntu 2012-3 onto another partition; Hooray! that same 1 page doc now printed in less than 30 seconds under Fuduntu.

    2 - went back to Ubuntu 12.04 partition and then deleted it. Then I loaded Ubuntu 11.10 onto that partition (after formatting it to ext4). Under Unity (sigh..) I printed the same 1 page doc - Great! it now prints in less than 30 seconds (very acceptable for the MP530).

    3 - Final test (I like Cinnamon over Unity); installed Cinnamon onto the 11.10 system.
    Next I ran the same 1 page doc print test - Yes! still under 30 seconds.

    Like others I feel there are some real issues in CUPS for non HP printers under 12.04.
    Not sure if you want to go back to 11.10 but it appears (at least to me) to work a lot faster than the 12.04 CUPS.... (Your mileage may vary).

    Cheers, J

Page 9 of 13 FirstFirst ... 7891011 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •