Page 7 of 13 FirstFirst ... 56789 ... LastLast
Results 61 to 70 of 121

Thread: Cups seems broken under 12.04 LTS...

  1. #61
    Join Date
    Aug 2006
    Beans
    110

    Re: Cups seems broken under 12.04 LTS...

    I can print now.
    I had to delete and remake the printer, in system-config-printer and choose AppSocket/JetDirect for the connection.

    Normally the default is ipp connection. But my printer, apparently, has errors in its ipp implementation, which makes cups write ipp-conformance-failure-report and give up.

    https://bugs.launchpad.net/ubuntu/+s...ps/+bug/992982
    http://www.cups.org/str.php?L4079
    Last edited by crf; May 31st, 2012 at 06:55 PM.

  2. #62
    Join Date
    Jan 2011
    Beans
    14

    Re: Cups seems broken under 12.04 LTS...

    Quote Originally Posted by ratcheer View Post
    I don't know, but I doubt that Ubuntu will ever carry a set of Canon printer drivers. At least not for the ones Canon does not support on Linux, which includes my MP620.

    What printer do you have? What Ubuntu release? 32 or 64 bit?

    Tim
    Hy ratcheer and thanks again for you help.
    I have an Canon i560x and an 64 bit ubuntu,

    I also tried that delete and reinstall you printer think which does not worked

  3. #63
    Join Date
    Aug 2011
    Beans
    13
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Cups seems broken under 12.04 LTS...

    In case someone is still following this thread: today I was able to print again using my Canon PIXMA iP3500 printer. I read an article stating that Gutenprint 5.2.8 was released, having improved printing features for Canon printers. I installed this, selected the correct Canon printer driver that came with it, and was then able to print a test page, an email (so only normal text) and a map from a website. I was not able to do any of this since I had installed Ubuntu 12.04 LTS (64 bit version).

  4. #64
    Join Date
    Mar 2012
    Location
    New Meadows, Idaho
    Beans
    200
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cups seems broken under 12.04 LTS...

    Strange but true... Some how the upgrade got trigger on my machine and so I proceeded with the update to 12.04. I was worried that my Canon MF4150 would die since it was quite the project to get it working in 11.10. Well guess what made the update no problems and Cannon printer is still working fine.

  5. #65
    Join Date
    Jan 2011
    Beans
    14

    Re: Cups seems broken under 12.04 LTS...

    Quote Originally Posted by NLinTKO View Post
    In case someone is still following this thread: today I was able to print again using my Canon PIXMA iP3500 printer. I read an article stating that Gutenprint 5.2.8 was released, having improved printing features for Canon printers. I installed this, selected the correct Canon printer driver that came with it, and was then able to print a test page, an email (so only normal text) and a map from a website. I was not able to do any of this since I had installed Ubuntu 12.04 LTS (64 bit version).
    One Question, how do you install Gutenprint 5.2.8!
    Can you explain it to an newby step by step please

  6. #66
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: Cups seems broken under 12.04 LTS...

    Quote Originally Posted by Snoopy_5_1 View Post
    One Question, how do you install Gutenprint 5.2.8!
    Can you explain it to an newby step by step please
    sudo apt-get install printer-driver-gutenprint

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  7. #67
    Join Date
    Jan 2011
    Beans
    14

    Re: Cups seems broken under 12.04 LTS...

    it seams I allready have the new on:
    driver and model: Canon i560 - CUPS+Gutenprint v5.2.8-pre1

    Is it strange that Cups and Gutenprint is installed?
    I really hope I can print again sometime

  8. #68
    Join Date
    Dec 2011
    Beans
    13

    Re: Cups seems broken under 12.04 LTS...

    I have a Canon s750 printer that was working fine on my laptop using 11.10 (32). It uses the driver specified for the s800 (CUPS+gutenprint v5.2.7 Simplified) and works perfectly. I installed 12.04 (x64) on my desktop and have not been able to get the same printer to work correctly using the Canon s750 driver (CUPS+gutenprint v5.2.8 pre1); however, the Canon s630 Foomatic/bj8XXYYZ.upp works most of the time. Something has definitely changed from 11.10 to 12.04. Hope there's a solution soon.

  9. #69
    Join Date
    Apr 2007
    Location
    Eldorado, NM
    Beans
    4,987
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Cups seems broken under 12.04 LTS...

    Despite all the updates to 12.04, I still cannot print over my network using ipp:// (or from a vm running windows using http://), both with serveripaddress:631/printers/HP-LaserJet-4

    This worked perfectly until 12.04.

    Help greatly appreciated!!!
    -merlin

  10. #70
    Join Date
    Sep 2006
    Location
    Tokyo, Japan
    Beans
    170

    Re: Cups seems broken under 12.04 LTS...

    I've read the entire theread wihtout seeing a single lines from CUPS logs anywhere. Very odd!
    If something does not work in CUPS, the first thing to do should be to enable debugging in the log file and then see what is the result.
    The reason is simple:
    - either it is a problem with CUPS
    - or it is a problem with gutenprint
    - or the Canon driver

    At least for the first two, this should be clear from the logs. As the maintainer of the Canon backend for the gutenprint project, I am very much interested in resolving bugs in the Canon backend, but this is impossible when the bugs are not clearly isolated.

    Currently, I have some bugs proven for the pro series, and I am trying to collect useable information on possible bugs with other Canon devices.

    Regards,
    Gernot Hassenpflug
    Learning the mechanism requires good teachers and dedication

Page 7 of 13 FirstFirst ... 56789 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •