Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: VLC Being a Jerk in 12.04

  1. #11
    Join Date
    Sep 2011
    Beans
    42

    Re: VLC Being a Jerk in 12.04

    As a bump, I've got an ATI RS690 card (Radeon x1200). In looking around, I don't think I want the Gallium 0.4 drivers for that, but have no idea how to change them.

    What clued me in was that I was unable to change brightness/contrast on the default Ubuntu movie player tonight. That might help with the VLC problem a bit, though I am still worried about the overall install and errors, as well as the nervous reboot.

  2. #12
    Join Date
    Sep 2011
    Beans
    42

    Re: VLC Being a Jerk in 12.04

    I ran a "dmesg | grep drm" command in the terminal and got a long string of stuff back, including a repeating error.

    I've looked around at driver issues, but nothing is telling me what I need to know (or, if it is, it is too cryptic for me). To wit, I need to find out how to reload ATI drivers.

  3. #13
    Join Date
    Oct 2005
    Beans
    520

    Re: VLC Being a Jerk in 12.04

    I had a problem with ver 2 of vlc that's in the repos upon upgrade. I jsut went back 1 ver and evrything works fine now, maybe that helps some.

  4. #14
    Join Date
    Dec 2004
    Location
    Atlanta, GA USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: VLC Being a Jerk in 12.04

    Just back up and do a clean install.

  5. #15
    Join Date
    Sep 2011
    Beans
    42

    Re: VLC Being a Jerk in 12.04

    I'm unclear on how to go about doing a clean install. I've got Natty 11.04 on a flash drive that I've been tempted to use again, or even just re-do 12.04, but I don't know where to find it.

    And by back-up, does that entail moving all of my files to another drive?

  6. #16
    Join Date
    May 2009
    Beans
    6

    Re: VLC Being a Jerk in 12.04

    You could try:

    sudo add-apt-repository ppa:n-muench/vlc
    sudo apt-get update
    sudo apt-get purge vlc
    sudo apt-get install vlc

    Another problem I found (with corrupted install) is that some instances of Ubuntu does not run a swap device. Usually when you encrypt your home directory at install. Check to see if your swap drive is online.

    swapon -s

    This should show you your swap device and other info. If it is not there you will have to format your swap device then mount it manually. Change your /etc/fstab to reflect the device so that it is mounted on reboot.

    If you have a corrupted install, you may have to reinstall or perform a number of 'sudo apt-get upgrade' and 'sudo apt-get dist-upgrade' to fix your problem.

  7. #17
    Join Date
    Jul 2005
    Location
    USA (Springfield,Vermont)
    Beans
    755
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: VLC Being a Jerk in 12.04

    For me, it started refusing to enable the swap automatically after I deleted the swap partition and increased the swap partition size.

    It's a known Debian-related issue where changing the swap partition size post-installation results in the OS refusing to enable the swap automatically.

    I always had to do swapon /dev/sda2 after any reboot!

    Confirmed to occur with Squeeze.
    Last edited by RJARRRPCGP; May 4th, 2012 at 03:18 AM.
    Acer Aspire M5630: 1 GB Kingston PC6400 DDR2 SDRAM dual channel (2x512 MB), Core 2 Duo E2180 (2.0 Ghz), Intel i915

  8. #18
    Join Date
    Sep 2011
    Beans
    42

    Re: VLC Being a Jerk in 12.04

    Quote Originally Posted by skeltonh View Post
    You could try:

    sudo add-apt-repository ppa:n-muench/vlc
    sudo apt-get update
    sudo apt-get purge vlc
    sudo apt-get install vlc

    Another problem I found (with corrupted install) is that some instances of Ubuntu does not run a swap device. Usually when you encrypt your home directory at install. Check to see if your swap drive is online.

    swapon -s

    This should show you your swap device and other info. If it is not there you will have to format your swap device then mount it manually. Change your /etc/fstab to reflect the device so that it is mounted on reboot.

    If you have a corrupted install, you may have to reinstall or perform a number of 'sudo apt-get upgrade' and 'sudo apt-get dist-upgrade' to fix your problem.
    My swap drive appears to be in order.

    Tried the VLC commands. Problem persists. It seems to work fine now until I switch to fullscreen.

    Running the sudo apt-get upgrade did some stuff, but I'm too nervous to reboot to see if it fixed anything.

  9. #19
    Join Date
    Jun 2007
    Location
    Iowa
    Beans
    32
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: VLC Being a Jerk in 12.04

    I realize that this thread may be a bit dated but since I found it when trying to resolve my own issue I thought I would post what worked for me so that any others that may stumble upon this can possibly benefit.

    I too was having trouble with VLC freezing when going fullscreen in Ubuntu 12.04. Audio was still working fine and I could move the mouse around but the screen was frozen and I couldn't do anything.

    For what it is worth my video card is a Nvidia GEForce 8300GS and I am using the most current restricted (nvidia) driver.

    I tried a couple of settings for VLC that I had seen in other forums/posts but those did not work for me. Here is what worked for me:

    Running Ubuntu 12.04 (Unity) in 2D mode instead of 3D mode.

    Now VLC plays video files fullscreen without issue. I was not really concerned with losing the 3D features since playing video files was the main purpose for this machine.

    You select 2D mode on the Ubuntu login screen by clicking on the icon in the upper right corner of the password entry window/box.
    In there you can select "Ubuntu 2D". Subsequent system boots will then use 2D mode until changed. (unless you have altered something to prevent this)

  10. #20
    Join Date
    May 2013
    Beans
    1

    Re: VLC Being a Jerk in 12.04

    I guess this helps.
    Open vlc, go to Tools > Preferences > Video > Output, change the Default to X11, save and restart vlc.
    Thanks to timendum
    http://askubuntu.com/questions/25745...ullscreen?rq=1

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •