Results 1 to 7 of 7

Thread: add-apt-repository Exception: NoDistroTemplate

  1. #1
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    2,002
    Distro
    Ubuntu Development Release

    add-apt-repository Exception: NoDistroTemplate

    Code:
    [08:43:34] ahsl@AL-DESK01:[~]: sudo add-apt-repository ppa:nijel/gammu-testing
    [sudo] password for ahsl: 
    You are about to add the following PPA to your system:
     This repository contains latest testing versions of Gammu - <http://wammu.eu/gammu/>.
     More info: https://launchpad.net/~nijel/+archive/gammu-testing
    Press [ENTER] to continue or ctrl-c to cancel adding it
    
    Traceback (most recent call last):
      File "/usr/bin/add-apt-repository", line 160, in <module>
        sp = SoftwareProperties(options=options)
      File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 96, in __init__
        self.reload_sourceslist()
      File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 584, in reload_sourceslist
        self.distro.get_sources(self.sourceslist)    
      File "/usr/lib/python2.7/dist-packages/aptsources/distro.py", line 87, in get_sources
        raise NoDistroTemplateException("Error: could not find a "
    aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template
    I'm assuming this is because we are theoretically running QQ and the PPA goes up to Precise, right?

    Regards,
    Effenberg
    Last edited by effenberg0x0; April 27th, 2012 at 02:49 PM.

  2. #2
    Join Date
    Feb 2007
    Beans
    Hidden!

    Re: add-apt-repository Exception: NoDistroTemplate

    Nope, it's because you haven't updated the distribution template, see
    http://ubuntuforums.org/showpost.php...5&postcount=39

    I've not tested that one but my own and that works for ppa:s too.

  3. #3
    Join Date
    Mar 2007
    Location
    Caprica
    Beans
    2,002
    Distro
    Ubuntu Development Release

    Re: add-apt-repository Exception: NoDistroTemplate

    Quote Originally Posted by Bowmore View Post
    Nope, it's because you haven't updated the distribution template, see
    http://ubuntuforums.org/showpost.php...5&postcount=39

    I've not tested that one but my own and that works for ppa:s too.
    Thanks for the tip Bowmore, I hadn't seen that post. It's fixed.

    Regards,
    Effenberg

  4. #4
    Join Date
    Aug 2006
    Location
    New York City
    Beans
    63
    Distro
    Ubuntu Development Release

    Re: add-apt-repository Exception: NoDistroTemplate

    Shouldn't this be a sticky thread?

  5. #5
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    6,038
    Distro
    Ubuntu Development Release

    Re: add-apt-repository Exception: NoDistroTemplate

    Quote Originally Posted by toobuntu View Post
    Shouldn't this be a sticky thread?

    I put that up in the sudo command sticky. If you know of any other sudo commands that would fit for crash recovery then feel free to put them up there.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  6. #6
    Join Date
    Aug 2009
    Beans
    881
    Distro
    Ubuntu Development Release

    Re: add-apt-repository Exception: NoDistroTemplate

    This happens every release but it should be fixed now:

    https://lists.ubuntu.com/archives/qu...ay/000287.html

  7. #7
    Join Date
    May 2008
    Beans
    1,020

    Re: add-apt-repository Exception: NoDistroTemplate

    Quote Originally Posted by jbicha View Post
    This happens every release but it should be fixed now:

    https://lists.ubuntu.com/archives/qu...ay/000287.html
    IIRC you were following up with eric5 since 12.04. Now that 12.10 is going python3 all the way I think eric( still eric4 in quantal) should be upgraded as well to eric5.?
    OB-untu. #!crunchbang

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •