Page 6 of 10 FirstFirst ... 45678 ... LastLast
Results 51 to 60 of 91

Thread: Wireless not working in Ubuntu 12.04

  1. #51
    Join Date
    Feb 2013
    Beans
    2

    Smile Re: Wireless not working in Ubuntu 12.04

    EDIT :SOLVED IT
    JUST USED SUDO APT-GET UPDATE THEN WAS ABLE TO FIND PROPRIETARY drivers

    I need some help setting up wireless for ubuntu 12.04. I have the 2012 macbookpro, bluetooth and ethernet work fine but wireless doesn't see any networks, how do I install the wireless drivers?
    Last edited by nmushkin; February 17th, 2013 at 07:03 AM.

  2. #52
    Join Date
    Apr 2013
    Beans
    7

    Re: Wireless not working in Ubuntu 12.04

    Hello! My wireless is not working either. I am new to the forums and Linux/Ubuntu, so be gentle haha I believe there are some terminal commands you would like me to run to know what is happening with my system?

  3. #53
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,735
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless not working in Ubuntu 12.04

    Hi, copy and paste this command in the terminal (ctrl+alt+t) please:
    Code:
    wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script
    It will download a script and create a text file in your home folder with wireless information so we can see the condition of your wireless at this time and the Mac address, WPA key and WEP key are removed for your security, then reply back, click on the paper clip and attach the netinfo.txt file.
    Thanks

  4. #54
    Join Date
    Apr 2013
    Beans
    7

    Re: Wireless not working in Ubuntu 12.04

    Per your request
    Attached Files Attached Files

  5. #55
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,735
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless not working in Ubuntu 12.04

    Please do:
    Code:
    sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source
    Code:
    sudo apt-get install linux-firmware-nonfree
    Code:
    sudo modprobe b43
    Then if it does not come on try:
    Code:
    sudo rfkill unblock all
    The wl driver will work with your device but I believe that the b43 driver works better IMO.
    Thanks

  6. #56
    Join Date
    Apr 2013
    Beans
    7

    Re: Wireless not working in Ubuntu 12.04

    I am getting this message for the first two commands:
    Code:
    E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
    and this for the third:
    Code:
    WARNING: /etc/modprobe.d/blacklist.conf line 56: ignoring bad line starting with 'Ic3man07'
    WARNING: /etc/modprobe.d/blacklist.conf line 57: ignoring bad line starting with 'sudo'

  7. #57
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,735
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless not working in Ubuntu 12.04

    This
    E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
    usually means you have like the terminal and software center open at the same time if that is not the case then reboot and it should clear it so you can install the packages.
    Thanks

  8. #58
    Join Date
    Apr 2013
    Beans
    7

    Re: Wireless not working in Ubuntu 12.04

    That was my guess. So I restarted and tried again before posting those messages.

  9. #59
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,735
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless not working in Ubuntu 12.04

    Please start another thread for that issue then come back here and do the commands I posted and you should have wifi.
    Thanks

  10. #60
    Join Date
    Apr 2013
    Beans
    1

    Re: Wireless not working in Ubuntu 12.04

    okay, I'm a new user so forgive me. I've tried everything that has been used in the forums and everywhere else, but I just can't seem to figure out why the internet isn't working properly. Ubuntu wont work, but my windows7 will. This is refering to wireless of course... so I typed in iw config and this is what comes up: Usage: iw [options] commandOptions:
    --debug enable netlink debugging
    --version show version (3.2)
    Commands:
    help
    event [-t] [-r] [-f]
    phy
    list
    phy <phyname> info
    dev
    dev <devname> info
    dev <devname> del
    dev <devname> interface add<name> type <type> [mesh_id <meshid>] [4addron|off] [flags <flag>*]
    phy <phyname> interface add<name> type <type> [mesh_id <meshid>] [4addron|off] [flags <flag>*]
    dev <devname> ibss join <SSID><freq in MHz> [fixed-freq] [<fixed bssid>][beacon-interval <TU>] [basic-rates <rate inMbps,rate2,...>] [mcast-rate <rate in Mbps>] [key d:0:abcde]
    dev <devname> ibss leave
    dev <devname> station dump
    dev <devname> station set <MACaddress> vlan <ifindex>
    dev <devname> station set <MACaddress> plink_action <open|block>
    dev <devname> station del <MACaddress>
    dev <devname> station get <MACaddress>
    dev <devname> survey dump
    dev <devname> mesh leave
    dev <devname> mesh join <meshID> [<param>=<value>]*
    dev <devname> mpath dump
    dev <devname> mpath set<destination MAC address> next_hop <next hop MAC address>
    dev <devname> mpath new<destination MAC address> next_hop <next hop MAC address>
    dev <devname> mpath del <MACaddress>
    dev <devname> mpath get <MACaddress>
    dev <devname> scan [-u] [freq<freq>*] [ies <hex as 00:11:..>] [ssid <ssid>*|passive]
    dev <devname> scan trigger [freq<freq>*] [ies <hex as 00:11:..>] [ssid <ssid>*|passive]
    dev <devname> scan dump [-u]
    reg get
    reg set <ISO/IEC 3166-1 alpha2>
    dev <devname> connect [-w]<SSID> [<freq in MHz>] [<bssid>] [key 0:abcded:1:6162636465]
    dev <devname> disconnect
    dev <devname> link
    dev <devname> offchannel <freq><duration>
    dev <devname> cqm rssi<threshold|off> [<hysteresis>]
    phy <phyname> wowlan show
    phy <phyname> wowlan disable
    phy <phyname> wowlan enable[any] [disconnect] [magic-packet] [gtk-rekey-failure][eap-identity-request] [4way-handshake] [rfkill-release] [patterns<pattern>*]
    dev <devname> roc start <freq><time>
    phy <phyname> set antenna<bitmap> | all | <tx bitmap> <rx bitmap>
    dev <devname> set txpower<auto|fixed|limit> [<tx power in mBm>]
    phy <phyname> set txpower<auto|fixed|limit> [<tx power in mBm>]
    phy <phyname> set distance<distance>
    phy <phyname> set coverage<coverage class>
    phy <phyname> set netns <pid>
    phy <phyname> set rts <rtsthreshold|off>
    phy <phyname> set frag<fragmentation threshold|off>
    dev <devname> set channel<channel> [HT20|HT40+|HT40-]
    phy <phyname> set channel<channel> [HT20|HT40+|HT40-]
    dev <devname> set freq <freq>[HT20|HT40+|HT40-]
    phy <phyname> set freq <freq>[HT20|HT40+|HT40-]
    phy <phyname> set name <newname>
    dev <devname> set peer <MACaddress>
    dev <devname> set 4addr <on|off>
    dev <devname> set type <type>
    dev <devname> set meshid<meshid>
    dev <devname> set monitor<flag>*
    dev <devname> set mesh_param<param>=<value> [<param>=<value>]*
    dev <devname> set power_save<on|off>
    dev <devname> set bitrates[legacy-<2.4|5> <legacy rate in Mbps>*]
    dev <devname> get mesh_param[<param>]
    dev <devname> get power_save<param>


    You can omit the 'phy' or 'dev' if theidentification is unique,
    e.g. "iw wlan0 info" or "iwphy0 info". (Don't when scripting.)


    Do NOT screenscrape this tool, we don'tconsider its output stable.

    I don't know if this helps, but I am getting super frustrated. please help! I have an Asus K501 and I just downloaded the Ubuntu 12.04 I tried uninstalling and reinstalling firefox as well, and now I can't reinstall it lol ugh!!! I don't know what to do!

Page 6 of 10 FirstFirst ... 45678 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •