Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 54

Thread: Ubuntu 12.04 Slow Wireless

  1. #21
    Join Date
    Aug 2009
    Beans
    287

    Re: Ubuntu 12.04 Slow Wireless

    Quote Originally Posted by KYSL View Post
    open terminal and type:
    sudo rmmod iwlwifi
    sudo modprobe iwlwifi 11n_disable=1

    if it works make it permanent by:
    opening/creating /etc/modprobe.d/options.conf and adding the following line
    options iwlwifi 11n_disable=1

    it resolved my issue. In my case in 11.10 the iwlwifi was defined as wilagn.

    it sucks as this issue was known in the previous release and did not get resolved out of the box. Shame on you Ubuntu. Anyway, hope it helps.

    I did this now (with "rmmod brcmsmac" instead")
    it resulted in no wifi anymore, and I cannot load Ubuntu anymore, it stalls in the purple Ubuntu screen. Ubuntu only loads if I disable wifi in the BIOS.

    damn.

    how do I undo this?
    Last edited by TheNessus; May 2nd, 2012 at 09:14 AM.

  2. #22
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Ubuntu 12.04 Slow Wireless

    @ OP

    I use that usb device as well.

    Did it detect it automatically for you or did you have to install drivers?

    I found that when it detected the device automatically for me it was very slow, I used the drivers from here which helped.

    http://www.realtek.com.tw/downloads/...oads=true#2772

    There is an install shell script included in the zip folder.
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

  3. #23
    Join Date
    Oct 2011
    Beans
    8

    Re: Ubuntu 12.04 Slow Wireless

    Quote Originally Posted by TheNessus View Post
    I did this now (with "rmmod brcmsmac" instead")
    it resulted in no wifi anymore, and I cannot load Ubuntu anymore, it stalls in the purple Ubuntu screen. Ubuntu only loads if I disable wifi in the BIOS.

    damn.

    how do I undo this?
    Sorry for the driver conflict that resulted. I am not an expert in these wifi driver but googling the issue i found this post that may help.
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/875892

  4. #24
    Join Date
    Aug 2009
    Beans
    287

    Re: Ubuntu 12.04 Slow Wireless

    Quote Originally Posted by KYSL View Post
    Sorry for the driver conflict that resulted. I am not an expert in these wifi driver but googling the issue i found this post that may help.
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/875892
    It's ok, I solved it. my adapter got blacklisted and I removed it from the list.

    thanks though!

  5. #25
    Join Date
    Aug 2007
    Location
    Belding, MI, USA
    Beans
    42
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Ubuntu 12.04 Slow Wireless

    Quote Originally Posted by chamber View Post
    @ OP

    I use that usb device as well.

    Did it detect it automatically for you or did you have to install drivers?

    I found that when it detected the device automatically for me it was very slow, I used the drivers from here which helped.

    http://www.realtek.com.tw/downloads/...oads=true#2772

    There is an install shell script included in the zip folder.
    they were automatically detected and installed.

    How do I go about installing the drivers from that website?

  6. #26
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Ubuntu 12.04 Slow Wireless

    Download the linux drivers from the website I linked to.

    Extract the drivers and then open a terminal and cd to the extracted folder.

    Once in the extracted folder run

    Code:
    bash install.sh
    This will compile the drivers for you.

    You will be prompted for your root password while it is working.
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

  7. #27
    Join Date
    Feb 2011
    Beans
    3

    Re: Ubuntu 12.04 Slow Wireless

    Quote Originally Posted by wildmanne39 View Post
    Hi, most people have not gotten that driver to work at all I believe, please post the output of:
    Code:
    cat /etc/lsb-release; uname -a
    lspci -nnk | grep -iA2 net
    lsusb
    iwconfig
    rfkill list all
    lsmod
    nm-tool
    here by clicking on new reply and click # and paste the information between the brackets.
    Thank you
    Code:
    cat /etc/lsb-release; uname -a
    
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04 LTS"
    Linux GarryHP 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    Code:
    lspci -nnk | grep -iA2 net
    
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
        Subsystem: Hewlett-Packard Company Device [103c:146a]
        Kernel driver in use: r8169
    --
    02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1000 [8086:0084]
        Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN [8086:1315]
        Kernel driver in use: iwlwifi
    Code:
    lsusb
    
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 003: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver
    Bus 001 Device 004: ID 138a:0005 Validity Sensors, Inc. VFS301 Fingerprint Reader
    Bus 002 Device 004: ID 10f1:1a28 Importek
    Code:
    iwconfig
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:"(hide from view)"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: 68:7F:74:2C:08:46   
              Bit Rate=1 Mb/s   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=35/70  Signal level=-75 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:1304  Invalid misc:122   Missed beacon:0
    
    eth0      no wireless extensions.
    Code:
    rfkill list all
    
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: hp-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    Code:
    lsmod
    
    Module                  Size  Used by
    snd_hda_codec_hdmi     32474  1 
    snd_hda_codec_idt      70795  1 
    bnep                   18281  2 
    rfcomm                 47604  0 
    bluetooth             180104  10 bnep,rfcomm
    parport_pc             32866  0 
    ppdev                  17113  0 
    arc4                   12529  2 
    hp_wmi                 18092  0 
    sparse_keymap          13890  1 hp_wmi
    joydev                 17693  0 
    uvcvideo               72627  0 
    snd_hda_intel          33773  3 
    snd_hda_codec         127706  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
    psmouse                87603  0 
    videodev               98259  1 uvcvideo
    snd_hwdep              13668  1 snd_hda_codec
    v4l2_compat_ioctl32    17128  1 videodev
    serio_raw              13211  0 
    snd_pcm                97188  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    usbhid                 47199  0 
    hid                    99559  1 usbhid
    snd_seq_midi           13324  0 
    wmi                    19256  1 hp_wmi
    snd_rawmidi            30748  1 snd_seq_midi
    iwlwifi               328352  0 
    mac80211              506816  1 iwlwifi
    mac_hid                13253  0 
    hp_accel               25976  0 
    lis3lv02d              19876  1 hp_accel
    input_polldev          13896  1 lis3lv02d
    snd_seq_midi_event     14899  1 snd_seq_midi
    snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
    cfg80211              205544  2 iwlwifi,mac80211
    intel_ips              18089  0 
    snd_timer              29990  2 snd_pcm,snd_seq
    i915                  468651  3 
    snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
    drm_kms_helper         46978  1 i915
    drm                   242038  4 i915,drm_kms_helper
    mei                    41616  0 
    snd                    78855  16 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    i2c_algo_bit           13423  1 i915
    video                  19596  1 i915
    soundcore              15091  1 snd
    lp                     17799  0 
    snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
    parport                46562  3 parport_pc,ppdev,lp
    r8169                  62099  0
    Code:
    nm-tool
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: wlan0  [(hide from view)] --------------------------------
      Type:              802.11 WiFi
      Driver:            iwlwifi
      State:             connected
      Default:           yes
      HW Address:        00:26:C7:8C:1A:E8
    
      Capabilities:
        Speed:           1 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        
        *(hide from view): Infra, 68:7F:74:2C:08:46, Freq 2412 MHz, Rate 54 Mb/s, Strength 57 WEP
        
    
      IPv4 Settings:
        Address:         192.168.1.107
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.1.1
    
        DNS:             192.168.1.1
        DNS:             64.71.255.198
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            r8169
      State:             unavailable
      Default:           no
      HW Address:        (hide from view)
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    Thanks!

  8. #28
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,912
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.04 Slow Wireless

    Hi, please copy and paste the commands one line at a time:
    Code:
    echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
    sudo modprobe -rfv iwlwifi
    sudo modprobe -v iwlwifi
    Thanks

  9. #29
    Join Date
    Feb 2011
    Beans
    3

    Re: Ubuntu 12.04 Slow Wireless

    THANKS!

    it works!! this problem bothered me for quite a long time!

    In addition, why removing iwlwifi module would make it work?

    Thank you again!

  10. #30
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,912
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 12.04 Slow Wireless

    Hi, your welcome! you removed the module but loaded it again with a parameter that turned off N speed because N speed does not work well in linux with intel drivers.
    Thanks
    Last edited by Wild Man; July 4th, 2012 at 01:11 AM.

Page 3 of 6 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •