Page 8 of 12 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 117

Thread: winepulse in ubuntu wine ppa

  1. #71
    Join Date
    Oct 2012
    Beans
    8

    Re: winepulse in ubuntu wine ppa

    Hi there,

    since the update to wine 1.5.16 I can't start programs that are using dsound any more.
    It is completely independent from the program as long as it is using dsound and they all crashing with the same error:

    Code:
    fixme:winediag:AUDDRV_GetAudioEndpoint Winepulse is not officially supported by the wine project
    fixme:winediag:AUDDRV_GetAudioEndpoint For sound related feedback and support, please visit http://ubuntuforums.org/showthread.php?t=1960599
    fixme:dsound:DSOUND_WaveFormat Limiting channels to 2 due to lack of multichannel support
    err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
    Assertion 'pa_atomic_load(&(b)->_ref) > 0' failed at pulsecore/memblock.c:590, function pa_memblock_unref(). Aborting.
    If I start them with WINENOPULSE=1 they work as expected and they also worked with wine 1.5.15. So it seams to me that there is something broken with the wine pulse audio support in the latest wine from the ppa.

    Hopefully this can be fixed.

  2. #72
    Join Date
    Dec 2006
    Beans
    42

    Re: winepulse in ubuntu wine ppa

    I'm surprised you're hitting that bug. Can you tell me what release you're on and what distribution?

    This is a really old pulseaudio bug, and can be fixed by applying http://cgit.freedesktop.org/pulseaud...5857fe0887de22 to your pulseaudio sources, which will fix the bug. Make sure that if you're on a 32 + 64-bits system to get both libraries patched, as it's a client a lib issue..

    I've been wanting to sru this to precise, but I wasn't able to reproduce the bug any more, but I know that commit fixes it since I hit the issue before myself. So if you're on precise let me know and I'll talk to the pulseaudio maintainer in ubuntu this week about sru'ing it after all.

    ~Maarten

  3. #73
    Join Date
    Oct 2012
    Beans
    8

    Re: winepulse in ubuntu wine ppa

    I'm surprised you're hitting that bug. Can you tell me what release you're on and what distribution?
    I'm currently running a fully patched Kubuntu 12.04 64bit.
    The package manager reports
    Code:
       pulseaudio           1:1.1-0ubuntu15.1
       libpulse0            1:1.1-0ubuntu15.1
       libpulse0:i386       1:1.1-0ubuntu15.1
       wine1.5              1.5.16-0ubuntu1  
       wine1.5-amd64        1.5.16-0ubuntu1
       wine1.5-i386:i386    1.5.16-0ubuntu1
    as being installed and being the latest available version of those packages.

    This is a really old pulseaudio bug, and can be fixed by applying http://cgit.freedesktop.org/pulseaud...5857fe0887de22 to your pulseaudio sources, which will fix the bug. Make sure that if you're on a 32 + 64-bits system to get both libraries patched, as it's a client a lib issue..

    I've been wanting to sru this to precise, but I wasn't able to reproduce the bug any more, but I know that commit fixes it since I hit the issue before myself. So if you're on precise let me know and I'll talk to the pulseaudio maintainer in ubuntu this week about sru'ing it after all.
    Before I'm going into the trouble and start cross-compiling the 32bit pulse audio library on my 64bit machine, I would like to wait for the response from the pulse audio package maintainer. So it would be kind of you if you could contact him and let me know his response.

    Falk

  4. #74
    Join Date
    Oct 2011
    Location
    London, UK
    Beans
    40
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: winepulse in ubuntu wine ppa

    The old version of the pulse server isnt great with wine. The 2.0 version with the audio-dev ppa works a lot better on 12.04 - 12.10 has the newer one and works nicely.

  5. #75
    Join Date
    Dec 2006
    Beans
    42

    Re: winepulse in ubuntu wine ppa

    Looks like the precise pulseaudio already had that commit backported after all, so dont bother trying it yourself.

    Either the backport didn' t fix it or you' re hitting another pulse issue specific to precise. Either way there's not much I can do right now, it looks like there is a workaround by using the mentioned ppa, so you can try that. Hopefully I'll have some time next week to look at it in more detail.
    Last edited by vladdy; October 30th, 2012 at 11:28 PM.

  6. #76
    Join Date
    Oct 2012
    Beans
    8

    Re: winepulse in ubuntu wine ppa

    I just wanted to let you know, I just installed pulse audio from the audio dev ppa, as suggested by father_ted.

    I have now installed:
    Code:
    libpulse0         1:2.0-0ubuntu1~precise2
    libpulse0:i386    1:2.0-0ubuntu1~precise2
    pulseaudio        1:2.0-0ubuntu1~precise2
    which seams to be the latest available versions for precise and it didn't solve the problem. I still get

    Code:
    Assertion 'pa_atomic_load(&(b)->_ref) > 0' failed at pulsecore/memblock.c:590, function pa_memblock_unref(). Aborting.
    So the workaround didn't work for me.

    Falk

  7. #77
    Join Date
    Oct 2012
    Beans
    8

    Re: winepulse in ubuntu wine ppa

    Ok another short update.

    I was able to pinpoint a pulseaudio option that directly triggers the bug.

    In my /etc/pulse/default.pa config I have set the option

    Code:
    load-module module-udev-detect tsched=0
    to workaround another bug which results in distorted sound on my system.

    I changed this option to the default configuration that comes with ubuntu (tsched=1) "est volia" the wine bug is gone. (But the distorted sound is back)
    After reseting this option back to tsched=0 again the wine bug was back.

    So vladdy if you are going to investigate the bug, don't forget to temporarily turn off the timer based and re-enable the old interrupt based scheduling in pulseaudio.

    Falk

  8. #78
    Join Date
    Dec 2006
    Beans
    42

    Re: winepulse in ubuntu wine ppa

    Still can't reproduce it after downgrading to old pulseaudio. Is there anything special about your config? What programs are you trying?

  9. #79
    Join Date
    Apr 2008
    Location
    Columbia, SC
    Beans
    282

    Re: winepulse in ubuntu wine ppa

    FWIW, when I have problems with audio in Wine, closing the program in question and doing pulseaudio -k then re-running the program gets them sorted out.

    This also fixes a really annoying bug in Chrome/Chromium where YouTube videos play on full-on fast-forward for no apparent reason. So it seems like there's a bug upstream in Pulse IMO.

  10. #80
    Join Date
    Oct 2012
    Beans
    8

    Re: winepulse in ubuntu wine ppa

    Hi vladdy,
    I don't think that there is something special within my config besides the already mentioned tshed=0 option.
    I've just appended my pulse audio config to this post, so you can compare it to yours and see if I missed something special.
    Within the tar you will also find a trace with +dsound,+pulse which may help you to find the problem.

    Concerning the Programs which are failing:

    For example every Game I try to run fails with the same error. They all worked without any problems in wine 1.5.15 and pulse audio and they still work fine if I use wine 1.5.16 without pulse audio.

    Need for Speed Most Wanted (the original)
    Battlefield 2
    World in conflict
    Prince of Persia WW

    just to name a few.

    Falk

    P.S.
    I tried the pulseaudio -k trick and it does not improve the situation.
    Attached Files Attached Files

Page 8 of 12 FirstFirst ... 678910 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •