Page 8 of 12 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 119

Thread: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

  1. #71
    Join Date
    Dec 2012
    Beans
    9

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Quote Originally Posted by chili555 View Post
    Please refer to your own thread where I answered.
    Thanks for quick response. It did not work.
    I tried the codes that you recommended.
    sudo apt-get remove --purge bcmwl-kernel-source sudo apt-get install linux-firmware-nonfree sudo modprobe b43
    this is what I got.
    rakesh@rakesh-C-Notebook-XXXX:~$ sudo apt-get remove --purge bcmwl-kernel-source
    [sudo] password for rakesh:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic-pae dkms
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    bcmwl-kernel-source*
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    After this operation, 3,252 kB disk space will be freed.
    Do you want to continue [Y/n]? Y
    (Reading database ... 170903 files and directories currently installed.)
    Removing bcmwl-kernel-source ...
    Removing all DKMS Modules
    Done.
    update-initramfs: deferring update (trigger activated)
    Purging configuration files for bcmwl-kernel-source ...
    update-initramfs: deferring update (trigger activated)
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-3.2.0-34-generic-pae

    rakesh@rakesh-C-Notebook-XXXX:~$ sudo apt-get install linux-firmware-nonfree
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    linux-firmware-nonfree is already the newest version.
    The following packages were automatically installed and are no longer required:
    linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic-pae dkms
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    rakesh@rakesh-C-Notebook-XXXX:~$ sudo modprobe b43
    (showed nothing)
    rakesh@rakesh-C-Notebook-XXXX:~$

    Please Help.

  2. #72
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,223
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Please Help.
    Sir or madam: I am answering in your own thread and not here. I am not going to answer every question twice and you needn't ask twice.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #73
    Join Date
    Feb 2013
    Beans
    3

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Hi, chili555,

    I have a very strange problem with my acer aspire 3750G. I have two routers at home, it can connect to one router (belkin), but not the other (huawei), could you please help me see if there's anything wrong with my wireless?

    Code:
    bingtian@aspire3750G:~$ dmesg | grep iwl
    bingtian@aspire3750G:~$ rfkill list all
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: acer-wireless: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    2: acer-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
    3: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    Does the sequence matter? original order was 1,2,0,3, but i did some modprobe, and but acer-wsi in blacklist once.

    Code:
    bingtian@aspire3750G:~$ lsmod | grep acer
    acer_wmi               28418  0
    sparse_keymap          13890  1 acer_wmi
    wmi                    19256  2 acer_wmi,mxm_wmi
    bingtian@aspire3750G:~$ dmesg | grep ath
    [   57.880056] ath9k 0000:0d:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [   57.880071] ath9k 0000:0d:00.0: setting latency timer to 64
    [   57.969810] ath: EEPROM regdomain: 0x65
    [   57.969812] ath: EEPROM indicates we should expect a direct regpair map
    [   57.969814] ath: Country alpha2 being used: 00
    [   57.969816] ath: Regpair used: 0x65
    [   57.973062] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
    [   57.973458] Registered led device: ath9k-phy0
    [   58.126080] usbcore: registered new interface driver ath3k
    Is there any problem? Thank you. I can provide more info on how the two routers are configured. Thanks.

    Quote Originally Posted by chili555 View Post
    Please open a terminal and run and post:
    Code:
    dmesg | grep iwl
    rfkill list all
    The pipe symbol | is on the right side of my US keyboard on the same key with \. Thanks.

  4. #74
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,223
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    I can provide more info on how the two routers are configured.
    Please do. You might try a temporary driver parameter:
    Code:
    sudo modprobe -r ath9k
    sudo modprobe ath9k btcoex_enable=1
    If it helps, we can write one quick file to make it persistent.

    Please post:
    Code:
    nm-tool
    Tell us which two access points you are trying to connect to.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #75
    Join Date
    Feb 2013
    Beans
    3

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Hi, chili,

    Thank you so much for your reply, and sorry for the late reply as now both networks do not work for my ubuntu, so I come up online from the other computer.

    The two networks are configured like this: one network is a subnet of the other. I name the larger one CO and the subnet ES, they are connected through home plug: ES's uplink is from CO LAN port. CO is configured with 192.168.64.* (gateway at 192.168.64.1, mask 255.255.240.0), ES is configured with 192.168.66.* (gateway at 192.168.66.1, mask 255.255.255.0). So the gateway for ES router is set at 192.168.64.1. This configuration works, as my notebook connect to ES in the bedroom and connects to CO at the living room.

    So I paste the outcome after doing "modprobe -r ath9k" and "modprobe ath9k btcoex_enable=1", for CO first, then ES.

    Code:
    bingtian@aspire3750G:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr e0:69:95:2a:04:68  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:50 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:2184 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2184 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:153869 (153.8 KB)  TX bytes:153869 (153.8 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 88:9f:fa:a2:ac:b1  
              inet addr:192.168.64.31  Bcast:192.168.79.255  Mask:255.255.240.0
              inet6 addr: fe80::8a9f:faff:fea2:acb1/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:24896 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16353 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:29281747 (29.2 MB)  TX bytes:1778517 (1.7 MB)
    
    bingtian@aspire3750G:~$ ping 192.168.64.1
    PING 192.168.64.1 (192.168.64.1) 56(84) bytes of data.
    ^C
    --- 192.168.64.1 ping statistics ---
    19 packets transmitted, 0 received, 100% packet loss, time 18143ms
    
    bingtian@aspire3750G:~$ nm-tool
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: wlan0  [CO] -----------------------------------------
      Type:              802.11 WiFi
      Driver:            ath9k
      State:             connected
      Default:           yes
      HW Address:        88:9F:FA:A2:AC:B1
    
      Capabilities:
        Speed:           13 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      IPv4 Settings:
        Address:         192.168.64.31
        Prefix:          20 (255.255.240.0)
        Gateway:         192.168.64.1
    
        DNS:             192.168.64.1
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            atl1c
      State:             unavailable
      Default:           no
      HW Address:        E0:69:95:2A:04:68
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    I have IP but cannot even ping the gateway, which is very strange. Now I disconnect CO and connect to ES

    Code:
    bingtian@aspire3750G:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr e0:69:95:2a:04:68  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:50 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:3788 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3788 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:260111 (260.1 KB)  TX bytes:260111 (260.1 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 88:9f:fa:a2:ac:b1  
              inet addr:192.168.66.84  Bcast:192.168.66.255  Mask:255.255.255.0
              inet6 addr: 2002:c0a8:4002:1234:8a9f:faff:fea2:acb1/64 Scope:Global
              inet6 addr: fe80::8a9f:faff:fea2:acb1/64 Scope:Link
              inet6 addr: 2002:c0a8:4002:1234:5df7:a9a4:e7f9:6781/64 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:33 errors:0 dropped:0 overruns:0 frame:0
              TX packets:100 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:5120 (5.1 KB)  TX bytes:17861 (17.8 KB)
    
    bingtian@aspire3750G:~$ ping 192.168.66.1
    PING 192.168.66.1 (192.168.66.1) 56(84) bytes of data.
    64 bytes from 192.168.66.1: icmp_req=1 ttl=64 time=126 ms
    64 bytes from 192.168.66.1: icmp_req=2 ttl=64 time=26.9 ms
    ^C
    --- 192.168.66.1 ping statistics ---
    3 packets transmitted, 2 received, 33% packet loss, time 2002ms
    rtt min/avg/max/mdev = 26.975/76.915/126.856/49.941 ms
    bingtian@aspire3750G:~$ nm-tool 
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: wlan0  [ES] ------------------------------------------
      Type:              802.11 WiFi
      Driver:            ath9k
      State:             connected
      Default:           yes
      HW Address:        88:9F:FA:A2:AC:B1
    
      Capabilities:
        Speed:           243 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      IPv4 Settings:
        Address:         192.168.66.84
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.66.1
    
        DNS:             192.168.66.1
        DNS:             192.168.64.1
    
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            atl1c
      State:             unavailable
      Default:           no
      HW Address:        E0:69:95:2A:04:68
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    Please advise, thank you!

  6. #76
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,223
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    I don't think you have a wireless card problem at all. I think you have a gateway, subnet, too-many-routers problem. I don't know how to fix this:
    wlan0 Link encap:Ethernet HWaddr 88:9f:fa:a2:ac:b1
    inet addr:192.168.64.31 Bcast:192.168.79.255 Mask:255.255.240.0
    inet6 addr: fe80::8a9f:faff:fea2:acb1/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    It may be solvable and it may be fine but I just am inexperienced in such complications. I suggest you start your own new thread and refer to your setup in detail and ask for an answer. I don't have it.

    I wish I could be of more help.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #77
    Join Date
    Feb 2013
    Beans
    3

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Hi, chili, thank you for your answer, I suspect it's the router problem too, but windows and androids are fine with the setting since Bcast:192.168.79.255 (11000000.10101000.01001111.11111111) & Mask:255.255.240.0 (11111111.11111111.11110000.00000000) = subnet:192.168.64.0 (11000000.10101000.01000000.0)

  8. #78
    Join Date
    Mar 2013
    Location
    Czech Republic
    Beans
    188
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Hi, I have problem with my wifi connection too. When I try to connect to my wifi, it writes: "Wireless connection established", but when I try to load a page in default browser, it says: "Server not found".
    I'm using Xubuntu 12.10 and before i had installed Windows 8 and the wifi worked fine.
    (I have Asus-X201E-kx006h)
    I've run some diagnostic:
    Code:
    vilix@vilix-X201EP:~$ sudo ufw status
    [sudo] password for vilix: 
    Status: inactive
    Code:
    vilix@vilix-X201EP:~$ dmesg | grep iwl
    vilix@vilix-X201EP:~$ rfkill list all
    0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
    1: asus-wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    2: asus-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
    3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    Code:
    vilix@vilix-X201EP:~$ iwconfig
    lo        no wireless extensions.
    wlan0   IEEE 802.11bgn  ESSID:"Wifinka"
              Mode:Managed  Frequency:2.462 GHz  Access Point: C8:6C:87:F3:D2:E0
              Bit Rate=13.5 Mb/s   Tx-Power=16 dBm  
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=45/70  Signal level=-65 dBm 
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Code:
    vilix@vilix-X201EP:~$ lsmod | grep asus 
    asus_nb_wmi        12710      0
    asus_wmi             24088      1  asus_nb_wmi
    sparse_keymap      13890      1  asus_wmi   
    wmi                     19070      1  asus_wmi
    Thank you for every help..

  9. #79
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,223
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Quote Originally Posted by ViliX64 View Post
    Hi, I have problem with my wifi connection too. When I try to connect to my wifi, it writes: "Wireless connection established", but when I try to load a page in default browser, it says: "Server not found".
    I'm using Xubuntu 12.10 and before i had installed Windows 8 and the wifi worked fine.
    (I have Asus-X201E-kx006h)
    .
    We would also love to see:
    Code:
    iwconfig
    lspci -nn | grep 0280
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #80
    Join Date
    Mar 2013
    Location
    Czech Republic
    Beans
    188
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Lenovo IdeaPad Z570-1024D9U - Laptop (Wireless Help)

    Here it is:

    Code:
    vilix@vilix-X201EP:~$ iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:"Wifinka"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: C8:6C:87:F3:D2:E0   
              Bit Rate=108 Mb/s   Tx-Power=16 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=48/70  Signal level=-62 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    vilix@vilix-X201EP:~$ lspci -nn | grep 0280
    02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)

Page 8 of 12 FirstFirst ... 678910 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •