Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Power Consumption related to desktop environment

  1. #11
    Join Date
    Jan 2008
    Beans
    86

    Re: Power Consumption related to desktop environment

    I do get direct rendering: yes from glxinfo. glxinfo | grep opengl returns:

    Code:
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
    OpenGL version string: 3.0 Mesa 8.0.2
    OpenGL shading language version string: 1.30
    OpenGL extensions:
    ...so it seems like OpenGL is at least being loaded properly. Are there any basic/very compatible OpenGL games/tests I can install and run quickly?

    Edit: Also, mesa-utils was not installed on my machine and I had to install that to run glxinfo. Not sure if that tells you anything.

  2. #12
    Join Date
    Feb 2009
    Location
    USA
    Beans
    3,187

    Re: Power Consumption related to desktop environment

    mesa-utils is just a few helper apps, not the OpenGL itself. It seems that OpenGL is up and running, now the issue may be with a bug in the game or maybe SandyBridge isn't powerful enough to render this particular game.

    Try running the glxgears, with VSync enabled you should get at least 50 - 60 FPS, without it, you should something in the thousands.

  3. #13
    Join Date
    Jan 2008
    Beans
    86

    Re: Power Consumption related to desktop environment

    glxgears runs at ~59.8 FPS with Vsync on, but I don't know how to disable Vsync. However, I believe this is a problem with the game itself. I was able to run Skulltag, which is another engine based on Gzdoom, with the OpenGL renderer with no problem. I was also able to run Darkplaces, which is an OpenGL Quake engine that is much more demanding, with no issue. I'll take this over to the gzdoom forums. Thanks again.

  4. #14
    Join Date
    Feb 2009
    Location
    USA
    Beans
    3,187

    Re: Power Consumption related to desktop environment

    Quote Originally Posted by raptir View Post
    glxgears runs at ~59.8 FPS with Vsync on, but I don't know how to disable Vsync. However, I believe this is a problem with the game itself. I was able to run Skulltag, which is another engine based on Gzdoom, with the OpenGL renderer with no problem. I was also able to run Darkplaces, which is an OpenGL Quake engine that is much more demanding, with no issue. I'll take this over to the gzdoom forums. Thanks again.
    59.8 is what you should get with Vsync, things are working right it seems.

    If you have no more questions, you can mark this thread as "Solved".

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •