Code:
alex@griever:~/Videos$ mencoder Immortals.2011.720p.BRRip.x264-x0r.mkv -ovc xvid -xvidencopts bitrate:800 -oac copy -o Immortals-2011-720-.avi
and here's the output:

MEncoder svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
Error parsing option on the command line: -xvidencopts
I also tried this:

Code:
alex@griever:~/Videos$ mencoder Immortals.2011.720p.BRRip.x264-x0r.mkv -ovc xvid bitrate:800 -oac copy -o Immortals-2011-720-.avi
and got the following:
MEncoder svn r34540 (Ubuntu), built with gcc-4.6 (C) 2000-2012 MPlayer Team
success: format: 0 data: 0x0 - 0x7a1b4576
libavformat version 53.21.0 (external)
Mismatching header version 53.19.0
libavformat file format detected.
[matroska,webm @ 0xb6b91d80]max_analyze_duration reached
[matroska,webm @ 0xb6b91d80]Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (ac3), -aid 0, -alang eng
[lavf] stream 2: subtitle (text), -sid 0, -slang eng
VIDEO: [H264] 1280x690 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:44 fourcc:0x34363248 size:1280x690 fps:23.976 ftime:=0.0417
xvid: using library version 1.3.2 (build xvid-1.3.2)
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
================================================== ========================
audiocodec: framecopy (format=2000 chans=6 rate=48000 bits=0 B/s=56000 sample-0)
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Unsupported PixelFormat 81
Pos: 0.0s 2f ( 0%) 0.00fps Trem: 0min 0mb A-V:0.004 [0:0]
Movie-Aspect is 1.86:1 - prescaling to correct movie aspect.
videocodec: XviD (1280x690 fourcc=44495658 [XVID])
xvid: par=0/0 (vga11), displayed=1280x690, sampled=1280x690
xvid: you must specify one or a valid combination of 'bitrate', 'pass', 'fixed_quant' settings
FATAL: Cannot initialize video driver.
Please help correct my code?